transmission crashed with SIGSEGV in g_closure_invoke()

Bug #334104 reported by RuiDC on 2009-02-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Transmission
Fix Released
Unknown
transmission (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: transmission

Had just clicked on the flashing window from a completion when it crashed.

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/transmission
Package: transmission-gtk 1.42-0ubuntu1
ProcCmdline: transmission
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: transmission
StacktraceTop:
 ?? ()
 ?? () from /usr/lib/libdbus-glib-1.so.2
 g_closure_invoke ()
 ?? () from /usr/lib/libgobject-2.0.so.0
 g_signal_emit_valist ()
Title: transmission crashed with SIGSEGV in g_closure_invoke()
Uname: Linux 2.6.28-8-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

RuiDC (ruidc) wrote :

StacktraceTop:marshal_dbus_message_to_g_marshaller (
IA__g_closure_invoke (closure=0x1e9a0b0,
signal_emit_unlocked_R (node=0x1691960, detail=663,
IA__g_signal_emit_valist (instance=0x1678230,
IA__g_signal_emit (instance=0x7f1d24069a40,

Changed in transmission:
importance: Undecided → Medium
Hew (hew) wrote :

Thanks for your report. Does the problem still exist with Ubuntu Jaunty and transmission 1.51-0ubuntu1?

Changed in transmission:
status: New → Incomplete
RuiDC (ruidc) wrote :

the bug has only happened on jaunty and the older version of transmission.

As the fault is not easily reproducible, i have not had it on 1.51.

Charles Kerr (charlesk) wrote :

I'm not exactly sure *how* it happened -- I think that part may be fixed in newer releases --
but looking at the stack trace, it's clearly a crash being caused by dereferencing a null
pointer:

> #0 notifyCallback (n=<value optimized out>, action=<value optimized out>,
> gdata=<value optimized out>) at notify.c:54
> tor = (tr_torrent *) 0x0
> info = (const tr_info *) 0x0

and, a few lines later, we have this:

> char * path = g_build_filename( dir, info->files[0].name, NULL );

We can prevent the crash by adding some NULL safeguards.

Changed in transmission (Ubuntu):
status: Incomplete → Confirmed
Charles Kerr (charlesk) wrote :

Fix committed upstream in r8670 for 1.72

Changed in transmission:
status: Unknown → Fix Released
RuiDC (ruidc) wrote :

thanks, am using deluge ATM, but will return one day to re-evaluate.

Regards,
Rui

Charles Kerr (charlesk) wrote :

:)

Changed in transmission (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.72-1ubuntu1

---------------
transmission (1.72-1ubuntu1) karmic; urgency=low

  * Merge from debian unstable (LP: #388377), remaining changes:
    - debian/control:
      + Added replaces & provides clutch (now included as part of transmission).
      + add quilt, liblaunchpad-integration and libtool to Build-Depends
    - debian/rules:
      + Create a PO template during package build.
      + re-enable quilt
      + run autoreconf for launchpad-integration
    - debian/patches/01_lpi.patch:
      + Integrate Transmission with Launchpad
    - debian/patches/20_add_X-Ubuntu-Gettext-Domain.diff:
      + Add X-Ubuntu-Gettext-Domain to .desktop file.
  * Closes Launchpad bugs:
    - Use tooltip to notify user of added torrent (LP: #217171)
    - Transmission forgets torrent when adding several (LP: #259123)
    - Unable to sort files in torrent by Progress, Download nor Priority.
      (LP: #300359)
    - "Revert" and "Remove" uses same alt-key in Torrent Tracker Details
      (LP: #311064)
    - transmission crashed with SIGSEGV in g_closure_invoke() (LP: #334104)
    - Bring transmission to the top when adding a torrent (LP: #353777)
    - Focus should not be on "Don't ask me again" when I quit Transmission
      (LP: #359268)
    - [karmic] removing download items makes property window useless
      (LP: #385334)
    - transmission doesn't remember maximized state (LP: #385982)
    - Transmission 1.71 (8646) crashes when changing download speed
      (LP: #386877)
    - transmission: event.c:875: timeout_next: Assertion `tv->tv_usec >= 0'
      failed. (LP: #387564)

transmission (1.72-1) unstable; urgency=low

  * new upstream release: (closes:#533423)
    - Can now sort the file list by priority, download, and completeness
      (closes: #517872)
    - fixed race condition adding file from browser (closes: #500195)
  * debian/control: policy 3.8.2 (no changes)

 -- Krzysztof Klimonda <email address hidden> Tue, 16 Jun 2009 02:41:48 +0200

Changed in transmission (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.