Ubuntu

gnome session termination isn't handled properly

Reported by Ric Flomag on 2008-12-13
82
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Transmission
New
Unknown
transmission (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: transmission

Steps to reproduce:
* have any downloading torrent(s) with transmission
* log out, or restart computer without previously exiting transmission
* log in and start transmission

Observed behavior: Transmission verifies all incomplete downloaded data before going on with the download.

Expected behavior: On logout, transmission should normally exit and on next start should not verify data and go on with downloading immediately.

This is on Ubuntu Intrepid, but I've observed this bug as far as i remember.

Duane Hinnen (duanedesign) wrote :

Thank you for taking the time to make Ubuntu better. Since what you submitted is a Feature Request to improve Ubuntu, you are invited to post your idea in Ubuntu Brainstorm at [WWW] https://brainstorm.ubuntu.com/ where it can be discussed, voted by the community and reviewed by developers. Thanks for taking the time to share your opinion!

Changed in transmission:
status: Unknown → New
Changed in transmission:
status: New → Confirmed
Daniel T Chen (crimsun) on 2008-12-28
Changed in transmission:
importance: Undecided → Wishlist
Chris Halse Rogers (raof) wrote :

What version of Ubuntu is this on? If it's on Intrepid (8.10) or Jaunty, then there's a major regression in the way gnome-session handles logouts, which results in (almost) all running programs simply being killed rather than asked to quit nicely.

This looks like it could be a symptom of that bug.

Changed in transmission:
status: Confirmed → Incomplete
Ric Flomag (ricflomag) wrote :

The bug is present my dos computer usding Intrepid and gutsy, and was present when i used Hardy too.

Ric Flomag (ricflomag) wrote :

Read "on both of my computers", not "my dos computer usding":

The bug is present on both of my computers using Intrepid and gutsy, and was present when i used Hardy too.

 I should never comment a bug before breakfast ;)

Changed in transmission:
status: Incomplete → New
Hew McLachlan (hew) on 2009-02-28
Changed in transmission:
status: New → Triaged
Charles Kerr (charlesk) on 2009-06-29
summary: - Transmission should not verify all data when restarted after forced exit
- by logout
+ gnome session termination isn't handled properly
LAZA (laza74) wrote :

It's not only when I close the GNOME session but also if I 'pause all', wait till all the transfer stops, close the session and come later back to it...
But it seems not every time so it's hard to say whats the trigger that causes the problem...

Ubuntu 9.04
Kernel 2.6.28-13-generic

LAZA (laza74) wrote :

...and also when I switch to another login with fast-switch-applet and then come back...

Charles Kerr (charlesk) wrote :

Yeah, this is a wider problem with Gnome in general.

See the comments in upstream ticket http://bugzilla.gnome.org/show_bug.cgi?id=79285

LAZA (laza74) wrote :

I have the problem also in GNOME 2.28.1 / Ubuntu 9.10 RC...

Charles Kerr (charlesk) on 2010-02-08
Changed in transmission (Ubuntu):
status: Triaged → Confirmed
Charles Kerr (charlesk) wrote :

Just to check in on this ticket -- the problem hasn't been forgotten. However it still hasn't been resolved upstream in GTK+:

https://bugzilla.gnome.org/show_bug.cgi?id=79285#c35

Ric Flomag (ricflomag) wrote :

Fixed in Oneiric, though the associated external bugs don't show any change in status.

Changed in transmission (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.