transmission crashed with SIGSEGV in g_markup_escape_text()

Bug #274844 reported by Korzyuk on 2008-09-26
106
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Transmission
Fix Released
Unknown
transmission (Ubuntu)
Medium
Unassigned
Intrepid
Medium
Unassigned

Bug Description

Binary package hint: transmission

transmission 1.34 (ubuntu 8.10)

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/transmission
NonfreeKernelModules: wl
Package: transmission-gtk 1.34-0ubuntu1
ProcAttrCurrent: unconfined
ProcCmdline: transmission
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: transmission
StacktraceTop:
 g_markup_escape_text () from /usr/lib/libglib-2.0.so.0
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
 g_object_set_valist () from /usr/lib/libgobject-2.0.so.0
 g_object_set () from /usr/lib/libgobject-2.0.so.0
 gtk_widget_set_tooltip_text ()
Title: transmission crashed with SIGSEGV in g_markup_escape_text()
Uname: Linux 2.6.27-4-generic i686
UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare

Korzyuk (evgeniy-korzyuk) wrote :
Changed in transmission:
status: Unknown → Fix Released
Changed in transmission:
importance: Undecided → Medium
status: New → Triaged
Drolyk (drolyk) wrote :

confirm here. I`ve got the same error on ubuntu 8.10 amd64

There seem to be quite a few people experiencing this one. It might be worth back-porting the fix from the upstream svn. Unfortunately, the fix doesn't apply cleanly to the Ubuntu version.

Here is the commit.

way-out (mmc48) wrote :

Have this error too. When tried to minimize by pressing close button

I had the same problem in Ubuntu 8.10 amd64...

Charles Kerr (charlesk) wrote :
John Dong (jdong) wrote :

Hey Charles,

With Intrepid release candidate images already in progress, I don't think this bug is a blocker to the release (unless I'm misunderstanding how often this would happen on average) -- would you be okay for punting this off as a StableReleaseUpdate after Intrepid ships?

debdiff aimed at intrepid proposed

Charles Kerr (charlesk) wrote :

John: This isn't a serious enough bug to block the release.

ADie (adie) wrote :

This bug forced me not to use Transmission, because it crashes very often.

Sergey K (koblin) wrote :

Confirm this bug!

Indeed, it is VERY often. If transmission is up- or downloading something, it crashes every few hours, or, sometime, minutes(!). No way to leave it for night.

I had to use sh-script with `while true` cycle to restart transmission on craches. But at every restart it re-checks all files, refreshes tracker info, so on. It is long enough, and people do not like such a headache.

If this bug will not be fixed in release, it is better for users to switch to another torrent client. So there is no need to put this buggy package into release at all, if it will not be fixed. IMHO.

John Dong (jdong) wrote :

Nobody said we aren't fixing this bug; I'm simply saying we are going to fix this bug as an intrepid-updates package rather than as a direct upload into intrepid which can potentially interfere with the spinning of the RC images currently. If the release managers say that it's okay to do this post-RC pre-release, I'd be fine with that too :)

Dmitry Korzhevin (korg) wrote :

Hello John!

All the same, perhaps worth a try include correcting this error before release? Otherwise, the release will contain a program that obviously is not working properly.

Martin Pitt (pitti) wrote :

Andrew, thanks. Your debdiff forgets to add the necessary dpatch invocations to debian/rules, I did that. I sponsored your package and uploaded to the intrepid-proposed queue, where it needs to stay until after intrepid is released.

Martin Pitt (pitti) on 2008-10-29
Changed in transmission:
status: Triaged → In Progress

Updated debdiff supplied in Bug #290769 fixing that as well

Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in transmission:
status: In Progress → Fix Committed
Hew (hew) wrote :

What is the test case for this? Is there a procedure that's able to reproduce the bug? I use transmission every day but haven't had this (or any) crash before. If there is no test case, I'm happy to just upgrade and test for regressions.

Martin Pitt (pitti) wrote :

Copied intrepid-proposed version to jaunty.

Changed in transmission:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to intrepid-updates. (Also tested in bug 290769, and no regression reports). If this crash still happens, please shout and we'll reopen. Thank you!

Changed in transmission:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.