Transmissions Clutch webinterface does not work

Bug #259155 reported by Thomas van der Burgt on 2008-08-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
transmission (Ubuntu)
Medium
Unassigned
Nominated for Intrepid by Thomas van der Burgt

Bug Description

Binary package hint: transmission

I noticed transmission was updated to 1.32 in Intrepid, I read in the release-notes that the Clutch Interface was added by default. After enabling it under preferences http://localhost:9091/transmission/web gives a blank page. When looking at the messagelog

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu.
Description: Ubuntu intrepid (development branch)
Release: 8.10

2) The version of the package you are using, via 'apt-cache policy packagename' or by checking in Synaptic.
transission(-common) 1.32-0ubuntu1

3) What you expected to happen
When enabling the Clutch-webinterface under preferences a web-based interface of transmission on http://localhost:9091/transmission/web

4) What happened instead
http://localhost:9091/transmission/web gave a white screen and the message-log of transmission gave the following error:
"Couldn't find the web interface's files! To customize this, set the CLUTCH_HOME environmental variable to the folder where index.html is located "

It seems the web interface file are not on the system at all, a "locate transmission.js" (I saw transmission looking for this in the message log) returns nothing

Changed in transmission:
assignee: nobody → andrewsomething
importance: Undecided → Medium
status: New → Confirmed

Thanks for catching this! I didn't realize that the build system didn't do this on its own and that I need to explicitly install these file in debian/rules. =(

Attached debdiff will install the webinterface along with the transmission-common package.

Changed in transmission:
assignee: andrewsomething → nobody

Also, it seems Debian uploaded a package shortly after the Ubuntu one which did this correctly. Maybe, it would be better to simply do a merge in order to stay closer to Debian. Please advise...

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=494438

Attached is a debdiff merging the current Intrepid package with Debian. This will resolve this issue. On further inspection, it also updates debian/copyright so I think merging would be the best option as this is important as well.

Sorry, for not getting this right the first time....

Daniel Holbach (dholbach) wrote :

Don't worry Andrew - that's fine.

The only problem is that Ubuntu and Debian now have a different .orig.tar.gz (different md5sum), we just have to make sure we get in sync again.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.32-1ubuntu1

---------------
transmission (1.32-1ubuntu1) intrepid; urgency=low

  * Remerge from debian unstable (LP: #259155), remaining changes:
   - Add missing X-Ubuntu-Gettext-Domain to gtk .desktop file
   - Add missing intltool build dependency.
   - debian/rules: Create a PO template during package build. (LP: #188690)

transmission (1.32-1) unstable; urgency=low

  * New upstream release (Closes: #494438, #487355)
  * debian/rules, debian/transmissioncli.{install,manpages}:
    - transmission-proxy is no longer shipped
    - add --as-needed to LDFLAGS
  * debian/transmission-common.install: add web directory
    (including upstream jquery since it includes plugins not available
    in libjs-jquery)
  * debian/copyright: updates from upstream and corrections (many GPL
    files had Licence:MIT fields) (thanks Kevin Bortis for the heads-up)

 -- Andrew Starr-Bochicchio <email address hidden> Tue, 19 Aug 2008 00:43:02 -0400

Changed in transmission:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.