Transmission forgets torrent when adding several

Bug #259123 reported by Tim Kornhammar on 2008-08-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Transmission
Fix Released
Unknown
transmission (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: transmission

Distribution: Ubuntu 8.04 / 8.10
Version: Transmission 1.32

Transmission doesn't seem to remember the file being opened after one file has been opened already using firefox. This is hard to describe, please see the steps below.

Steps to reproduce:
1) Open firefox (or possibly any web browser)
2) Locate a .torrent file and click it
3) Select "Open with [Transmission BitTorrent Client]" (not Save File) and press OK
* Transmission should appear with the Torrent Options. Note the Torrent file is correctly mentioned.
4) Select Add
* The torrent should have been successfully added.
5) Repeat steps 2 and 3 (ie. find another torrent file and open it)

What should happen:
The Torrent Options appear with the correct Torrent file selected, ready for adding.

What actually happens:
The Torrent Options appear with the Torrent file listed as (None). Selecting Add results in nothing at all.

description: updated
Charles Kerr (charlesk) wrote :

I don't understand what this bug report means. When I try to add two torrents, I get two "add torrent" dialogs, but Transmission won't know about either torrent until I press `add' in one of the dialogs.

Tim: could you walk me through step-by-step, click-by-click, how to reproduce this issue?

I download one torrent file via Firefox and open it with transmission.
Before I add it within transmission I download a second torrent and
open it with transmission as well. Now the local address to the first
torrent file has been "forgotten" and I need to locate it again in the
/tmp/ folder.

On Fri, Sep 5, 2008 at 9:17 PM, charles <email address hidden> wrote:
> I don't understand what this bug report means. When I try to add two
> torrents, I get two "add torrent" dialogs, but Transmission won't know
> about either torrent until I press `add' in one of the dialogs.
>
> Tim: could you walk me through step-by-step, click-by-click, how to
> reproduce this issue?
>
> --
> Transmission forgets torrent when adding several
> https://bugs.launchpad.net/bugs/259123
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Tim Kornhammar
<email address hidden>

Hew (hew) wrote :

I have updated the bug description. This bug is hard to describe since it doesn't happen the first time, but hopefully I have made the steps clear enough so that others can reproduce the problem.

Note that as a workaround, you can use Save File for torrents and open them through nautilus (for example).

description: updated
Changed in transmission:
importance: Undecided → Medium
status: New → Triaged
Changed in transmission:
status: Unknown → Confirmed
Charles Kerr (charlesk) wrote :

Fixed upstream in svn r8669 for 1.72.

Charles Kerr (charlesk) on 2009-06-11
Changed in transmission (Ubuntu):
status: Triaged → Fix Committed
Changed in transmission:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.72-1ubuntu1

---------------
transmission (1.72-1ubuntu1) karmic; urgency=low

  * Merge from debian unstable (LP: #388377), remaining changes:
    - debian/control:
      + Added replaces & provides clutch (now included as part of transmission).
      + add quilt, liblaunchpad-integration and libtool to Build-Depends
    - debian/rules:
      + Create a PO template during package build.
      + re-enable quilt
      + run autoreconf for launchpad-integration
    - debian/patches/01_lpi.patch:
      + Integrate Transmission with Launchpad
    - debian/patches/20_add_X-Ubuntu-Gettext-Domain.diff:
      + Add X-Ubuntu-Gettext-Domain to .desktop file.
  * Closes Launchpad bugs:
    - Use tooltip to notify user of added torrent (LP: #217171)
    - Transmission forgets torrent when adding several (LP: #259123)
    - Unable to sort files in torrent by Progress, Download nor Priority.
      (LP: #300359)
    - "Revert" and "Remove" uses same alt-key in Torrent Tracker Details
      (LP: #311064)
    - transmission crashed with SIGSEGV in g_closure_invoke() (LP: #334104)
    - Bring transmission to the top when adding a torrent (LP: #353777)
    - Focus should not be on "Don't ask me again" when I quit Transmission
      (LP: #359268)
    - [karmic] removing download items makes property window useless
      (LP: #385334)
    - transmission doesn't remember maximized state (LP: #385982)
    - Transmission 1.71 (8646) crashes when changing download speed
      (LP: #386877)
    - transmission: event.c:875: timeout_next: Assertion `tv->tv_usec >= 0'
      failed. (LP: #387564)

transmission (1.72-1) unstable; urgency=low

  * new upstream release: (closes:#533423)
    - Can now sort the file list by priority, download, and completeness
      (closes: #517872)
    - fixed race condition adding file from browser (closes: #500195)
  * debian/control: policy 3.8.2 (no changes)

 -- Krzysztof Klimonda <email address hidden> Tue, 16 Jun 2009 02:41:48 +0200

Changed in transmission (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.