does not create a PO template on build

Bug #188690 reported by Jonathan Ernst on 2008-02-03
52
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned
avahi (Ubuntu)
Undecided
Martin Pitt
boost (Ubuntu)
Undecided
Unassigned
cheese (Ubuntu)
Undecided
Unassigned
debootstrap (Ubuntu)
Wishlist
Colin Watson
f-spot (Ubuntu)
Undecided
Unassigned
gwenview-i18n (Ubuntu)
Undecided
Unassigned
ibus (Ubuntu)
Undecided
LI Daobing
libhildon (Ubuntu)
Undecided
Unassigned
libxpm (Ubuntu)
Undecided
Unassigned
mousetweaks (Ubuntu)
Undecided
Martin Pitt
pbuilder (Ubuntu)
Undecided
Unassigned
powertop (Ubuntu)
Undecided
Martin Pitt
qt-x11-free (Ubuntu)
Undecided
Unassigned
splix (Ubuntu)
Undecided
Unassigned
tasks (Ubuntu)
Undecided
Unassigned
transmission (Ubuntu)
Undecided
Martin Pitt
tuxtype (Ubuntu)
Undecided
Unassigned
userconfig (Ubuntu)
Undecided
Unassigned
xkeyboard-config (Ubuntu)
Undecided
Artem Popov

Bug Description

Transmission is not localized altough a translation exists upstream in SVN.

Transmission is a new default Ubuntu package, it should appear in the user's language.

For example the French translation exists since a long time in SVN but is not visible in current transmission installed on Hardy.

David Planella (dpm) wrote :

I can also confirm this for the Catalan language (although the SVN translation is not complete).

I also believed packages in 'main' required to have a translation template set up, which transmission does not to have at https://translations.launchpad.net/ubuntu/hardy/+source/transmission/+translate

Martin Pitt (pitti) on 2008-03-20
Changed in transmission:
assignee: nobody → pitti
status: New → In Progress
Martin Pitt (pitti) wrote :

I just got an up-to-date list from the LP translation developers. Those are all source packages in main which have at least one .PO file, but the source package does not create a PO template (usually po/<gettext_domain>.pot) during build. This needs to get fixed.

Packages which use cdbs just need to include /usr/share/cdbs/1/rules/langpack.mk. Packages using intltool usually need a call to "intltool-update -p" in debian/rules, or call an already existing Makefile target to build the POT (this does exist quite often in fact). Packages which don't use intltool need to get fixed individually, usually by adding a call to xgettext and po/POTFILES.in, or finding an already existing Makefile target.

Changed in tasks:
assignee: nobody → ubuntu-mobile
Changed in libhildon:
assignee: nobody → ubuntu-mobile
Changed in avahi:
assignee: nobody → pitti
status: New → In Progress
Changed in mousetweaks:
assignee: nobody → pitti
status: New → In Progress
Martin Pitt (pitti) wrote :

Transmission uploaded, will get into Hardy after beta freeze.

Changed in transmission:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

mousetweaks fix uploaded.

Changed in mousetweaks:
status: In Progress → Fix Committed
Martin Pitt (pitti) on 2008-03-20
Changed in powertop:
assignee: nobody → pitti
status: New → In Progress
Martin Pitt (pitti) wrote :

Avahi uploaded.

Changed in avahi:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

powertop uploaded

Changed in powertop:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.06-0ubuntu2

---------------
transmission (1.06-0ubuntu2) hardy; urgency=low

  * debian/rules: Create a PO template during package build. (LP: #188690)

 -- Martin Pitt <email address hidden> Thu, 20 Mar 2008 16:55:45 +0100

Changed in transmission:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mousetweaks - 2.22.0-0ubuntu2

---------------
mousetweaks (2.22.0-0ubuntu2) hardy; urgency=low

  * debian/rules: Build a PO template on package build. (LP: #188690)

 -- Martin Pitt <email address hidden> Thu, 20 Mar 2008 17:07:40 +0100

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package powertop - 1.9-2ubuntu1

---------------
powertop (1.9-2ubuntu1) hardy; urgency=low

  * debian/rules: Build a PO template on package build. (LP: #188690)

 -- Martin Pitt <email address hidden> Thu, 20 Mar 2008 17:22:42 +0100

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avahi - 0.6.22-2ubuntu4

---------------
avahi (0.6.22-2ubuntu4) hardy; urgency=low

  * debian/rules: Include langpack.mk, so that package build creates an up to
    date PO template. (LP: #188690)

 -- Martin Pitt <email address hidden> Thu, 20 Mar 2008 17:12:25 +0100

Changed in avahi:
status: Fix Committed → Fix Released
Changed in mousetweaks:
status: Fix Committed → Fix Released
Changed in powertop:
status: Fix Committed → Fix Released
Colin Watson (cjwatson) wrote :

This isn't really an issue for debootstrap; that .po file (a) isn't really a PO file (b) isn't actually used by anything yet.

I'll see if I can fix it up upstream, though.

Changed in debootstrap:
importance: Undecided → Wishlist
assignee: nobody → kamion
status: New → Triaged
Caroline Ford (secretlondon) wrote :

Tuxtype uses a homebew thing rather than gnu gettext. It is poorly localised at present.

Martin Pitt (pitti) wrote :

Ah, thanks Caroline. Closing tuxtype task then.

Changed in tuxtype:
status: New → Invalid
David Planella (dpm) wrote :

Hardy's Transmission has now a template in Rosetta [1], but it is empty (i.e. it has no translatable strings at all), although the one from upstream is not.

[1] https://translations.launchpad.net/ubuntu/hardy/+source/transmission/

Martin Pitt (pitti) wrote :

boost itself does not have translations and gettext, just one file used in the test suite.

Changed in boost:
status: New → Invalid
Martin Pitt (pitti) wrote :

libxpm does not have any PO files. Jeroen, this must be a false positive from your generated list of packages which lack a PO template.

Changed in libxpm:
status: New → Invalid
Martin Pitt (pitti) wrote :

pbuilder just has two .po files in the documentation. Jeroen, could this situation be detected when generating the list?

Changed in pbuilder:
status: New → Invalid
Martin Pitt (pitti) wrote :

split does not actually use gettext.

Changed in splix:
status: New → Invalid
Martin Pitt (pitti) wrote :

qt-x11-free just has some po files in examples/demo/, it does not use localized strings on its own.

Changed in qt-x11-free:
status: New → Invalid
Martin Pitt (pitti) wrote :

gwenview-i18n is a KDE-specialism, only KDE translation files for the gwenview package.

Changed in gwenview-i18n:
status: New → Invalid

Hi Martin,

The solution is block those files that aren't valid translations. I already blocked all things you detected as non valid translations and approved gwenview-i18n translations to be imported in gwenview package. This should remove those entries from next report, we only check for files in Needs review status.

Thanks for your help.

Adrien Cunin (adri2000) on 2008-04-18
Changed in tasks:
assignee: ubuntu-mobile → adri2000
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tasks - 0.13-1ubuntu1

---------------
tasks (0.13-1ubuntu1) hardy; urgency=low

  * debian/rules: copy POTFILES.in to the right place so that intltool-update
    works and the .pot file is generated (LP: #188690)
  * Set Maintainer to core-dev

 -- Adrien Cunin <email address hidden> Fri, 18 Apr 2008 18:09:21 +0200

Changed in tasks:
status: In Progress → Fix Released

Launchpad only got .po file updates, no .pot file was uploaded into Launchpad with latest task package update so there is still something going wrong here...

Changed in tasks:
status: Fix Released → Confirmed
Adrien Cunin (adri2000) wrote :

Yes, thanks for setting back the bug to confirmed. Indeed, there is still a problem that doesn't appear when building in a pbuilder, so I need to investigate. It will be fixed in intrepid and maybe in hardy with a SRU.

Adrien, if you provide me with the .pot file, I can upload it by hand, so next language pack update will include tasks translations.

Loïc Minier (lool) wrote :

Loïc, I guess that file was generated after all patches are applied to the source tree, right?

I just uploaded it so tasks should be ready to be translated/exported soon.

Loïc Minier (lool) wrote :

No patch in tasks right now.

Martin Pitt (pitti) wrote :

Thanks, Loic! Can you please upload this once intrepid opens?

Changed in tasks:
assignee: adri2000 → lool
status: Confirmed → In Progress
Loïc Minier (lool) wrote :

You mean copy the pot to po/ manually and upload that?

I uploaded 0.13-1ubuntu1 above before the release, but it failed to extract the template and this isn't reproducible in pbuilder...

Martin Pitt (pitti) wrote :

Loic,

there seems to be an error in your previous change, see build log:

can't open ./../data/tasks.desktop.in: No such file or directory at /usr/bin/intltool-extract line 210.
Building untitled.pot...
Running xgettext --add-comments --directory=. --default-domain=untitled --flag=g_strdup_printf:1:c-format --flag=g_string_printf:2:c-format --flag=g_string_append_printf:2:c-format --flag=g_error_new:3:c-format --flag=g_set_error:4:c-format --flag=g_markup_printf_escaped:1:c-format --flag=g_log:3:c-format --flag=g_print:1:c-format --flag=g_printerr:1:c-format --flag=g_printf:1:c-format --flag=g_fprintf:2:c-format --flag=g_sprintf:2:c-format --flag=g_snprintf:3:c-format --flag=g_scanner_error:2:c-format --flag=g_scanner_warn:2:c-format --output=untitled.pot --files-from=./POTFILES.in.temp --keyword=_ --keyword=N_ --keyword=U_ --keyword=Q_ --from-code=ASCII
Removing generated header (.h) files...done.
xgettext: error while opening "../data/tasks.desktop.in.h" for reading: No such file or directory
ERROR: xgettext failed to generate PO template file. Please consult
       error message above if there is any.

So the .pot file hasn't been built.

Loïc Minier (lool) wrote :

Yes, it's what I was writing in comment #30; I don't know how to reproduce on my system.

Martin Pitt (pitti) wrote :

Loic, really? I just built the current hardy source on hardy final, and get the error. The problem seems to be due to the multibuild system, it apparently cd's to the wrong po/ directory or so. This might be a problem in the cdbs langpack.mk rule.

Martin Pitt (pitti) wrote :

Loic, if I run intltool-update -p --verbose in $DEB_BUILDDIR/po (debian/build/standard/po), I get the error. If I run it in po/, all is well. So either the intltool setup needs to be fixed in the build directories, or tasks needs to manually call intltool-update in po/ (not in debian/build/*/po).

Artem Popov (artfwo) wrote :

A fix for xkeyboard-config not updating translations, original bug 213192 marked as duplicate of this one.

Loïc Minier (lool) wrote :

Артём, thanks, I've uploaded the proposed changes to intrepid with the following tweaks:
  * Rebase above change on top of 1.3-1 and target intrepid.
  * Use "$(MAKE) -C po update-po" instead of "(cd po; make update-po; cd ..)".
  * Update upload date.

If a hardy SRU is needed, please add a hardy task for xkeyboard-config to this bug; thanks.

Changed in xkeyboard-config:
assignee: nobody → artfwo
status: New → Fix Committed
Martin Pitt (pitti) wrote :

xkeyboard-config (1.3-1ubuntu1) intrepid; urgency=low

  [ Артём Попов ]
  * debian/rules: make update-po in the build target (LP: #213192)

  [ Loic Minier ]
  * Rebase above change on top of 1.3-1 and target intrepid.
  * Use "$(MAKE) -C po update-po" instead of "(cd po; make update-po; cd ..)".
  * Update upload date.

 -- Aerteieem PEopeove < <email address hidden>> Tue, 17 Jun 2008 23:40:34 +0200

Changed in xkeyboard-config:
status: Fix Committed → Fix Released
Daniel Holbach (dholbach) wrote :

Unsubscribed sponsors. nothing to sponsor right now.

Colin Watson (cjwatson) wrote :

I've removed debootstrap's broken and largely unnecessary (since base-installer takes care of it) attempt at gettext support upstream. We'll get it on the next sync from Debian.

Changed in debootstrap (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debootstrap - 1.0.12

---------------
debootstrap (1.0.12) unstable; urgency=low

  [ Otavio Salvador ]
  * Improve code to choose between libc packages. Thanks to Luca Favatella
    <email address hidden> for first version of the patch.

  [ Colin Watson ]
  * Remove partial support for emitting translated progress messages with
    gettext. Don't panic; d-i still has all the support necessary for this.
    debootstrap's own support for doing this outside d-i with gettext's
    shell bindings has been completely broken ever since it was added in
    2003, though, and nobody has complained. Fixing it would require a big
    pile of infrastructure and some non-trivial patches, plus arranging to
    copy all the translations over from base-installer, and it just doesn't
    seem worth it, so lose the cruft (LP: #188690).
  * Export PATH, just to make sure. It isn't necessarily exported by shells
    running from init=/bin/sh or similar, and the upstream bash maintainer
    is unwilling to export it by default; it's easy enough to do so here
    (LP: #320188).

debootstrap (1.0.11) unstable; urgency=low

  * Add (Ubuntu) jaunty as a symlink to gutsy.
  * Clarify that --second-stage is needed to complete the bootstrapping
    process after --foreign.
  * Fix --make-tarball= option (closes: #484869).
  * Fix old Debian scripts and all Ubuntu scripts to cope with Anthony's
    change in 1.0.8 to make --second-stage not bother recalculating required
    and base.
  * Rename 'repeat' to 'repeatn', since 'repeat' is a reserved word in zsh;
    although strictly speaking this seems like an incompatibility in zsh
    when linked to /bin/sh (closes: #340058).
  * Fix --unpack-tarball= option (thanks, Torsten Landschoff; closes:
    #500759).
  * Fix handling of relative DEBOOTSTRAP_DIR (thanks, Mikhail Gusarov;
    closes: #503460).
  * Cope with ancient versions of chroot(8) that don't call chdir() (thanks,
    Patrik Arvhult; closes: #350635).
  * Recommend gnupg for --keyring option (thanks, Robert Millan; closes:
    #467571).
  * Note that you can't --include packages with non-required Pre-Depends
    (see #487908).
  * Mention /sys in EXAMPLE section of manual page, and use "defaults"
    rather than "none" as the mount options for /proc (thanks, Raúl Sánchez
    Siles; closes: #410787).
  * Add /dev/console to devices.tar.gz (after all, MAKEDEV's 'consoleonly'
    was added for boot-floppies in the first place; see
    https://lists.ubuntu.com/archives/ubuntu-devel/2009-January/027230.html).
  * Add support for squeeze (closes: #513488).

 -- Colin Watson <email address hidden> Wed, 18 Mar 2009 10:42:22 +0000

Changed in debootstrap:
status: In Progress → Fix Released
Oliver Grawert (ogra) wrote :

unassigning mobile team, libhildon isnt used by us anymore and its unlikely to be SRUed

Changed in libhildon (Ubuntu):
assignee: Ubuntu Mobile Team (ubuntu-mobile) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tasks - 0.15-1ubuntu1

---------------
tasks (0.15-1ubuntu1) karmic; urgency=low

  * Create tasks.pot during build: Add a common-build-arch:: snippet to call
    langpack.mk's langpack-mk-update-pot target with
    DEB_BUILDDIR=$(DEB_SRCDIR); intltool-update can't be called in builddir as
    it needs POTFILES.in and even with it wont lookup files listed there in
    srcdir; add a clean:: snippet to remove the pot file; LP: #188690.

 -- Loic Minier <email address hidden> Thu, 02 Jul 2009 11:35:04 +0200

Changed in tasks (Ubuntu):
status: In Progress → Fix Released
David Planella (dpm) on 2009-07-27
tags: added: i18n
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cheese - 2.27.5-0ubuntu2

---------------
cheese (2.27.5-0ubuntu2) karmic; urgency=low

  * debian/rules:
    - run intltool-update since the cdbs code doesn't work when building
      out of the source directory which is the case there (lp: #188690)

 -- Sebastien Bacher <email address hidden> Thu, 30 Jul 2009 17:24:52 +0200

Changed in cheese (Ubuntu):
status: New → Fix Released
LI Daobing (lidaobing) on 2009-09-08
Changed in ibus (Ubuntu):
assignee: nobody → LI Daobing (lidaobing)
David Planella (dpm) wrote :

The F-Spot translation template in Launchpad hasn't been updated for months. It seems that the latest successful import was on 2009-07-29 02:15:53.544463+00:00, after which the f-spot package seemed to stop generating PO Templates on build. So f-spot needs to start creating templates as part of the build process.

Please consult the https://wiki.ubuntu.com/UbuntuDevelopment/Internationalisation#Verifying translation uploads document for more information on verifying that packages create a translation template.

Thanks.

Loïc Minier (lool) wrote :

David, this giant bug for all packages with out of date pots is a pain; could we move to individual bugs in the future? this bug already spans four releases!

perhaps a tag to track them, or the ubuntu-translations project is enough to get an overview instead?

Changed in tasks (Ubuntu):
assignee: Loïc Minier (lool) → nobody
David Planella (dpm) wrote :

Hi Loïc,

I just filed it here because I saw all the other bug tasks and thought it was the preferred way. I'd be more than happy to use the ubuntu-translation project and a tag (e.g. 'needs-pot-building') instead.

Loïc Minier (lool) wrote :

Ack; thanks

Bugs with a long list of tasks act like mail amplifiers and are bugging a lot of uninterested people (some people only care for one of the package but get traffic for all).

Loïc Minier (lool) wrote :

f-spot (0.6.1.3-1ubuntu1) karmic; urgency=low

  * debian/rules: update translation template

 -- Sebastien Bacher <email address hidden> Wed, 30 Sep 2009 14:45:16 +0200

Changed in f-spot (Ubuntu):
status: New → Fix Released
Jonathan Thomas (echidnaman) wrote :

I'm a bit puzzled about userconfig. It has a Messages.sh file that should be being executed on build. Any hints?

David Planella (dpm) on 2009-10-09
tags: added: needs-pot-on-build
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibus - 1.2.0.20090927-2

---------------
ibus (1.2.0.20090927-2) unstable; urgency=low

  * create po template when build (LP: #188690)
    - debian/rules: updated.
    - debian/clean: remove pot file when clean.
  * debian/control: build depends on python-rsvg (LP: #432375)

ibus (1.2.0.20090927-1) unstable; urgency=low

  * new upstream release.

ibus (1.2.0.20090915-1) unstable; urgency=low

  * new upstream release.

ibus (1.2.0.20090904-1) unstable; urgency=low

  * new upstream release.
  * debian/rules: remove ibus.desktop (LP: #420282)

ibus (1.2.0.20090828-1) unstable; urgency=low

  * new upstream release.
  * debian/control: bump standards version to 3.8.3.
  * debian/libibus1.symbols: updated.

ibus (1.2.0.20090812-1) unstable; urgency=low

  * new upstream release.
  * debian/libibus1.symbols: updated.

ibus (1.2.0.20090810-1) unstable; urgency=low

  * new upstream release.

ibus (1.2.0.20090807-1) unstable; urgency=low

  * new upstream release.
  * suggest qt4:
    - debian/control: add recommends for ibus-qt4
    - debian/xinput/ibus: detect ibus-qt4

ibus (1.2.0.20090806-1) unstable; urgency=low

  * new upstream release.

 -- LI Daobing <email address hidden> Mon, 12 Oct 2009 16:04:02 +0100

Changed in ibus (Ubuntu):
status: New → Fix Released
Luca Ferretti (elle.uca) wrote :

Gabor Epiphany in karmic is old 2.26 (Gecko), Epiphany in l10n.gnome.org is new 2.28 (WebKit)

Please file a *new bug* for epiphany. This one is far too noisy and is
CCed to far too many people who have long since fixed the reasons it was
CCed to them and are no longer interested.

Jonathan Thomas (echidnaman) wrote :

Seems to have been a transient failure for userconfig.

Changed in userconfig (Ubuntu):
status: New → Fix Released
Adi Roiban (adiroiban) wrote :

I'm closing this bug for ubuntu-translations.

I think it is easier to track each package that does not create a pot file in a separate bug report.

libhildon is now in universe and it will no longer be imported in Launchpad Translations.

Changed in ubuntu-translations:
status: New → Fix Released
Arne Goetje (arnegoetje) on 2009-11-09
Changed in libhildon (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers