Transmission tries to close connections when no active torrents present

Bug #188685 reported by Kayra Akman on 2008-02-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
transmission (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: transmission

When I try to quit Transmission without any torrents in the list, it tries to close nonexisting connections. It takes a while until the app closes. the "Quit immediately" way of closing the app should be taken automatically when there are no active torrents or no torrents at all as in my case.

Please provide Ubuntu version and Transmission version.

Changed in transmission:
status: New → Incomplete

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in transmission:
status: Incomplete → Invalid
David Balažic (xerces8) wrote :

Still happening.
1.75-0ubuntu2
Ubuntu 9.10 i386 desktop LiveCD

After starting and closing (no torrents) transmission it prints "Closing Connections / Sending upload/download totals to tracker..."

Changed in transmission (Ubuntu):
status: Invalid → New
Charles Kerr (charlesk) wrote :

David, do you have port forwarding enabled? One other thing Transmission does during that shutdown period is to attempt to unmap the port forwarding...

David Balažic (xerces8) wrote :

I did not enable any port forwarding.
I do not have a (P)NAT router.

Charles Kerr (charlesk) wrote :

If you look in Edit > Preferences, does it say that port forwarding is enabled? iirc it's enabled by default, so you didn't have to enable it yourself...

David Balažic (xerces8) wrote :

Even if it is, why would it try to unmap non-existing forwardings?

David Balažic (xerces8) wrote :

Now I tried (and experienced bug 494719)
 - I turned off port forwarding in preferences
 - started Transmission (no torrents)
 - exited

I still shows "Closing Connections / Sending upload/download totals to tracker..." for a second or two.

Charles Kerr (charlesk) on 2010-01-15
Changed in transmission (Ubuntu):
status: New → Confirmed
Charles Kerr (charlesk) wrote :

David, does this problem persist for you in 1.92? I'm not able to trigger this anymore.

> David, does this problem persist for you in 1.92?
Sorry, I'm not using Ubuntu this month ;)

David Balažic (xerces8) wrote :

(I tried to reply via email, but it did not work, so here I type it again in the web interface)

> David, does this problem persist for you in 1.92?
Sorry, I'm not using Ubuntu this month ;)

Charles Kerr (charlesk) on 2010-04-26
Changed in transmission (Ubuntu):
status: Confirmed → Incomplete
Charles Kerr (charlesk) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in transmission (Ubuntu):
status: Incomplete → Invalid

Confirmed on Ubuntu 10.10 Maverick, Transmission 2.04 (11151). Port forwarding disabled.

Changed in transmission (Ubuntu):
status: Invalid → Confirmed
summerishere (culpritdoctor) wrote :

Confirmed in ubuntu 10.10
Transmission 2.04 (11151

Mörgæs (moergaes) wrote :

Is this still a problem in 13.10?

Mörgæs (moergaes) wrote :

Closed due to age.
If a similar bug appears in 13.10 please open a new report.

Changed in transmission (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers