Missing icon from dock and dash

Bug #1212835 reported by manfreed on 2013-08-15
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Transmission
Unknown
Unknown
transmission (Ubuntu)
High
Unassigned

Bug Description

The usual transmission icon is not visible in the dock, and the dash, instead the placeholder icons are visible (grey rectangle with question mark, paper icon)

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: transmission-qt 2.82-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-1.4-generic 3.11.0-rc4
Uname: Linux 3.11.0-1-generic x86_64
ApportVersion: 2.12-0ubuntu3
Architecture: amd64
Date: Thu Aug 15 22:41:04 2013
InstallationDate: Installed on 2013-04-29 (108 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
SourcePackage: transmission
UpgradeStatus: Upgraded to saucy on 2013-06-24 (52 days ago)

manfreed (manfreed) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in transmission (Ubuntu):
status: New → Confirmed

Hello,

This is an easy fix. transmission-qt.desktop reference a non existing transmission-qt icon. It should use the same icon as gtk interface. So, the .desktop file should be updated to have:

Icon=transmission

Instead of:

Icon=transmission-qt

The icon is provided by transmission-common. Please, fix this problem in repo package.

As a workarround, simply modify it yourself, editing /usr/share/applications/transmission-qt.desktop as root or:

 cp /usr/share/applications/transmission-qt.desktop ~/.local/share/applications
 sed -i -e '/Icon/{s/transmission-qt/transmission/}' ~/.local/share/applications/transmission-qt.desktop

Sebastien Bacher (seb128) wrote :

that's an upstream bug and was fixed for 0.90 see https://trac.transmissionbt.com/ticket/5685

Changed in transmission (Ubuntu):
status: Confirmed → Fix Committed
importance: Undecided → High
Bartosz Kosiorek (gang65) wrote :

Reopening as this bug was not fixed in Ubuntu

Changed in transmission (Ubuntu):
status: Fix Committed → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 2.84-3ubuntu3

---------------
transmission (2.84-3ubuntu3) xenial; urgency=medium

  * debian/patches/lp1212835_changeset_14374: Take #14374 from upstream to
    make transmission-qt get an icon. (LP: #1212835)

 -- Iain Lane <email address hidden> Mon, 21 Mar 2016 17:32:29 +0000

Changed in transmission (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.