Segfault in curl_multi_cleanup error() when multi->closure_handle is NULL

Bug #1124508 reported by HsH on 2013-02-13
388
This bug affects 71 people
Affects Status Importance Assigned to Milestone
Curl
New
Undecided
Unassigned
curl (Ubuntu)
High
Barry Warsaw
transmission (Ubuntu)
Medium
Unassigned

Bug Description

Lubuntu 13.04
Transmission 2.76

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: transmission-gtk 2.76-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-6.11-generic 3.8.0-rc7
Uname: Linux 3.8.0-6-generic i686
ApportVersion: 2.8-0ubuntu4
Architecture: i386
CasperVersion: 1.330
Date: Wed Feb 13 20:51:27 2013
ExecutablePath: /usr/bin/transmission-gtk
LiveMediaBuild: Lubuntu 13.04 "Raring Ringtail" - Alpha i386 (20130213)
MarkForUpload: True
ProcCmdline: transmission-gtk
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SegvAnalysis: Skipped: missing required field "Disassembly"
Signal: 11
SourcePackage: transmission
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

HsH (hsh) wrote :
information type: Private → Public

StacktraceTop:
 curl_multi_cleanup (multi_handle=multi_handle@entry=0xb310a610) at multi.c:1776
 tr_webThreadFunc (vsession=0xb827d340) at web.c:439
 ThreadFunc (_t=0xb3b015c0) at platform.c:118
 start_thread (arg=0xb3affb40) at pthread_create.c:311
 clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Changed in transmission (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

This is a bug in the curl_multi_cleanup() implementation in the new version of CURL.

Upstream fix: https://github.com/bagder/curl/commit/da3fc1ee91de656a30f3a12de394bcba55119872#lib/multi.c

Upstream bug: http://sourceforge.net/p/curl/bugs/1194/

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in transmission (Ubuntu):
status: New → Confirmed
summary: - Transmission crashes on logout
+ Transmission crashes on exit [curl_multi_cleanup error]
Changed in curl (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in transmission (Ubuntu):
status: Confirmed → Invalid
tags: added: running-unity
Julian Taylor (jtaylor) on 2013-02-28
tags: added: patch

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1124508

tags: added: iso-testing
tags: added: bugpattern-needed
Cyberjunky (ron-8) wrote :

Please fix this for 13.04 release, all projects which use libcurl can/will crash on exit...
Fix is already made upstream...

ctrl (vlad-z-4096) wrote :

Affects amd64 as well.

Ian Ross (iankross) wrote :

just loading after a fresh install

Barry Warsaw (barry) wrote :

This is probably what's causing pycurl to crash in LP: #1163609

Changed in curl (Ubuntu):
assignee: nobody → Barry Warsaw (barry)
status: Triaged → In Progress
importance: Medium → High
milestone: none → ubuntu-13.04-beta-1
Barry Warsaw (barry) on 2013-04-03
summary: - Transmission crashes on exit [curl_multi_cleanup error]
+ Segfault in curl_multi_cleanup error() when multi->closure_handle is
+ NULL
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package curl - 7.29.0-1ubuntu2

---------------
curl (7.29.0-1ubuntu2) raring; urgency=low

  * debian/patches/08_lp1124508.patch: Backport fix for upstream bug 1194,
    segfault in curl_multi_cleanup() when multi->closure_handle is NULL.
    (LP: #1124508)
 -- Barry Warsaw <email address hidden> Wed, 03 Apr 2013 17:26:06 -0400

Changed in curl (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.