Up arrow and down arrow not rendered properly in web interface

Bug #1059136 reported by Avi Greenbury on 2012-09-30
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Transmission
Fix Released
Unknown
transmission (Ubuntu)
Undecided
Unassigned

Bug Description

The up arrow and down arrow for each torrent aren't rendered as arrows, but instead as the text '&uarrr;' and '↓'. I've attached a screenshot of this in both Firefox and Chromium (transmission-arrows.png).

When I create an html document using those character references I see actual arrows, so my assumption is that Transmission's doing these in a 'wrong' way, rather than that my browsers aren't supporting them properly. I've also attached a screenshot of that, in case I've used the wrong terminology somewhere above.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: transmission-common 2.61-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
Date: Sun Sep 30 16:45:59 2012
Dependencies:

InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120910)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: transmission
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in transmission (Ubuntu):
status: New → Confirmed
Changed in transmission:
status: Unknown → Fix Released
Yvon TANGUY (vono22) wrote :

I can confirm this bug on Ubuntu 12.04, with Firefox 15.0.1 (Ubuntu too) as web client.

Justin High (novafluxx) wrote :

I have 12.10 and Transmission 2.61. I know how to fix this, but I'm not sure how to go about doing so and submitting the patch so we can all benefit. I've never done anything like this, but this is a simple bug to resolve.

Justin High (novafluxx) wrote :

The attachment "From Transmission Trac, sergio" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.