transmageddon fails to transcode because python-gst0.10 doesn't expose gst.preset_set_app_dir

Bug #1031439 reported by Doug McMahon on 2012-07-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gst0.10-python (Debian)
Fix Released
Unknown
gst0.10-python (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Iain Lane
transmageddon (Ubuntu)
Undecided
Unassigned

Bug Description

= gst0.10-python =

[ Description ]

gst-python0.10 didn't expose preset_set_app_dir, which the SRUed transmageddon (0.20-1ubuntu0.1) relied upon.

[ Proposed fix ]

Cherry-pick upstream patch to expose this. Upload transmageddon with appropriate versioned dep.

[ Development release fix ]

Identical.

[ Regression potential ]

Applications could rely on the new exposed functions without an appropriate versioned dep, leading to runtime failures.

[ Test plan ]

Launch `transmageddon' from a terminal. Attempt to transcode a video. Note that an error referring to preset_set_app_dir appears before the update, and transcoding does not proceed. After the update, note that transcoding does proceed without this specific error.

[ Original description ]

All transcoding attempts fail the same -
~$ transmageddon
Traceback (most recent call last):
  File "transmageddon.py", line 863, in on_transcodebutton_clicked
    self._start_transcoding()
  File "transmageddon.py", line 736, in _start_transcoding
    self.videopasstoggle, self.interlaced, self.inputvideocaps)
  File "/usr/share/transmageddon/transcoder_engine.py", line 60, in __init__
    Gst.preset_set_app_dir("/usr/share/transmageddon/presets/")
NameError: global name 'Gst' is not defined

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: transmageddon 0.20-1ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
Uname: Linux 3.5.0-6-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
Date: Tue Jul 31 13:42:04 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120707)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: transmageddon
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
James M. Leddy (jm-leddy) wrote :
Changed in transmageddon (Ubuntu):
status: New → Invalid
no longer affects: gst-python (Ubuntu)
James M. Leddy (jm-leddy) wrote :

That's odd, there is something half-comipling the script, and changing Gst->gst

> if self.container != False:
> self.containercaps = gst.Caps(codecfinder.containermap[CONTAINERCHOICE])
> # special case mp3 which is a no-container format with a container (id3mux)
> else:
> if self.audiocaps.intersect(gst.Caps("audio/mpeg, mpegversion=1, layer=3")):
> self.containercaps=gst.Caps("application/x-id3")
> self.container=gst.Caps("application/x-id3")
>
> # set preset directory
> Gst.preset_set_app_dir("/usr/share/transmageddon/presets/")

When Gst is changed to gst this works.

Changed in transmageddon (Ubuntu):
status: Invalid → New
James M. Leddy (jm-leddy) wrote :

That was a stupid observation, I was looking at the upstream transcode_engine.py

James M. Leddy (jm-leddy) wrote :

Okay, after adjusting the patch, I've pushed two branches for merging. One of these exposes the new functions in gstreamer python, and the other fixes the capitalization difference in transmageddon. I'd like for these to be merged in for quantal, and then for us to get an SRU to precise for this.

Doug McMahon (mc3man) wrote :

Running transmageddon with the name change & applied gst-python diff it seems to again be working ok in 12.10 (sad how outdated some gst-10* sources are in 12.04/.10

Though it does expose the ongoing h264parse bug in gst bad0.10 & transmageddon can be added to list of affected apps as it can Not transcode those AVC files (though with a patched bad plugin it does them fine
Bug 973014

Iain Lane (laney) on 2012-08-05
Changed in transmageddon (Ubuntu):
status: New → Fix Released
Iain Lane (laney) wrote :

The name change is in 0.21 which is in Quantal now, and which I'll backport to Precise in a second. Thanks for spotting it. I'm not sure why I didn't — I can only assume that I just plain didn't install the new version. My bad.

gst-python upload coming too. James, I can't find your branch on this bug but I did find the commit upstream:

  http://cgit.freedesktop.org/gstreamer/gst-python/patch/gst/gst.defs?id=574275e773f3fbbbc0f980d541eb0d477cdf476e

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst0.10-python - 0.10.22-3ubuntu1

---------------
gst0.10-python (0.10.22-3ubuntu1) quantal; urgency=low

  * Backport upstream commit 574275e7 to expose new
    gst.preset_{set,get}_app_dir() functions, required by transmageddon (LP:
    #1031439)
 -- Iain Lane <email address hidden> Sun, 05 Aug 2012 21:31:30 +0100

Changed in gst0.10-python (Ubuntu):
status: New → Fix Released
Iain Lane (laney) wrote :

The transmageddon SRU fix doesn't need tracking in its own bug; I'll just reupload it.

description: updated
summary: - transcoding fails to start: NameError: global name 'Gst' is not defined
+ transmageddon fails to transcode because python-gst0.10 doesn't expose
+ gst.preset_set_app_dir
no longer affects: transmageddon (Ubuntu Precise)
Changed in gst0.10-python (Ubuntu Precise):
status: New → In Progress
assignee: nobody → Iain Lane (laney)
Changed in gst0.10-python (Debian):
status: Unknown → Fix Committed

Hello Doug, or anyone else affected,

Accepted gst0.10-python into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gst0.10-python/0.10.22-3ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gst0.10-python (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Doug McMahon (mc3man) wrote :

Works without incident within the current limits of the 'bad' bad plugin parser

tags: added: verification-done
removed: quantal verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst0.10-python - 0.10.22-3ubuntu0.1

---------------
gst0.10-python (0.10.22-3ubuntu0.1) precise-proposed; urgency=low

  * Backport upstream commit 574275e7 to expose new
    gst.preset_{set,get}_app_dir() functions, required by transmageddon (LP:
    #1031439)
 -- Iain Lane <email address hidden> Sun, 05 Aug 2012 22:23:47 +0100

Changed in gst0.10-python (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in gst0.10-python (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.