Yakkety version of transcode needed (removal causes unmet dependencies)

Bug #1631796 reported by StoatWblr on 2016-10-09
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
MythTV
Unknown
Unknown
subtitleripper (Ubuntu)
Undecided
Unassigned
transcode (Ubuntu)
Undecided
Unassigned
Yakkety
Undecided
Unassigned

Bug Description

This package hasn't been ported to Yakkety yet.

That breaks a number of other packages which depend on it.

SRU acceptance criteria: the package builds in yakkety and can fulfill the dependencies again.

Hans Joachim Desserud (hjd) wrote :

Thanks for reporting.

From what I can see this package has been removed from Ubuntu Yakkety (and Debian). See https://launchpad.net/ubuntu/+source/transcode/+publishinghistory or https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=817199 for more details.

>That breaks a number of other packages which depend on it.

Could you list some of these? The Debian bug report only spoke about one reverse dependency for this package.

tags: added: yakkety
xabilon (xabilon) wrote :

It breaks Subtitleripper

Hans Joachim Desserud (hjd) wrote :

Thanks for responding. :)

Indeed, subtitleripper lists transcode as a dependency [1]. It is currently not installable on Ubuntu 16.10 since transcode is missing. Odd, because I thought reverse dependencies were checked or would block package removal...

[1] http://packages.ubuntu.com/yakkety/subtitleripper

tags: added: unmetdeps zesty
Changed in subtitleripper (Ubuntu):
status: New → Confirmed
Changed in transcode (Ubuntu):
status: New → Confirmed
summary: - Yakkety version needed
+ Yakkety version of transcode needed (removal causes unmet depdendencies)

$ apt-cache rdepends transcode
transcode
Reverse Depends:
  transcode-doc
  dvdrip
  xjadeo
  subtitleripper
  ripmake
  mythtv-frontend
  mytharchive
  multimedia-video
  python-mecavideo

That's just the ones installed on my system
(Apologies for the late reply, buried alive in email)

StoatWblr (stoatwblr) wrote :

K3b also uses transcode (if installed) but it's not a hard dependency.

Steve Langasek (vorlon) wrote :

Matthias, it seems you processed the transcode removal, but it had reverse-dependencies. Could you follow through on this for zesty? I don't imagine we'll fix this for yakkety now.

Changed in subtitleripper (Ubuntu):
assignee: nobody → Matthias Klose (doko)
Simon Dawson (spdawson) wrote :

This is currently preventing the installation of mythtv-frontend on 16.10.

Joseph Yasi (joe-yasi) on 2016-11-15
Changed in mythtv:
importance: Undecided → Unknown
status: New → Unknown
Matthias Klose (doko) wrote :

transcode was removed in yakkety because it fails to build with the ffmpeg in yakkety. Sorry about not checking all the reverse dependencies. To build it again, the build failure in transcode has to be fixed. Attaching the build log.

summary: - Yakkety version of transcode needed (removal causes unmet depdendencies)
+ Yakkety version of transcode needed (removal causes unmet dependencies)
Thomas Mashos (tgm4883) wrote :

For the MythTV packages, this is fixed in the 0.28 PPA

Joseph Yasi (joe-yasi) wrote :

This patch fixes the build with newer ffmpeg.

Joseph Yasi (joe-yasi) wrote :

This gentoo patch is probably cleaner than my patch which leaves a bunch of warnings in place:
https://gitweb.gentoo.org/repo/gentoo.git/tree/media-video/transcode/files/transcode-1.1.7-ffmpeg29.patch

The attachment "Fix build with newer ffmpeg PIXFMT names" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Matthias Klose (doko) on 2016-11-19
no longer affects: subtitleripper (Ubuntu Yakkety)
Changed in subtitleripper (Ubuntu):
status: Confirmed → Invalid
assignee: Matthias Klose (doko) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transcode - 3:1.1.7-9ubuntu1

---------------
transcode (3:1.1.7-9ubuntu1) zesty; urgency=medium

  * Fix building with recent ffmpeg. LP: #1631796.

 -- Matthias Klose <email address hidden> Sat, 19 Nov 2016 23:25:05 +0100

Changed in transcode (Ubuntu):
status: Confirmed → Fix Released
Matthias Klose (doko) on 2016-11-19
description: updated
Matthias Klose (doko) wrote :

ubuntu-sru: the package is in the NEW queue, not in the unapproved queue.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in transcode (Ubuntu Yakkety):
status: New → Confirmed
Graham Inggs (ginggs) on 2016-11-29
Changed in transcode (Ubuntu Yakkety):
status: Confirmed → In Progress

Hello StoatWblr, or anyone else affected,

Accepted transcode into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/transcode/3:1.1.7-9ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in transcode (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed
Matthias Klose (doko) wrote :

package built successfully in yakkety-proposed

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transcode - 3:1.1.7-9ubuntu0.1

---------------
transcode (3:1.1.7-9ubuntu0.1) yakkety-proposed; urgency=medium

  * SRU: Build transcode in yakkety again. LP: #1631796.

 -- Matthias Klose <email address hidden> Sun, 20 Nov 2016 00:44:49 +0100

Changed in transcode (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for transcode has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.