Deskbar applet crashes at startup since I installed libdeskbar-tracker

Bug #85029 reported by Sakumatti Luukkonen on 2007-02-14
98
Affects Status Importance Assigned to Milestone
Tracker
Fix Released
Critical
deskbar-applet
Fix Released
Critical
tracker (Ubuntu)
High
Unassigned

Bug Description

I get the following message when I login to my Feisty desktop. If I kill gnome-panel, the applet works fine again.

Here's the relevant info:

Distribution: Ubuntu 7.04 (feisty)
Gnome Release: 2.17.90 2007-01-23 (Ubuntu)
BugBuddy Version: 2.17.3

System: Linux 2.6.20-6-generic #2 SMP Wed Jan 31 20:53:39 UTC 2007 i686
X Vendor: The X.Org Foundation
X Vendor Release: 70101000
Selinux: No
Accessibility: Disabled

Memory status: size: 0 vsize: 0 resident: 0 share: 0 rss: 0 rss_rlim: 0
CPU usage: start_time: 0 rtime: 0 utime: 0 stime: 0 cutime:0 cstime: 0 timeout:
0 it_real_value: 0 frequency: 0

----------- .xsession-errors (2542 sec old) ---------------------
beryl: pixmap 0x3a000d7 can't be bound to texture
beryl: Couldn't bind redirected window 0x10000e7 to texture
beryl: pixmap 0x3a000d5 can't be bound to texture
beryl: Couldn't bind redirected window 0x10000b6 to texture
beryl: pixmap 0x3a000d7 can't be bound to texture
beryl: Couldn't bind redirected window 0x10000e7 to texture
beryl: pixmap 0x3a000d5 can't be bound to texture
beryl: Couldn't bind redirected window 0x10000b6 to texture
beryl: pixmap 0x3a000d7 can't be bound to texture
beryl: Couldn't bind redirected window 0x10000e7 to texture
beryl: pixmap 0x3a000d5 can't be bound to texture
beryl: Couldn't bind redirected window 0x10000b6 to texture
beryl: pixmap 0x3a000d7 can't be bound to texture
...Too much output, ignoring rest...
--------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/deskbar/ModuleLoader.py", line 157, in
load_all
    self.load (f)
  File "/usr/lib/python2.5/site-packages/deskbar/ModuleLoader.py", line 139, in
load
    mod_instance = getattr (mod, handler) ()
  File "/home/saku/.gnome2/deskbar-applet/handlers/deskbar-tracker-05.py", line
92, in __init__
    self.proxy_obj = self.bus.get_object('org.freedesktop.Tracker',
'/org/freedesktop/tracker')
  File "/var/lib/python-support/python2.5/dbus/_dbus.py", line 412, in
get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/var/lib/python-support/python2.5/dbus/proxies.py", line 232, in
__init__
    _dbus_bindings.UInt32(0))
  File "/var/lib/python-support/python2.5/dbus/proxies.py", line 171, in
__call__
    reply_message = self._connection.send_message_with_reply_and_block(message,
timeout)
DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process
/usr/bin/trackerd exited with status 0

Deskbar + Beryl works fine here.

What this crash incidental or does it keep recurring?
And ifso, does it also occur without beryl?

Yes it does also occur without beryl. My feisty is upgraded from edgy, maybe that has something to do with it?

This seems to be problem with the Tracker Live Search plugin for Deskbar Applet (libdeskbar-tracker). If I disable it, the crash doesn't occur.

Correction: it seems to happen without libdeskbar-tracker too.

There is problem with libdeskbar-tracker when you login to your session. But when you do 'killall gnome-panel' in a terminal you will see it launches without problem.

The reason the libdeskbar-tracker makes it crash is because deskbar is launched before the tracker-deamon is executed.

Please try an 'killall gnome-panel' and see if deskbar launches at all for you.

Your traceback does indicate it has to do with the tracker-backend though: i've had that problem too and reported it upstream (with the gnome-guys)

But it turned out they already know about it:
http://bugzilla.gnome.org/show_bug.cgi?id=403752

Giving the traceback being identical in all cases, I suspect its the same bug and it _is_ related to the tracker-backend.

You said:
"Correction: it seems to happen without libdeskbar-tracker too."

Are you sure its the same bug? I would love to see the traceback when you have libdeskbar-tracker uninstalled.. (an aptitude remove libdeskbar-tracker)

For now i've changed the package that is causing this..

Changed in deskbar-applet:
status: Unconfirmed → Confirmed

I said: "Please try an 'killall gnome-panel' and see if deskbar launches at all for you."

Sorry, i've should have read your bugreport more carefully.

I have also linked to the upstream bugs about this..

Yes, if I do 'killall gnome-panel' it starts up normally without any problems.

Double correction: I meant that it happens even if I don't have Tracker Live Search selected in my deskbar configuration. I didn't actually uninstall libdeskbar-tracker, but I will try that too now.

Update: I tested now it with libdeskbar-tracker uninstalled and it didn't crash at startup now.

So it seems to be a problem with libdeskbar-tracker package.

Whats your traceback without libdeskbar-tracker?
Because the traceback of your original bug is identical to all the upstream bugs about libdeskbar-tracker.

So if it still crashes without libdeskbar-tracker, it should be another bug ;-)

Heh, I think I've been really unclear on this bugreport.

It doesn't crash at all with libdeskbar-tracker uninstalled.

No you haven't been unclear. This is just us trying to find out what's wrong. But the bug is clear now, and we it is tracked upstream. Let's hope the fix gets in before Feisty's release.

I think they want to use to tracker in the future on a default install, since it much lighter than beagle.

You can still use tracker in nautilus when you have it installed (without the libdeskbar plugin). Unfortunately the default search window (Locations -> Search..) does not support it yet..

I've changed the summary to be more specific about what's going on; it might prevent some duplicates..

Changed in deskbar-applet:
status: Unknown → Confirmed
Changed in tracker:
status: Unknown → Unconfirmed

I just tried again yesterday. Now it not only crashes at login, but any time. Deskbar just refuses to load.

In the past you could do a 'killall gnome-panel' after a while and deskbar and its tracker plugin would start working. As if, it just didn't work at login-time because the tracker-deamon wasn't ready yet.

So something about this bug changed. Deskbar was updated, but tracker was not.
Considering we all assume Tracker is to blame (which it problely is), whats going on?

Does anyone have a clue? The error now is still the same though! It just now also occurs at any other time than login.

Actually, deskbar-applet doesn't crash anymore on my box when libdeskbar-tracker is installed. Everything works fine now somehow.

Well, it worked for one reboot. It crashes again now.

Emilio Pozuelo Monfort (pochu) wrote :

Does this happen with 0.5.4-4?

Changed in tracker:
importance: Undecided → Medium

On tor, 2007-03-08 at 14:55 +0000, Emilio Pozuelo Monfort wrote:
> Does this happen with 0.5.4-4?
>

It does for me.

/Mikael

Is there a way to make the tracker-deamon (trackerd in your gnome-session) launch before gnome-panel?

Because when I do a 'killall gnome-panel' it seems to work, if the deamon has already started. Unfortunately there is delay before the deamon gets started ..

Does anyone have a suggestion?
I would love to use this and at this point, I would settle for a hack like this. Perhaps the hack can be applied downstream if it works.

So, how to force trackerd to launch _before_ gnome-panel?

I've found a bug about the same issue with much more related info.
They say its fixed in CVS. Can the fix be back-ported?

I will be releasing 0.6.0 version of tracker soon with these and other important fixes - I guess we can request a feature freeze break as its a universe component when its ready

That sounds great!

For now, based on the other bug-report's analysis, i've found a simple workaround.

SIMPLE WORKAROUND
1. Go to system -> Preferences -> Session
2. Unmark 'tracker'
3. Now Deskbar will launch tracker and everything will be fine.

PS. I've set this bug as a duplicate, but its wrong, because the other bug seemed to be about deskbar+tracker (and had lots of interesting info), yet the bug-poster was quite right about dbus being killed if you logout and log back in again. How to unset a bug as a duplicate? I can't find the option!

Emilio Pozuelo Monfort (pochu) wrote :

Hey Ralf

To unmark a bug as a duplicate, click on "Mark as a Duplicate", and then remove the bug number, and mark it.

Regards
Emilio

Jamie, you said there would be a 0.6 release for Feisty.
Is this still going to happen?

yes in next few days

Changed in tracker:
status: Unconfirmed → Rejected

Its not going to make the release candidate is it?

Changed in tracker:
status: Unknown → Confirmed
Bram Bonné (brambonne) wrote :

I would REALLY love to see the patch make it to the repositories ASAP, since tracker+deskbar is a great way to show off with ubuntu to your friends, and encourage them to install feisty.
@ralf: The workaround doesn't seem to work for me. It does the first time, like when it's not used, but after that it will stop working again.

tziel (tziel) wrote :

Unfortunately Ralf's workaround does not work ;[
I can confirm that the bug depends on trackerd. When trackerd is watching or indexing files, deskbar applet fails to load and crash. After finishing indexing by Tracker and killing gnome-panel, deskbar applet is running OK.
I'm looking forward the patch, RC version, fix or sth, I just can't wait :}

Any news on whether this is going to make it into the repos by tomorrow? Or through backports or something?

Emilio Pozuelo Monfort (pochu) wrote :

No, I'm afraid this is not going to make Feisty's release. Since we're too late, and, more important, since there is not fixed yet upstream, and we don't have a patch available.

So this will have to wait for Gutsy.

Changed in tracker:
importance: Medium → High

New version with this fixed should come tonight/tomorrow

If its too late then we can arrange a backport

Bram Bonné (brambonne) wrote :

Any news on a backport yet?

Emilio Pozuelo Monfort (pochu) wrote :

GooZ: not yet, it will be out as soon as tracker 0.6 is released.

apelete (apelete) wrote :

I have just switch from Beagle to Tracker but this bug really is a showstopper.
Like someone said above; the bug is fixed in the new svn versions on Gnome side.
When will Tracker 0.6 be released ? And can we expect an upgrade, or at least a backport, for Feisty ?

apelete (apelete) wrote :

Just for info, Ralf's workaround seems to work for me.
I already rebooted twice and Deskbar is loading just fine (slower than usual though), and Tracker along with it...

We are aiming for 0.6 release this week (cant say for sure when as there are a few bugs to be sorted yet)

Changed in deskbar-applet:
status: Confirmed → Fix Released
Changed in tracker:
status: Confirmed → Fix Released
Apreche (apreche) wrote :

I don't have this problem in Gnome under Feisty, but I do have the problem in Xfce under Feisty. I've uninstalled libdeskbar-tracker. I've also killed trackerd, and tried to make sure it does not start automatically. This, of course, allows deskbar to start without crashing. However, trackerd is still running when I login to Xfce! I can't figure out what is starting it.

fixed upstream

Changed in tracker:
status: Confirmed → Fix Committed

But will this fix be backported?

Emilio Pozuelo Monfort (pochu) wrote :

It will once 0.6 is released.

apelete (apelete) wrote :

We are at the end of may and the fix has not been pushed to the repos...
Tracker 0.6 seems to take a while too, why wait for 0.6 to be released before fixing the bug ??

Martin Knudsen (brainwashed) wrote :

We are now two months past that. Will this be fixed anytime soon?

ravbc (ravbc) wrote :

0.6 was released yesterday. So when it will be in repo? ;-)

Sebastien Bacher (seb128) wrote :

 tracker (0.6.0-1) unstable; urgency=low
 .
   * New upstream release.
     - Uses XDG directories to store the settings, cache, database and log
       files. Closes: #414860
     - Fixes the crash of the deskbar applet at session start. Closes: #434078
     - Does not fall back to polling when the inotify limit is exceeded.
       Closes: #412089
     - Correctly uses xdg-open to open the search results with the preferred
       application. This requires the xdg-utils package to be installed, which
       is a Recommends of tracker-search-tool. Closes: 415705
   * Removed debian/man/ as the man pages are now shipped upstream.
     Update tracker.manpages, tracker-search-tool.manpages and
     tracker-utils.manpages accordingly.
   * Removed patches that were applied upstream or are now obsolete
     - debian/patches/20-trackerd_manpage.patch
     - debian/patches/30-deskbar_plugin_max_results.patch
     - debian/patches/40-inotify_syscalls.patch
     - debian/patches/50-expand_pathname.patch
     - debian/patches/60-check_pointer.patch
     - debian/patches/70-check_magic_file_results.patch
   * debian/copyright
     - The htmless sources are not shipped anymore and the qdbm sources are now
       in a separate subdirectory. Update the copyright file accordingly.
   * debian/libtracker-gtk-dev.install, debian/libtracker-gtk0.install
     - Added. libtracker-gtk is a new library that provides handy GTK+ widgets
       for applications that use tracker.
   * debian/control
     - Drop libmagic-dev from Build-Depends, add libunac1-dev and libqdbm-dev.
     - Add djvulibre-bin and gnumeric to Suggests. They are used as external
       filters for indexing djvu, csv and spreadsheet documents.
     - Add binary packages libtracker-gtk0 and libtracker-gtk-dev.
     - Update the long description of tracker-utils and include the new tool
       "tracker-status".
     - Add binary package tracker-dbg which provides the debugging symbols of
       trackerd and its utilities. Closes: #412140
   * debian/rules
     - Make sure we link against the system qdbm library.
     - Enable the support for libunac.
     - Explicitly enable the compilation of the GUI, the preferences applet
       and libtracker-gtk.

Changed in tracker:
status: Fix Committed → Fix Released

Now that tracker 0.6 is released, any chance of upgrading or backporting tracker & libdeskbar-tracker to 0.6.x in feisty? It would fix this bug for feisty.

Changed in deskbar-applet:
status: Fix Released → Confirmed
Changed in tracker:
status: Fix Released → Confirmed
Nikolaus Filus (nfilus) wrote :

one more PING on this bug - This bug is still there on feisty.
How to request a backport of trackerd 0.6 or at least the fix to feisty?

Emilio Pozuelo Monfort (pochu) wrote :

Backport requested in bug #135171.

Changed in deskbar-applet:
status: Confirmed → Fix Released
Changed in tracker:
status: Confirmed → Fix Released
gkey (gmkey) wrote :

I reported the crash with GNOME. This is the standard reply:

This is a bug in tracker versions before 0.6.3 (causing deskbar-applet to
crash). Please ask your distribution for an upgrade to tracker 0.6.3 (or
newer).

Emilio Pozuelo Monfort (pochu) wrote :

Hi gkey.

I built tracker 0.6.3 for feisty (you have feisty right?) in my ppa, but since it's still a bit buggy I don't think we should backport it. However, svn is freeze for 0.6.4, so it should be out soon, and I'll request a backport for it to feisty and gutsy (providing it works well, of course).

We haven't patched tracker to fix this since it isn't trivial, so we need a backport. Let's see if we can get it done with 0.6.4.

Changed in deskbar-applet:
importance: Unknown → Critical
Changed in tracker:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.