[apport] tracker-extract crashed with SIGSEGV in strlen()

Bug #82879 reported by ChristofferS on 2007-02-02
96
Affects Status Importance Assigned to Milestone
Tracker
Fix Released
Critical
tracker (Ubuntu)
Medium
Emilio Pozuelo Monfort

Bug Description

Binary package hint: tracker

Tracker version 0.5.4.

Just indexing normally, and then it crashed.

ProblemType: Crash
Date: Fri Feb 2 17:48:00 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/tracker-extract
Package: tracker 0.5.4-1ubuntu1
ProcCmdline: tracker-extract /media/hda5/cs/freevo2/share/freevo/htdocs/favicon.ico image/x-ico
ProcCwd: /home/cs
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_DK.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: tracker
StacktraceTop:
 strlen () from /lib/tls/i686/cmov/libc.so.6
 g_strescape () from /usr/lib/libglib-2.0.so.0
 ?? ()
 ?? ()
 ?? ()
Uname: Linux t23 2.6.20-5-generic #2 SMP Sat Jan 6 14:50:47 UTC 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev scanner video

Changed in tracker:
status: Unknown → Unconfirmed
Mika Fischer (zoop) wrote :

For a crash report with debug symbols see the duplicate bug #84000

ChristofferS (ubuntu-curo) wrote :

File causing the crash.

Scott Zawalski (cowbud) wrote :

I just indexed the file you attached without any issues. Are you still experiencing this issue?

pirast (pirast) wrote :

Indeed, seems to be fixed for me, at least I do not run into this issue anymore.

Changed in tracker:
status: Unconfirmed → Fix Released
pirast (pirast) wrote :

just reappeard to me. see bug 85649 for recent debugging output.

Changed in tracker:
status: Fix Released → Confirmed
Changed in tracker:
importance: Undecided → Medium

My bugreport was flagged as a duplicate of this one. However, in my case it concerned a file that was being written while it was being indexed.

This might explain why this bug, later, seems fixed and then resurfaces.

Perhaps other bug posters can tell us how likely or unlike it was that the offending file was being written to at the time of the crash?

pirast (pirast) wrote :

bug 90144 has newer debugging information as the old ones to not work with the new apport-retrace tool.

Emilio Pozuelo Monfort (pochu) wrote :

Thanks for your reports.

This bug should have been fixed with tracker 0.5.4-4.
Please, reopen the report if it happens again.

Regards
Emilio

Changed in tracker:
assignee: nobody → pochu
status: Confirmed → Fix Released
Changed in tracker:
status: New → Fix Released
bwallum (rbw2) wrote :

Seems to be back in jaunty updated to 20/3/09. AMD64. nVidia.

Changed in tracker:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.