Tracker does not index Evolution mails

Bug #360399 reported by Nico on 2009-04-13
220
This bug affects 34 people
Affects Status Importance Assigned to Milestone
tracker (Ubuntu)
Medium
Unassigned
Nominated for Karmic by Simone Tolotti
Jaunty
Medium
Unassigned

Bug Description

Binary package hint: tracker

In jaunty, today, tracker is not indexing Evolution Email.

This is because the built-in tracker module that pulls data from Evolutionis buggy and is not built anymore.

https://bugs.launchpad.net/ubuntu/+source/tracker/+bug/354601

The goal is to use an Evolution plugin (eplug) so that Evolution pushes data to Tracker.

This eplug is still nowhere to be found.

Changed in tracker (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → Medium
status: New → In Progress
Murat Gunes (mgunes) wrote :

Thanks for reporting. Assigning to Chris Coulson as per IRC discussion.

Changed in tracker (Ubuntu):
importance: Medium → Low
status: In Progress → Triaged
status: Triaged → In Progress
Chris Coulson (chrisccoulson) wrote :

The plugin comes in 2 parts - the new Evo push-module (which we install already), and an Evo EPlugin, which we aren't installed.

Changed in tracker (Ubuntu):
importance: Low → Medium
tags: added: regression-potential
Chris Coulson (chrisccoulson) wrote :
Changed in tracker (Ubuntu):
status: In Progress → Triaged
Martin Pitt (pitti) wrote :

Merged Chris' patch into the ubuntu branch, but not uploading yet due to the RC freeze.

Changed in tracker (Ubuntu):
status: Triaged → Fix Committed
Nico (nico-rdo) wrote :

Thank you!

Joe Barnett (thejoe) wrote :

I built & installed new tracker .debs from the ubuntu branch using `bzr bd`, but found that tracker-indexer hangs! with debug logs turned on, trackerd.log shows many messages to the effect of "the indexer is not responding to dbus request", and a gdb stacktrace showed the indexer hanging out trying to open a sqlite database. have reverted to no-eplugin tracker .debs for now and don't have the logs or stack trace in front of me, but can get more detailed messages/stack traces if you need.

Murat Gunes (mgunes) wrote :

Joe, please file separate bug reports for crashes, using Apport. This bug is about the missing Evolution plugin.

Alex Murray (alexmurray) wrote :

Can this get uploaded for Jaunty before release? Would be a shame to ship tracker when it can't index evolution email.

Martin Pitt (pitti) wrote :

SRU ack because it is a regression from jaunty.

is there a fix in someone's PPA?

Chris Coulson (chrisccoulson) wrote :

Yes, it is in my PPA. It hasn't been uploaded yet because it doesn't actually fix Evolution indexing for me, but you're more than welcome to try it out and provide feedback (perhaps it works for you and then it would be worth uploading).

Thanks

Chris,
thanks. Your PPA version doesn't fix it for me either.

I've reverted the change that installs the plugin for the update, as e-mail indexing still doesn't work with it anyway. This needs some more investigation.

Changed in tracker (Ubuntu Jaunty):
status: Fix Committed → Triaged
Changed in tracker (Ubuntu):
status: Fix Committed → Triaged
Steve Beattie (sbeattie) on 2009-04-28
tags: added: jaunty regression-release
removed: regression-potential
Chris Coulson (chrisccoulson) wrote :

I've just discussed this with upstream, and it seems that the push-modules are broken, and have now been disabled in the 0.6.x branch anyway. The old indexer module (which I disabled in Jaunty anyway) won't work with our version of Evolution:

(18:49:41) chrisccoulson: pvanhoof - i'm trying to debug the evolution plugin on ubuntu, because i haven't got it to work yet. i don't really understand it enough to work out what is going on, but in register_account, this check always evaluates to true:
(18:49:44) chrisccoulson: if (!(provider->flags & CAMEL_PROVIDER_IS_STORAGE))
(18:49:52) chrisccoulson: and so, register_account just returns
(18:50:05) pvanhoof: chrisccoulson, we have disabled the push modules
(18:50:05) chrisccoulson: i'm assuming that is why it never sends any data out
(18:50:14) chrisccoulson: in which version?
(18:50:20) pvanhoof: tracker-0.6 branch
(18:50:47) chrisccoulson: we're running 0.6.93 in ubuntu, and the push modules are built and loading it seems
(18:51:03) pvanhoof: Yes, but not working correctly in 0.6.9x
(18:51:25) chrisccoulson: that's probably why i can't get it to work then ;)
(18:51:32) pvanhoof: probably :)
(18:52:18) chrisccoulson: hmmmm, would you recommend i re-enable the old evolution indexer module? we disabled that completely in ubuntu
(18:53:20) pvanhoof: chrisccoulson, it wont work with the new evolution, which uses sqlite as storage

Jack Deslippe (jdeslip) wrote :

That discussion seems contradictory to the evolution changelog. It says they enabled push on 0.6.92:

http://mail.gnome.org/archives/tracker-list/2009-March/msg00078.html

Nothing in the 94 and 93 changelog suggests they turned it off.

Martin Pitt (pitti) wrote :

Not appropriate for an SRU target, since changes are too invasive.

Changed in tracker (Ubuntu Jaunty):
status: Triaged → Won't Fix
summary: - Tracker Evolution Eplug missing
+ Tracker does not index Evolution mails
Sheldon Hearn (sheldonh) wrote :

I see tracker still doesn't index Evolution emails in Karmic.

Sheldon Hearn (sheldonh) wrote :

And neither does Beagle. What have other people been using to index email for the last two Ubuntu releases?

Am Samstag, den 31.10.2009, 11:36 +0000 schrieb Sheldon Hearn:
> And neither does Beagle. What have other people been using to index
> email for the last two Ubuntu releases?

  The answer is simple: nothing.

  Which is a little bit annoying.

  Oliver

Jan Nekvasil (jan-nekvasil) wrote :

Tracker 0.7.x promises to enable Evolution support again. Is there still a chance that this version will be included in Lucid?
(Sorry for double posting this here and in "Answers" — I don't know where question like this belong (and will be possibly answered))

John Dong (jdong) wrote :

Removing ubuntu-sru per Martin's decision above..

@Sheldon Hearn
I'm using package recol as my desktop search engine.

cement_head (andorjkiss) wrote :

Using Tracker in Karmic from the following PPA: ppa:tracker-team/tracker-unstable

Tracker is attempting to index eMAILs but never accomplishes the task.

- CH

cement_head (andorjkiss) wrote :

Should I try this repo: ppa:tracker-team/tracker ?

Chris Coulson (chrisccoulson) wrote :

Yes, please use ppa:tracker-team/tracker instead. The tracker-unstable PPA is currently out-of-date whilst I prepare it for the 0.9.x unstable series, whilst the stable PPA is up-to-date

cement_head (andorjkiss) wrote :

@Chris Coulson

ppa:tracker-team/tracker caused evolution to hang. The email index showed only "initializing" but never accomplished the indexing.

Had to remove the packages using the ppa-purge script to default Karmic install.

Please notify this bug report when the 0.9.x is built and I'll try those out.

-CH

Florian Echtler (floe) wrote :

Just wanted to confirm that this bug is still occuring in Maverick with tracker-0.8.17-0ubuntu1. tracker-miner-evolution is installed and enabled in Evolution. Evolution shows on console:

Tracker-Message: Registering D-Bus service...
  Name:'org.freedesktop.Tracker1.Miner.Emails'
Tracker-Message: Registering D-Bus object...
Tracker-Message: Path:'/org/freedesktop/Tracker1/Miner/Emails'
Tracker-Message: Object Type:'TrackerEvolutionPlugin'
EI: MAIL PREFS

Nevertheless, no emails are ever indexed as indicated by .local/share/tracker/*.log. Is it possible that the push module in /usr/lib/tracker-0.8/push-modules/daemon is missing?

Michael Luthardt (michalu) wrote :

Same here with Maverick and Tracker 0.9.26. The Tracker applet shows trackerd is indexing Emails all the way but shows 0 % forever.
Evolution plugin is enabled.

Martin Pitt (pitti) on 2011-02-15
Changed in tracker (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → nobody
Changed in tracker (Ubuntu Jaunty):
assignee: Chris Coulson (chrisccoulson) → nobody

I have the same problem in Natty. It does look as if a file is missing in /usr/lib/tracker-0.8/push-modules/daemon.

FlashBuster (flashbuster) wrote :

Did someone ever get Evolution Mail Search to work? It seriously is a pain for me :(
Tracker stays at 0% initializing and this hasn't been working since many releases (actually never for me).
Why even distributing tracker-miner-evolution when it's not even working!?
(yes, i enabled the evolution plugin)

Sheldon Hearn (sheldonh) wrote :

On Fri, Jul 20, 2012 at 11:07 AM, FlashBuster <email address hidden> wrote:
> Did someone ever get Evolution Mail Search to work? It seriously is a pain for me :(

When last I looked at this, most of the C# stuff on which the Ximian
okes went mental is now abandonware, and so it's very hard to get
forward momentum going in the Ximian Desktop components like
Evolution.

I gave up on desktop search on *any* platform some time ago,
preferring to push my data into online services with good support for
search (e.g. Gmail).

Good luck!

Ciao,
Sheldon.

Thomas Pilarski (thomas.pi) wrote :

I installed thunderbird, which has an build in search. It works great. Tracker should be able to access the index, but I have never tested this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers