tracker indexes all the time even though only "one" folder with "one" file configured for indexing

Bug #353008 reported by Alexander Sack on 2009-04-01
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Tracker
Fix Committed
Undecided
Unassigned
tracker (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: tracker

I only have enabled one folder for indexing, which only contains one file. Still tracker is always indexing. Please fix this if tracker wants to become anything useful.

My config:

[General]
# Log Verbosity - Valid values are 0 (displays/logs only errors), 1 (minimal), 2 (detailed), and 3 (debug)
Verbosity=0

# Set the initial sleeping time, in seconds
InitialSleep=45

# Minimizes the use of memory but may slow indexing down
LowMemoryMode=false
# Set to TRUE when the home directory is in a NFS filesystem
NFSLocking=false

[Watches]
# List of directory roots to index and watch seperated by semicolons
WatchDirectoryRoots=/home/asac/test;
# List of directory roots to index but not watch (no live updates but are refreshed when trackerd is next restarted) seperated by semicolons
CrawlDirectory=
# List of directory roots to not index and not watch seperated by semicolons
NoWatchDirectory=
# Set to false to prevent watching of any kind
EnableWatching=true

[Indexing]
# Throttles the indexing process. Allowable values are 0-20. higher values decrease indexing speed
Throttle=0
# Disables the indexing process
EnableIndexing=true
# Enables indexing of a file's text contents
EnableFileContentIndexing=true
# Enables generation of thumbnails
EnableThumbnails=true
# List of partial file patterns (glob) seperated by semicolons that specify files to not index (basic stat info is only indexed for files that match these patterns)
NoIndexFileTypes=

# Sets minimum length of words to index
MinWordLength=3
# Sets maximum length of words to index (words are cropped if bigger than this)
MaxWordLength=30
# Sets the language specific stemmer and stopword list to use
# Valid values are 'en' (english), 'da' (danish), 'nl' (dutch), 'fi' (finnish), 'fr' (french), 'de' (german), 'it' (italien), 'nb' (norwegian), 'pt' (portugese), 'ru' (russian), 'es' (spanish), 'sv' (swedish)
Language=en
# Enables use of language-specific stemmer
EnableStemmer=true
# List of disabled modules (separator=;)
# The modules that are indexed are kept in $prefix/lib/tracker/indexer-modules
DisabledModules=
# Set to false to NOT hog the disk for extended periods
FastMerges=false
# Set the minimum length of words to index (0->30, default=3)
MinWorldLength=3
# Set the maximum length of words to index (0->200, default=30)
MaxWorldLength=30
# Set to true to disable indexing when running on battery
BatteryIndex=true
# Set to true to disable initial indexing when running on battery
BatteryIndexInitial=false
# Pause indexer when disk space is <= this value
# (0->100, value is in % of $HOME file system, -1=disable pausing)
LowDiskSpaceLimit=1
# Set to true to enable traversing mounted directories on other file systems
# (this excludes removable devices)
IndexMountedDirectories=false
# Set to true to enable traversing mounted directories for removable devices
IndexRemovableMedia=true

[Emails]
IndexEvolutionEmails=true

[Performance]
# Maximum size of text in bytes to index from a file's text contents
MaxTextToIndex=1048576
# Maximum number of unique words to index from a file's text contents
MaxWordsToIndex=10000
# Specifies the no of entities to index before determining whether to perform index optimization
OptimizationSweepCount=10000
# Sets the maximum bucket count for the indexer
MaxBucketCount=524288
# Sets the minimum bucket count
MinBucketCount=65536
# Sets no. of divisions of the index file
Dvisions=4
# Selects the desired ratio of used records to buckets to be used when optimizing index (should be a value between 0 and 4)
BucketRatio=1
# Alters how much padding is used to prevent index relocations. Higher values improve indexing speed but waste more disk space. Value should be in range (1..8)
Padding=2

Alexander Sack (asac) wrote :

importance high as this makes tracker completely unusable for anyone who doesnt want the complete HOME dir to be indexed.

Changed in tracker (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Martyn Russell (martyn-lanedo) wrote :

tracker-preferences allows you to change WHERE gets indexed, $HOME is the default and why shouldn't it be, from a fresh install, nothing exists to be indexed really. If it says it is always indexing then it can be one of two things.

1. The bug we fixed where the status was always indexing.
2. You have data constantly changing in that directory.

Chris Coulson (chrisccoulson) wrote :

Alex - are you using Evolution? I notice from your prefs that you still have Evolution indexing enabled. I thought I was experiencing this too, but the problem goes away if I disable Evolution indexing.

Chris Coulson (chrisccoulson) wrote :

I've added a dummy upstream task and set it to fixed so that I know to add this bug to the changelog entry when I prepare 0.7.0. The code causing this issue has all gone from git master now.

Changed in tracker:
status: New → Fix Released
Chris Coulson (chrisccoulson) wrote :

Technically it should be fix committed. Upstream have not done a 0.7.0 release yet

Changed in tracker:
status: Fix Released → Fix Committed
Miloš Mandarić (mandzo18) wrote :

I have this issue and my version of Tracker is 0.8.16-0ubuntu1 in Maverick. Is it possible that this isn't fixed in this version? Should I open a new bug?
Here is my problem in detail:
I added only Documents folder to index recursively and after few hours it has indexed every possible partition on my hard disc.
Here is my .config/tracker/tracker-miner-fs.cfg

[General]
# Log verbosity (0=errors, 1=minimal, 2=detailed, 3=debug)
Verbosity=0
# Time in seconds before crawling filesystem (0->1000)
InitialSleep=15

[Monitors]
# Set to false to completely disable any monitoring
EnableMonitors=true
# Time in seconds between same events to prevent flooding (0->1000)
ScanTimeout=0
# Time in seconds for events to be cached (0->1000)
CacheTimeout=60

[Indexing]
# Sets the indexing speed (0->20, where 20=slowest speed)
Throttle=0
# Set to true to index while running on battery
IndexOnBattery=false
# Set to true to index while running on battery for the first time only
IndexOnBatteryFirstTime=true
# Set to true to enable traversing mounted directories for removable devices
# (this includes optical discs)
IndexRemovableMedia=false
# Set to true to enable traversing CDs, DVDs, and generally optical media
# (if removable devices are not indexed, optical discs won't be either)
IndexOpticalDiscs=false
# Pause indexer when disk space is <= this value
# (0->100, value is in % of $HOME file system, -1=disable pausing)
LowDiskSpaceLimit=1
# List of directories to crawl recursively for indexing (separator=;)
# Special values include: (see /etc/xdg/user-dirs.defaults & $HOME/.config/user-dirs.default)
# &DESKTOP
# &DOCUMENTS
# &DOWNLOAD
# &MUSIC
# &PICTURES
# &PUBLIC_SHARE
# &TEMPLATES
# &VIDEOS
# If $HOME is the default below, it is because $HOME/.config/user-dirs.default was missing.
IndexRecursiveDirectories=&DOCUMENTS;
# List of directories to index but not sub-directories for changes (separator=;)
# Special values used for IndexRecursiveDirectories can also be used here
IndexSingleDirectories=
# List of directories to NOT crawl for indexing (separator=;)
IgnoredDirectories=po;CVS;core-dumps;lost+found;
# List of directories to NOT crawl for indexing based on child files (separator=;)
IgnoredDirectoriesWithContent=backup.metadata;
# List of files to NOT index (separator=;)
IgnoredFiles=*~;*.o;*.la;*.lo;*.loT;*.in;*.csproj;*.m4;*.rej;*.gmo;*.orig;*.pc;*.omf;*.aux;*.tmp;*.po;*.vmdk;*.vm*;*.nvram;*.part;*.rcore;lzo;autom4te;conftest;confstat;Makefile;SCCS;litmain.sh;libtool;config.status;confdefs.h;*.py;*.pyd;*.c;*.cpp;

Martyn Russell (martyn-lanedo) wrote :

Yes, that looks like a bug to me. Can you set Verbosity=3 and re-run tracker-control -ts to make sure we capture what is happening on startup. To find out how to do this see:

  http://live.gnome.org/Tracker/Documentation/Debugging

The logs should indicate which directories we are trying to index. Generally the important ones are: IndexRecursiveDirectories, IndexSingleDirectories, IndexRemovableMedia and IndexOpticalDiscs. they all seem to be sensible here though.

Miloš Mandarić (mandzo18) wrote :

I was able to workaround this bug by adding all partitions except / to
  IgnoredDirectories=po;CVS;core-dumps;lost+found;/media/ost;/media/win;/media/jaunty;

OK, I will reset everything again and collect logs. How much time should I wait? Because full indexing of my hdd takes 4+ hours.

Miloš Mandarić (mandzo18) wrote :

> I was able to workaround this bug by adding all partitions except / to
> IgnoredDirectories=po;CVS;core-dumps;lost+found;/media/ost;/media/win;/media/jaunty;

Which kind of partitions are /media/ost and /media/jaunty ? Are they external USB disks mounted, or internal ones?

Miloš Mandarić (mandzo18) wrote :

all internal

KeithG (grider-4) wrote :

I have some older hardware (Core 2 Duo 1.5) and unless I disable tracker, the computer is unusable. CPU 100%, CPU temps up to 85C. With it disabled, CPU idles at 47 and the old laptop is, at least, useful for light browsing, email, etc. Using Gnome shell. I have no clue what it is doing, but it thrashes for hours or until the CPU temps out. I did not notice this with 12.04, but with later versions it seems to be worse.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers