Tracker's Evolution mail indexation hangs Evolution

Bug #335911 reported by Jonathan Ernst on 2009-02-28
58
This bug affects 7 people
Affects Status Importance Assigned to Milestone
tracker (Ubuntu)
High
Ubuntu Desktop Bugs
Jaunty
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: tracker

Since some time on my Jaunty install, Evolution was not working. I was able to open it one time, then it was "hanging" while trying to display mails or send mails.

After closing Evolution, it was not possible to reopen it without rebooting (i.e. evolution --force-shutdown, didn't let it reopen)

I found that the culprit was not Evolution but tracker... Disabling Evolution mail indexing in tracker's preferences fixes the problem for me.

Related branches

Ben Crisford (bencrisford) wrote :

What distrobution are you using?

Changed in tracker:
status: New → Incomplete
Luís Silva (luis) wrote :

I have the same behaviour with ubuntu jaunty...

After the last update to tracker, I can open evolution an browse mail and folders for about 5 to 10 minutes. After that, evolution freezes and I can only shut it down with "evolution --force-shutdown". After evolution shutdown, it doesn't start again. Executing evolution in a command line also doesn't give any relevant error message... Only after a reboot I can startup evolution and the story repeats again.

Martyn Russell (martyn-lanedo) wrote :

We have seen several reports of this. It seems that our "peeking" at Evolution's SQLite database is causing Evolution problems and not doing us any favours either.

We have disabled support for the Evolution SQLite DB inspection code since it was causing problems with Evolution running and not responding. We have a new method which involves Evolution "pushing" data to Tracker instead and this will be enabled for release 0.6.92 coming this week.

Steve Beattie (sbeattie) on 2009-03-23
Changed in tracker:
status: Incomplete → Confirmed
importance: Undecided → High
assignee: nobody → canonical-desktop-team
Martin Pitt (pitti) wrote :

Robert, can you look into this? If not, please reassign back to canonical-desktop-team, and I'll find someone else. Thank you!

Changed in tracker (Ubuntu Jaunty):
assignee: canonical-desktop-team → robert-ancell
Sebastien Bacher (seb128) wrote :

reassigning this bug to desktop-bugs a desktop team contributor will do the update when the new tarball will be rolled

Changed in tracker (Ubuntu Jaunty):
assignee: robert-ancell → desktop-bugs
Tiefflieger (tiefflieger) wrote :

I'm having the same problem, but I can't disable mail indexing. Whenever I disable it, the tracker tells me that it must restart indexing. Then I clicked on "yes", but when I re-open the preferences, the option is re-enabled.

Is this part of this bug or is this another one?

Martyn Russell (martyn-lanedo) wrote :

Tiefflieger, what version are you using?

Tiefflieger (tiefflieger) wrote :

Tracker v0.6.91

Martyn Russell (martyn-lanedo) wrote :

Hmm, we did improve the preferences dialog (I am sure for 0.6.91) I am surprised to hear disabling mail doesn't work. Can you give me the exact steps you use so I can try to reproduce it?

Tiefflieger (tiefflieger) wrote :

I made a screen capture right after reboot and logging in :-) .

Ka-Hing Cheung (kahing) wrote :

According to reinouts on #tracker and http://mail.gnome.org/archives/tracker-list/2009-March/msg00078.html this is fixed in 0.6.92. Relevant ChangeLog entry:

- Disabled evolution module since it is problematic and lots of Evolution issues were reported - Enabled evolution push plugin (different to the Evolution module), non-intrusive, Evolution sends us the data

Jack Deslippe (jdeslip) wrote :

I also have this problem. Is there a 0.6.92 package for jaunty coming?

Martin Pitt (pitti) wrote :

Fixed upstream, waiting for new tarball.

Changed in tracker (Ubuntu Jaunty):
status: Confirmed → Fix Committed
kumar (kumar-physics) wrote :

I do have the same problem(I can't disable email indexing), waiting for the update
Thanks

Martyn Russell (martyn-lanedo) wrote :

OK, so I did test the same steps as in the screen cast and I couldn't reproduce it with TRUNK at the time. We just release (last Friday) tracker 0.6.92. I believe this is fixed and from what I have heard the packages should be integrated this week some time.

Martyn Russell (martyn-lanedo) wrote :

Also, I should add that we disabled Evolution support by default using the old plugin mechanism which "reads their mail" :) so to speak by peaking at the SQLite DBs. Now we use a "push" plugin so Evolution passes us the information we need. I believe this has to be enabled on the Evolution side and *should* be available in the Jaunty release.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tracker - 0.6.92-1ubuntu1

---------------
tracker (0.6.92-1ubuntu1) jaunty; urgency=low

  * Merge from debian unstable (LP: #353480), remaining changes:
    - debian/control:
      + Do not build-depend on universe dependencies:
        libunac1-dev, libqdbm-dev.
      + Build-depends on evolution-dev and e-d-s-dev (>= 2.25.5)
        for the new Evolution plugin.
      + tracker depends on procps.
    - debian/30-tracker.conf:
      + Increase maximum number of inotify watches to 524288.
    - debian/rules:
      + Don't build against the system qdbm library.
      + Pass --disable-unac to configure. The new version won't
        automatically build without UNAC support when it
        is not installed now.
    - debian/tracker.install:
      + Don't install the DBus service so trackerd is not automatically
        started when other software try to see if it's already running
      + Install tracker.py in /usr/share/apport/package-hooks/
    - debian/tracker.postinst:
      + Start procps to apply "sysctl.d/30-tracker.conf"
    - debian/tracker.py:
      + Added an apport hook to ignore tracker-extract crashes, since they
        are caused by setrlimit terminating tracker-extract when it raises
        it's cpu/memory limit.
    - debian/patches/03_dont_activate_indexing_and_watching.patch:
      + Don't active indexing nor watching as decided by the
        technical board.
    - debian/patches/02_no_kde_autostart.patch:
      + Do not autostart trackerd in KDE, as they have strigi.
    - debian/patches/11_drop_evolution_module.patch:
      + Don't build the old Evolution module (fixes LP: #335911).
    - 99_autotools.patch:
      + Recreate build system.
  * Other changes:
    - debian/rules:
      + Drop obsolete "--enable-external-sqlite" build option.

 -- Chris Coulson <email address hidden> Thu, 02 Apr 2009 17:40:15 +0100

Changed in tracker (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Jack Deslippe (jdeslip) wrote :

This version fixes the evolution crash. However, evolution emails no longer seem to be indexed at all...

Luís Silva (luis) wrote :

That's true for me too. After deleting ~/.cache/tracker/ and issuing a complete reindex the problem was solved.

But unfortunatelly evolution emails don't get indexed... And 0.93 doesn't index evolution emails also.

Jack Deslippe (jdeslip) wrote :

There was a new version of tracker released on 24th, 0.6.94 - perhaps evolution emails will be indexed again. I think we should change the status of this bug from fixed->released to something else because it is not really a fix. Now, no emails get indexed...

Jack Deslippe (jdeslip) wrote :

Ok, I see there is already a bug report for the missing evolution push plugin: Bug 360399 - So, I will leave this bug closed.

knownbad (knownbad-) wrote :

I am surprised to learn an important function of tracker has been disabled without better informing public.

Chris Coulson (chrisccoulson) wrote :

It's been disabled because it just doesn't work

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments