Please merge tracker 0.6.90-1 (main) from Debian experimental

Bug #329201 reported by Dmitry Korzhevin on 2009-02-13
6
Affects Status Importance Assigned to Milestone
tracker (Ubuntu)
Wishlist
Unassigned

Bug Description

Please update outdated version of tracker (0.6.6-2ubuntu3) included in Ubuntu 9.04 to latest version (0.6.90)

http://projects.gnome.org/tracker/

Related branches

Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report. That probably won't happen for 9.04 though - feature freeze is only a few days away and the Tracker update has some big changes, which also need some packaging changes too (it ships extra shared libraries which should go in to new binary packages etc), a lot of files moved around/changed name etc which messes up the packaging too. I attempted to package a recent SVN build (in my PPA), but it still requires more work

Changed in tracker:
importance: Undecided → Wishlist
status: New → Confirmed

FYI
http://packages.debian.org/experimental/tracker
http://git.debian.org/?p=users/biebl/tracker.git;a=summary (experimental branch)

I decided to *not* move libtracker-common and libtracker-module into
separate binary packages until they are moved to /usr/lib/ (and not
/usr/lib/tracker)

Cheers,
Michael

2009/2/13 Chris Coulson <email address hidden>:
> Thank you for your bug report. That probably won't happen for 9.04
> though - feature freeze is only a few days away and the Tracker update
> has some big changes, which also need some packaging changes too (it
> ships extra shared libraries which should go in to new binary packages
> etc), a lot of files moved around/changed name etc which messes up the
> packaging too. I attempted to package a recent SVN build (in my PPA),
> but it still requires more work
>
> ** Changed in: tracker (Ubuntu)
> Importance: Undecided => Wishlist
> Status: New => Confirmed
>
> ** Tags added: update
>
> --
> Please update tracker search system in Ubuntu 9.04
> https://bugs.launchpad.net/bugs/329201
> You received this bug notification because you are subscribed to tracker
> in ubuntu.
>

--
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

Thanks Michael.

I've prepared a merge with Experimental. Here is the delta to Debian

Chris Coulson (chrisccoulson) wrote :

And here is the 0.6.90-1ubuntu1.diff.gz

Changed in tracker:
status: Confirmed → Triaged
Daniel Holbach (dholbach) wrote :

Just FYI: the procps change was in Debian already, other than that great work! :)

In a future version these files could get installed too:
dh_install: usr/share/man/man1/tracker-services.1 exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/man/man1/tracker-files.1 exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/man/man1/tracker-applet.1 exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/man/man1/tracker-query.1 exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/man/man1/tracker-status.1 exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/man/man1/tracker-tag.1 exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/man/man1/tracker-meta-folder.1 exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/man/man1/trackerd.1 exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/man/man1/tracker-thumbnailer.1 exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/man/man1/tracker-search-tool.1 exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/man/man1/tracker-unique.1 exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/man/man1/tracker-search.1 exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/man/man1/tracker-extract.1 exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/man/man1/tracker-info.1 exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/man/man1/tracker-stats.1 exists in debian/tmp but is not installed to anywhere
dh_install: usr/share/man/man1/tracker-preferences.1 exists in debian/tmp but is not installed to anywhere

What do you think?

Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package tracker - 0.6.90-1ubuntu1

---------------
tracker (0.6.90-1ubuntu1) jaunty; urgency=low

  * Merge with Debian experimental, remaining changes (LP: #329201):
    - debian/control:
      + Do not build-depend on universe dependencies:
        libunac1-dev, libqdbm-dev.
      + Depend on python-gnome2-desktop (for patch 05_gnomedesktop.patch)
    - debian/patches/02_no_kde_autostart.patch:
      + Do not autostart trackerd in KDE, as they have strigi.
    - debian/patches/03_dont_activate_indexing_and_watching.patch:
      + Don't active indexing nor watching as decided by the
        technical board.
    - debian/patches/05_gnomedesktop.patch:
      + Use python module gnomedesktop directly rather than
        deskbar.core.gnomedesktop python module
    - debian/rules:
      + Enable sqlite external db instead of qdbm.
      + Pass --disable-unac to configure. The new version won't
        automatically build without UNAC support when it
        is not installed now.
    - debian/30-tracker.conf:
      + Increase maximum number of inotify watches to 524288.
    - debian/tracker.py:
      + Added an apport hook to ignore tracker-extract crashes, since they
        are caused by setrlimit terminating tracker-extract when it raises
        it's cpu/memory limit.
    - debian/tracker.install:
      + Don't install the DBus service so tracker is not automatically
        started when other software try to see if it's already running
      + Install tracker.py in /usr/share/apport/package-hooks/
    - debian/tracker.postinst:
      + Start procps to apply "sysctl.d/30-tracker.conf"
  * Patches converted to quilt and updated for new version:
    - 02_no_kde_autostart.patch
    - 03_dont_activate_indexing_and_watching.patch
    - 05_gnomedesktop.patch
  * Dropped patches:
    - 04_Correct_spelling_of_additional.patch (merged upstream)
    - email-crasher.patch (the patch is obsolete now)

tracker (0.6.90-1) experimental; urgency=low

  * New upstream release.
    - Adds proper D-Bus introspection support. Closes: #411778
    - Limit of search results can now be specified via the --limit option for
      tracker-{query,tag,files}. Closes: #430621
  * debian/patches/02-static_keywords_reply.patch
    - Removed, merged upstream.
  * debian/patches/03-prefer_odt2txt.patch
    - Removed, merged upstream.
  * debian/patches/01-secure_tmpdir.patch
    - Update to the latest upstream changes.
    - Output the resulting text file to stdout.
  * Switch patch management system to quilt.
  * debian/compat
    - Bump to debhelper v7 compat mode.
  * debian/control
    - Update Build-Depends
      + Bump debhelper to (>= 7).
      + Bump libglib2.0-dev to (>= 2.16.0).
      + Bump libgstreamer0.10-dev to (>= 0.10.12).
      + Add libgstreamer-plugins-base0.10-dev (>= 0.10.12).
      + Replace libxml-parser-perl with intltool.
      + Drop libgnomevfs2-dev.
      + Add libtotem-plparser-dev.
      + Add libraptor1-dev.
      + Add libhal-storage-dev (>= 0.5).
      + Add libtiff4-dev.
    - Add ${misc:Depends} to all packages.
    - Add tracker (= ${binary:Version}) to tracker-dbg.
  * Bump Standards-Version to 3.8.0. Add README.s...

Read more...

Changed in tracker:
status: Triaged → Fix Released

2009/2/17 Daniel Holbach <email address hidden>:
> Just FYI: the procps change was in Debian already, other than that great
> work! :)
>
> In a future version these files could get installed too:
> dh_install: usr/share/man/man1/tracker-services.1 exists in debian/tmp but is not installed to anywhere
> dh_install: usr/share/man/man1/tracker-files.1 exists in debian/tmp but is not installed to anywhere
> dh_install: usr/share/man/man1/tracker-applet.1 exists in debian/tmp but is not installed to anywhere
> dh_install: usr/share/man/man1/tracker-query.1 exists in debian/tmp but is not installed to anywhere
> dh_install: usr/share/man/man1/tracker-status.1 exists in debian/tmp but is not installed to anywhere
> dh_install: usr/share/man/man1/tracker-tag.1 exists in debian/tmp but is not installed to anywhere
> dh_install: usr/share/man/man1/tracker-meta-folder.1 exists in debian/tmp but is not installed to anywhere
> dh_install: usr/share/man/man1/trackerd.1 exists in debian/tmp but is not installed to anywhere
> dh_install: usr/share/man/man1/tracker-thumbnailer.1 exists in debian/tmp but is not installed to anywhere
> dh_install: usr/share/man/man1/tracker-search-tool.1 exists in debian/tmp but is not installed to anywhere
> dh_install: usr/share/man/man1/tracker-unique.1 exists in debian/tmp but is not installed to anywhere
> dh_install: usr/share/man/man1/tracker-search.1 exists in debian/tmp but is not installed to anywhere
> dh_install: usr/share/man/man1/tracker-extract.1 exists in debian/tmp but is not installed to anywhere
> dh_install: usr/share/man/man1/tracker-info.1 exists in debian/tmp but is not installed to anywhere
> dh_install: usr/share/man/man1/tracker-stats.1 exists in debian/tmp but is not installed to anywhere
> dh_install: usr/share/man/man1/tracker-preferences.1 exists in debian/tmp but is not installed to anywhere
>
> What do you think?

They are installed. list-missing doesn't pick them up because they are gzipped.

Cheers,
Michael
--
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers