ooo-thumbnailer - Thumbnails for Openoffice.org documents

Bug #25827 reported by Wouter Stomp on 2005-11-16
112
This bug affects 13 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Wishlist
Ubuntu Desktop Bugs
ooo-thumbnailer (Ubuntu)
Medium
Chris Cheney
openoffice.org (Mandriva)
Unknown
Wishlist
tracker (Ubuntu)
Wishlist
Unassigned

Bug Description

It would be nice to show thumbnails for openoffice documents in nautilus. A
howto for doing this can be found here:
http://doc.gwos.org/index.php/Thumbnails_Ooo2

Sebastien Bacher (seb128) wrote :

Thanks for your bug. That's a cool feature, the place to ship it is probably not
nautilus but we will figure quite easily. I'll speak with upstream about that.

Andrew Jorgensen (ajorg) wrote :

Wasn't evince working on an OOo viewer? If they are then thumbnails for OOo docs will come along when that's finished, right?

Sebastien Bacher (seb128) wrote :

They have some work on it but upstream is feature frozen now so that will probably not happen for dapper

And the method from http://doc.gwos.org/index.php/Thumbnails_Ooo2 can't be used for dapper?

Sebastien Bacher (seb128) wrote :

If somebody contribute to an integrated and tested patch before feature freeze it can be shipped with dapper, you are welcome to work on it :)

Changed in nautilus:
assignee: seb128 → desktop-bugs

Sadly I don't have anough knowledge to do that, but I'll try finding someone who can do it on the forums.

Richard Laager (rlaager) wrote :

Does this maybe belong in openoffice.org-gnome?

I wonder if the python dependency would be a problem or not... The initial version of the script could be easily reworked to be in C using GnomeVFS (which isn't a new dependency) and zlib (which shouldn't be very problematic). But... all the image manipulation... I'm not sure about that. I suppose that could be done with gdk-pixbuf, which shouldn't be a problematic dependency either.

Martin Bergner (martin-bergner) wrote :

gnome-app-install is written in python, IIRC, so that shouldn't be a problem. So again the question, why is the script at http://doc.gwos.org/index.php/Thumbnails_Ooo2 not appropriate?

Richard Laager (rlaager) wrote :

There's an updated script at this forum: http://www.ubuntuforums.org/showthread.php?t=76566&page=3

Sebastien Bacher (seb128) wrote :

didn't get worked during that cycle, if anybody wants to work on getting that integrated next cycle he's welcome. Dropping the dapper milestone for now

MrRio (rio-x5g) wrote :

I'll work on getting this done for edgy.

Nikolaus Filus (nfilus) wrote :

Voting against this in it's current form: tried it and removed it after short time.

- The thumbnail background is transparent and it looks unreadable in any other view than nautilus window with white background (ex. Desktop with wallpaper).

- Most spreadsheet previews look meaningless and one has to look explicitly at file extension to identify the type of file, which is much better reflected by the default icon. Presentations, Drawings and some text document may look better and more distinguishable.

(if Nautilus would at least zoom the preview with mouse over, like it's done in KDE ...)

Try the updated script from http://ubuntuforums.org/showthread.php?t=76566, don't remember exactly which page, but I've attached a script that were posted on that thread.

 - It doesn't have transparent background on thumbnails
 - It attaches a small icon to help identify whether it's a spreadsheet, word document, presentation, etc...

I hope someone will add this for a future version of Ubuntu, other distros like SuSE have had for a long time.

noddeat (noddeat) wrote :

So and what? Two years past and still we don't have this in Gutsy. Is it a complicated thing to add? It already works in Fedora 8, why not in Ubuntu?

And also, will it disappear if i upgrade my system to another version (e.g. 8.04) ?

Michael Nagel (nailor) wrote :

update...:

there is a brainstorm item: http://brainstorm.ubuntu.com/idea/4367/
there is a blueprint: https://blueprints.launchpad.net/awn/+spec/ooo-thumbnails
there are working solutions: http://nailor.devzero.de/nwiki/Computer/MiscTipps/odt_thumbnails_in_nautilus (taken from http://nailor.devzero.de/nwiki/Computer/MiscTipps/odt_thumbnails_in_nautilus )

one could really include it quite easily... any volunteers?

Michael Nagel (nailor) wrote :
Sebastien Bacher (seb128) wrote :

reassigning to openoffice.org, that will not be changed in nautilus which is not the right place to add random thumbnailer for other format, either that should be something shipped in openoffice which is the application which knows how to read those or a new thumbnailer source package should be created

Changed in nautilus:
assignee: desktop-bugs → nobody
status: Confirmed → New

Gnome Bug about this which has just been closed as NOTGNOME and proposed to be filed under OOo bugs.
But I can't add any other external bugs....
http://bugzilla.gnome.org/show_bug.cgi?id=347694

A. Walton (awalton) wrote :

Hubert Figuiere would like to remind us that libgsf (one of the libraries for Abiword) also ships a thumbnailer for ODF files, but since Ubuntu doesn't ship GNOME's office tools by default, and we do ship OpenOffice, this should be taken care of by OpenOffice. In general, this is an OpenOffice bug. The Nautilus bug was invalid since its creation.

Sebastien Bacher (seb128) wrote :

that's not a nautilus bug

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: New → Invalid
Chris Cheney (ccheney) on 2008-10-31
Changed in openoffice.org:
status: New → Triaged
Chris Cheney (ccheney) wrote :

I read on the ubuntu-desktop mailing list that Tracker already can do this but maybe isn't enabled by default?

Changed in openoffice.org:
status: Triaged → New
Michael Nagel (nailor) wrote :

i dont think this is correctly filed against tracker.

the bug i am talking about is that you do not get thumbnails for odt files in nautilus like you get for pdfs.

i do not know too much of the technical details about thumbnail generation, but the only two programs that make sense to be responsible for generating and displaying the thumbnails are nautilus itself (or a plugin/addon) and the word processor (i.e. open office) (or a plugin/addon).

®om (rom1v) wrote :

It doesn't work yet in jaunty alpha… is it planned to be fixed for jaunty?

Sebastien Bacher (seb128) wrote :

not that I know but you are welcome to contribute there

KillerKiwi (killerkiwi2005) wrote :

The thumbnails already exist.. they are in the odt files... all this requires is a gconf key and about 2 lines of bash to extract the icon from the zip file like thunar does.. in a package

I can do the code and gconf if some one can package it.....

Michael Nagel (nailor) on 2009-03-06
Changed in nautilus:
status: Invalid → New
Sebastien Bacher (seb128) wrote :

that is NOT a nautilus bug stop reopening this task

Changed in nautilus:
status: New → Invalid
KillerKiwi (killerkiwi2005) wrote :

Here it is
https://code.launchpad.net/~killerkiwi2005/+junk/ooo-thumbnailer

Tested with Intrepid and Jaunty

Please test and include

Chris Cheney (ccheney) wrote :

KillerKiwi,

Thanks I will look into this and try to get it in this week if possible.

Chris

Changed in openoffice.org:
assignee: nobody → ccheney
importance: Undecided → Medium
milestone: none → jaunty-alpha-6
status: New → Triaged
Chris Cheney (ccheney) wrote :

Unfortunately the code is listed as having no license at the moment so I can't upload it until it does.

Chris

Chris Cheney (ccheney) wrote :

Also please switch it to using default python instead of python2.5 if possible or change it to use python2.6 if it has to be hardcoded.

Chris Cheney (ccheney) wrote :

Also I think we need the authors real names in the copyright file and the python script, currently the python script has a place holder on the BSD license for the authors real name.

Chris Cheney (ccheney) wrote :

And the README says this:

This script was taken from http://ubuntuforums.org/showthread.php?t=76566 , was taken without permission.

which probably needs to be resolved whether we have permission to distribute this at all...

Martin Pitt (pitti) wrote :

Keeping one bug task open is enough; closing the tracker one.

Changed in tracker:
status: New → Invalid
Martin Pitt (pitti) wrote :

My woe with that (aside from the license issues above) is that this will call a new Python instance for each and every OOo document that you have in a directory. This is a very expensive operation, so it'll drain a lot of CPU and I/O resources.

Of course this is equally true for video thumbnails, which are also awfully expensive. I just wonder whether we should aggravate the problem with more file types, by default.

But aside from that, of course there is no reason whatsoever to not put it at least in universe. For jaunty, getting it into main and installed by default is a bit late.

TAC one (tacone) wrote :

@pitti: what would be a solution ? Rewriting in C ? Are there better ways to do thumbnails?

Martin Pitt (pitti) wrote :

Rewriting in C would reduce the overhead significantly already. I'm afraid I don't know whether there are better ways; maybe the code can be integrated into some existing thumbnailer, to reuse its build system and programs.

But as I said, while this is an opt-in, and not installed by default, then efficiency doesn't really matter much.

Chris Cheney (ccheney) on 2009-03-09
Changed in openoffice.org:
milestone: jaunty-alpha-6 → ubuntu-9.04-beta
KillerKiwi (killerkiwi2005) wrote :

We could just use an sh script (which is what thunar does already using ImageMagick. http://goodies.xfce.org/projects/thunar-plugins/thunar-thumbnailers/).. the only reason its in python at the moment is some niceness about not templating the ~/Templates and making the background color white instead of transparent.

Heh, nice; you need to change the copyright header, and some comments, BTW :-)

This requires imagemagick, though, which isn't installed by default. However, why not use GNOME's own thumbnailer? It also converts transparency into white:

$ unzip -p /usr/share/example-content/oo-maxwell.odt Thumbnails/thumbnail.png > /tmp/thumbnail.png
$ gnome-video-thumbnailer /tmp/thumbnail.png /tmp/nautilus-thumbnail.png

/tmp/nautilus-thumbnail.png looks just fine to me.

Sorry, last comment was from me. I didn't intend to cover myself, I
was just still logged in as apport to do some retracer cleanup. :-)

Film has made an updated copy using sh script and gnome-video-thumbnailer

see http://ubuntuforums.org/showpost.php?p=6878603&postcount=78

Looks like this has been implemented in jaunty, see the attached image of my nautilus window.

Sorry, I misunderstood the bug report, just ignore me...

David D Lowe (flimm) wrote :

I've written a thumbnailer bash script, that uses imagemagick if it's installed, if not, totem-gstreamer-video-thumbnailer. Unfortunately, the latter puts "film strips" or "film rolls" in the image, giving the user the impression that the file is a video, not a document. Any one know how I could disable this behaviour? Is there another program that's installed by default that I could use? evince-thumbnailer unfortunately keeps the transparency in the image.

Chris Cheney (ccheney) on 2009-03-21
Changed in openoffice.org (Ubuntu):
milestone: ubuntu-9.04-beta → ubuntu-9.04
KillerKiwi (killerkiwi2005) wrote :

David try evince-thumbnailer !! its the same thumbnailer that does the PDF's even

Chris Cheney (ccheney) on 2009-04-09
Changed in openoffice.org (Ubuntu):
status: Triaged → Fix Committed
Chris Cheney (ccheney) wrote :

It's now sitting in new waiting to be processed for universe.

Chris Cheney (ccheney) on 2009-04-09
tags: added: needs-packaging
summary: - Thumbnails for Openoffice.org documents
+ ooo-thumbnailer - Thumbnails for Openoffice.org documents
Chris Cheney (ccheney) wrote :

I have it uploaded to revu with some changes, once it is approved I will send the resulting debdiff back to Flimm.

http://revu.ubuntuwire.com/p/ooo-thumbnailer

Changed in openoffice.org (Ubuntu):
status: Fix Committed → In Progress
Chris Cheney (ccheney) wrote :

I have uploaded the resulting package from going through REVU process to jaunty but it is waiting in NEW.

Michael Nagel (nailor) wrote :

has this made it to jaunty? if not, will it be in karmic?

The package is in Karmic, but obviously won't make it into Jaunty. Though it could be marked as 'Fix Released' I guess.

Michael Nagel (nailor) wrote :

can you provide a link to it on packages.ubuntu.com? i cannot find it there. will open office depend on it? and if yes, what version of open office (standard or full) will depend on it?

See https://launchpad.net/ubuntu/+source/ooo-thumbnailer/0.1~alpha2-1

It's not in the repos yet because it failed to build apparently. OpenOffice.org won't depend on it, rather the contrary... If you wanted to know if it would be installed by default, the answer is no - for now. It should be promoted to main, which can be discussed here for a start. But first it should be built correctly... :-)

Chris Cheney (ccheney) on 2009-06-08
affects: openoffice.org (Ubuntu) → ooo-thumbnailer (Ubuntu)
Changed in ooo-thumbnailer (Ubuntu):
milestone: ubuntu-9.04 → karmic-alpha-3
status: In Progress → Triaged
Michael Nagel (nailor) wrote :

python script locations have changes somehow:

dh_builddeb -pooo-thumbnailer Found files in /usr/lib/python2.6/site-packages (must be in dist-packages for python2.6)

could you fix it in the package and re-upload? thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ooo-thumbnailer - 0.1~alpha2-1ubuntu1

---------------
ooo-thumbnailer (0.1~alpha2-1ubuntu1) karmic; urgency=low

  * Add missing XB-Python-Version to debian/control (fixes FTBFS, lp: #25827)

 -- Michael Bienia <email address hidden> Fri, 04 Sep 2009 11:06:38 +0200

Changed in ooo-thumbnailer (Ubuntu):
status: Triaged → Fix Released
David D Lowe (flimm) wrote :

I've uploaded a better version to revu, could whoever uploaded it to Debian do the same again please? The new version depends on imagemagick until this bug is fixed: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=546663

Changed in openoffice.org (Mandriva):
status: Unknown → Confirmed
David D Lowe (flimm) wrote :

I've discovered a packaged that does this already: libgsf-bin. It also handles Microsoft Office files. All its dependencies are included in the default install. Is there any way I can suggest it be included by default?

Changed in openoffice.org (Mandriva):
importance: Unknown → Wishlist
Changed in openoffice.org (Mandriva):
status: Confirmed → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.