tracker search tool never finds anything

Bug #190844 reported by Jeffrey Baker on 2008-02-11
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
tracker (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: tracker

Using hardy alpha with tracker 0.6.4, tracker never returns any results. I have tried using the tracker notification applet and the deskbar to launch the search. Regardless of what I search for, valid strings which are in lots of files in my home directory and on my desktop, and despite the fact that tracker goes crazy every time I create a file, no results are ever found. The exact message is "Your search returned no results."

Jeffrey Baker (jwbaker) wrote :

Here's the output of tracker-stats:

-------fetching index stats---------

default : 0
Files : 1054
Folders : 35
Documents : 416
Images : 137
Music : 0
Videos : 0
Text : 131
Development : 6
Other : 329
Emails : 0
EvolutionEmails : 0
ThunderbirdEmails : 0
KMailEmails : 0
EmailAttachments : 0
EvolutionAttachments : 0
KMailAttachments : 0
Conversations : 0
GaimConversations : 0
Applications : 244
------------------------------------

Works as expected for me with tracker 0.6.4-1ubuntu1. Can you confirm if this still occurs for you with all updates applied?

Jeffrey Baker (jwbaker) wrote :

It still doesn't work:

jwb@stinkpad:~$ tracker-stats | grep Files\ :
Files : 1998
jwb@stinkpad:~$ echo banana > test.txt
jwb@stinkpad:~$ tracker-stats | grep Files\ :
Files : 1999
jwb@stinkpad:~$ tracker-search banana
jwb@stinkpad:~$ dpkg -l tracker | grep tracker
ii tracker 0.6.4-1ubuntu1 metadata database, indexer and search tool

Jeffrey Baker (jwbaker) wrote :

I purged tracker, killed it, deleted its databases, and reinstalled it. Tracker went through the whole circus of finding all my files, running them through pdftotext, wv, w3m, etc. This had no effect: tracker-search still returns no results, as above.

Using your test case above, it still works as expected for me finding test.txt with no problem. Possibly an arch specific bug? I tested on i386, which arch are you using?

Rafal Kwasny (mag) wrote :

I confirm tracker is not finding anything, I've got 64bit install

Ubuntu Hardy, updated as of 2008-03-10

tracker 0.6.6-0ubuntu1

I have a similar error, which may or may not be the same:

Tracker stops returning any results after a while, some period of time that I have yet to pin down. Everything looks perfectly normal in tracker-status (idle) and tracker-stats, as well as in the applet. Everything is responsive, but no tool can get any answer, not command line, not search tool, not deskbar, not any external application.

"killall trackerd" makes it work instantly.

I haven't yet found out what triggers this, it is capable of surviving suspend/resume, which was my first suspect, as I do that often.

Jeffrey Baker (jwbaker) wrote :

That's a different bug, because killing trackerd has no effect in my case. You should open (or find) a different bug report for that.

Thought so, but this was the only similar bug I found, so tried it first to avoid unnecessary duplicates.

Robert Jordens (jordens) wrote :

This (no results, sometimes temporarily cured by restarting trackerd) happens for me in hardy and intrepid (as of today)

Daniel T Chen (crimsun) on 2008-11-28
Changed in tracker:
status: New → Confirmed
Paul (b01) wrote :

Ubuntu 8.04.1
Tracker 0.6.6-0ubuntu3

Same problem of no results at all. Is cured (temporarily) by killing and restarting trackerd.

Tracker 0.6.6-1ubuntu5.1 on 8.10 still completely silent. Killing and restarting trackerd dosesn't work for me.
Added to the fact of the buggy behaviour with .tex and .txt files, and the inability to track ThunderBird mailboxes, it is quite annoying... that's a pity because tracker has a great potential to be a kill-tool. Please keep up the good work and try to solve the problems...

Trying to re-index now.

(reference to the .tex problem: https://bugs.launchpad.net/ubuntu/+source/tracker/+bug/225611)

Paul (b01) wrote :

Is this still valid in Lucid or Maverick with latest Tracker version?

I restarted tracker (it disappeared after upgrade, at least the icon) and again, no results for any search, nor .tex nor anything.
So I did

tracker-control -t
tracker-control -r
tracker-control -s

and then started by hand tracker-preferences. I told to show the icon everytime, but there is no icon visible. I had to start tracker-status-icon by hand. And the icon says that the index is at 100%, which is impossible, I just started it.

And btw, no mail are indexed (it is greyed out), but I cannot find the place to enable it. tracker-miner-evolution is installed.

I tried to reinstall all the tracker packages, no joy. Maybe some old config sticking around? I deleted $HOME/.config/tracker by hand, but it didn't help.

Suggestions, please?

Ok. I re-did, deleting the $HOME/.cache/tracker directory completely, which seems that tracker-control -r did not remove completely. This was the content of the dir:

(0)pern:~/.cache/tracker% ls -l
total 212396
-rw-r--r-- 1 romano romano 3072 2010-11-23 10:23 contents.db
-rw-r--r-- 1 romano romano 2 2010-11-10 11:15 db-version.txt
-rw-r--r-- 1 romano romano 3072 2010-09-23 10:53 email-contents.db
-rw-r--r-- 1 romano romano 2359292 2010-11-05 15:22 email-index.db
-rw-r--r-- 1 romano romano 34816 2010-09-23 10:53 email-meta.db
-rw-r--r-- 1 romano romano 44444672 2010-11-05 15:16 file-contents.db
-rw-r--r-- 1 romano romano 131203608 2010-11-05 15:22 file-index.db
-rw-r--r-- 1 romano romano 37533696 2010-11-05 15:17 file-meta.db
-rw-r--r-- 1 romano romano 40960 2010-11-23 10:23 fulltext.db
-rw-r--r-- 1 romano romano 1619968 2010-11-23 10:23 meta.db

and tracker-control -r removed only meta.db, contents.db, fulltext.db.

I suppose this is a mess from the upgrading. Now the applet (that I had to restart by hand, again) show a 3% indexed, which is
quite correct.

And the search seems to work ok.

Ok, I found out that the mail search indicator works if evolution is running.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers