tracker search hangs and never returns results

Bug #1861358 reported by Christoph Gohle
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
tracker (Ubuntu)
High
Unassigned
Focal
Undecided
Unassigned

Bug Description

* Impact
the tracker search utility isn't working

* Test case
$ tracker search something

it should return results if there are any matching items

* regression potential
it's a build flag change, just check that the tracker search works including in the desktop and nautilus

----------

When I run

$ tracker search -f Bruni

I see the following output on console
-------------
(tracker search:11112): GLib-GObject-WARNING **: 00:31:10.761: cannot register existing type 'TrackerLanguage'

(tracker search:11112): GLib-GObject-WARNING **: 00:31:10.761: cannot add private field to invalid (non-instantiatable) type '<invalid>'

(tracker search:11112): GLib-CRITICAL **: 00:31:10.761: g_once_init_leave: assertion 'result != 0' failed

(tracker search:11112): GLib-GObject-CRITICAL **: 00:31:10.761: g_object_new_valist: assertion 'G_TYPE_IS_OBJECT (object_type)' failed
---------------------

The program hangs and never returns. Sending Control-C brings me back to prompt

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: tracker 2.3.0-1
ProcVersionSignature: Ubuntu 5.3.0-29.31-generic 5.3.13
Uname: Linux 5.3.0-29-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu8.2
Architecture: amd64
Date: Thu Jan 30 00:31:59 2020
ExecutablePath: /usr/bin/tracker
InstallationDate: Installed on 2016-11-05 (1180 days ago)
InstallationMedia: Ubuntu-Server 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
SourcePackage: tracker
UpgradeStatus: Upgraded to eoan on 2020-01-21 (8 days ago)

Revision history for this message
Christoph Gohle (gohle2) wrote :
Revision history for this message
Christoph Gohle (gohle2) wrote :

I also found a similar bug report here:
https://gitlab.gnome.org/GNOME/tracker/issues/161

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tracker (Ubuntu):
status: New → Confirmed
description: updated
Changed in tracker (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tracker - 2.3.6-2

---------------
tracker (2.3.6-2) unstable; urgency=medium

  * debian/rules:
    - build without Bsymbolic and strip Bsymbolic-function, fixes the
      tracker search hanging on Ubuntu (lp: #1861358)

 -- Sebastien Bacher <email address hidden> Thu, 17 Sep 2020 16:18:10 +0200

Changed in tracker (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
gebi (gebi) wrote :

As this is a regression in 20.04, I'm asking if there is a backport planned ?

Revision history for this message
Chris Halse Rogers (raof) wrote : Please test proposed package

Hello Christoph, or anyone else affected,

Accepted tracker into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/tracker/2.3.6-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in tracker (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (tracker/2.3.6-0ubuntu1)

All autopkgtests for the newly accepted tracker (2.3.6-0ubuntu1) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

tracker/2.3.6-0ubuntu1 (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#tracker

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Lennart Karssen (l.c.karssen) wrote :

This is to confirm that the package in 'proposed' works. I installed tracker 2.3.6-0-ubuntu1 from 'focal-proposed' and when running 'tracker search something' I get actual search results (and no more Glib warnings).

tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
Christoph Gohle (gohle2) wrote :

I have teste the package from focal proposed.

I confirm that searches work with the updated package. However, tracker-miner-fs and tracker-extract get removed when installing because of the update to libtracker-control and libtracker-sparql. This should be fixed before backporting.

Revision history for this message
Christoph Gohle (gohle2) wrote :

I have to correct myself. Using selective upgrades the correct upgrade command is

$ sudo apt upgrade libtracker-miner-2.0-0/focal-proposed libtracker-control-2.0-0/focal-proposed libtracker-sparql-2.0-0/focal-proposed tracker/focal-proposed

in this case tracker installs correctly and seems to work.

Cheers,
Christoph

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tracker - 2.3.6-0ubuntu1

---------------
tracker (2.3.6-0ubuntu1) focal; urgency=medium

  * New upstream version (lp: #1896073)
  * debian/rules:
    - build without Bsymbolic and strip Bsymbolic-function, fixes the
      tracker search hanging (lp: #1861358)
  * tracker.install: Drop XDG autostart file for tracker-store. Dropped
    upstream, tracker uses DBus activation. Include new manpage

 -- Sebastien Bacher <email address hidden> Thu, 17 Sep 2020 17:03:10 +0200

Changed in tracker (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for tracker has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.