trackerd crashed with SIGSEGV

Bug #182712 reported by Daniel Karlsson on 2008-01-13
94
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tracker (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: tracker

Crashes shortly after boot every time.

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Sun Jan 13 23:43:02 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/trackerd
Package: tracker 0.6.4-1ubuntu1
PackageArchitecture: i386
ProcCmdline: trackerd
ProcCwd: /home/danka
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: tracker
Stacktrace:
 #0 0x08071cc4 in ?? ()
 #1 0x08124d50 in ?? ()
 #2 0x082a5e60 in ?? ()
 #3 0x00000000 in ?? ()
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: trackerd crashed with SIGSEGV
Uname: Linux oin 2.6.24-3-generic #1 SMP Thu Jan 3 23:30:29 UTC 2008 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin netdev plugdev powerdev scanner video

Related branches

Daniel Karlsson (danka) wrote :

StacktraceTop:index_mail_messages_by_summary_file (db_con=0x8124d50,
evolution_index_file (db_con=0x8124d50, info=0x8243b18)
tracker_email_index_file (db_con=0x8124d50, info=0x8243b18,
process_files_thread () at trackerd.c:909
g_thread_create_proxy (data=0x80fa570)

Changed in tracker:
importance: Undecided → Medium
Paulo J. S. Silva (pjssilva) wrote :

I am moving here from bug

https://bugs.launchpad.net/ubuntu/+source/tracker/+bug/148938

Emilio, should I move some information from that bug report here?

Paulo J. S. Silva (pjssilva) wrote :

I new twist...

I have just discovered that I can avoid the crash if:

1) I delete all the emails in the problematic sub-folders before doing a full re-index
2) Re-index all the files and emails
3) Download again the problematic emails and let trackerd index them.

Tracker then finishes indexing all the emails and it doesn't crash any more!

The only problem is that it doesn't fully index many emails with the following message:

 ERROR: could not get file id for email://1201090646.15521.0@trinity/INBOX/Trabalho/Mac;uid=3617/unnamed - unable to continue indexing this file

However I believe that this is another problem not directly related with this bug.

I believe this is fixed but pls reopen if its not

Changed in tracker:
status: New → Fix Committed
Changed in tracker:
status: Fix Committed → Fix Released
Erik I (erik-itland) wrote :

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

bug still appears to be here

Changed in tracker:
status: Fix Released → Confirmed

possible patch that might fix crasher

Paulo J. S. Silva (pjssilva) wrote :

I had the bug in feisty and after compiling and svn version it seemed gone.

Now I upgraded to Hardy and the bug is back. I can easily reproduce it using a stripped version of my email structure as a evolution backup. Since this data has personal information I can not put it here as an attachment. But I can send it if a developer wants it and contact me directly be email. Jamie already has access to it.

The good news is that applying Jamie's patch above to the Hardy's tracker source make the bug disappear. So it looks like we get a fix.

Changed in tracker:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tracker - 0.6.6-0ubuntu3

---------------
tracker (0.6.6-0ubuntu3) hardy; urgency=low

  * debian/patches/email-crasher.patch:
    - Patch by upstream, fix crash on mail indexing. LP: #182712.
      Thanks to Jamie McCracken for providing the patch.

 -- Emilio Pozuelo Monfort <email address hidden> Wed, 02 Apr 2008 18:51:37 +0200

Changed in tracker:
status: In Progress → Fix Released
billytalent (billytalent) wrote :

just happened to me in Jaunty Beta..

By the way.... i was testing suspend and resume.. and the tests went fine.. now my computer automatically shutsdown.. every hour or so..even when its active... how do i disable the tests ?

Paul O'Keefe (pbokeefe) wrote :

Just enabled tracker on a system where I had not been running it and immediately hit the SIGSEGV error.

Eugene Crosser (crosser) wrote :

On jaunty, I have unchecked "Enable indexing", unchecked "Index mounted directories", and "/media" added to "Ignored paths". However, almost every time I insert an SD card and it gets automounted, I get a "crash report" window about segfault in tracker-indexer, and after that a busylooping tracker-indexer process that I have to kill by hand.

Linux pccross 2.6.28-11-generic #40-Ubuntu SMP Fri Apr 3 17:39:41 UTC 2009 x86_64 GNU/Linux
tracker:
  Installed: 0.6.92-1ubuntu1

Eugene

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers