[Hardy] tracker results window is empty despite search results being found

Bug #181010 reported by Rhadamanthos on 2008-01-07
This bug report is a duplicate of:  Bug #163544: tracker search tool shows no results. Edit Remove
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tracker (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libdeskbar-tracker

Via some other Tracker bugs, found out that Tracker will not return search results until after the indexing is completed, so tried the following on the command line:

rhadamanthos@QuinMantha:~$ tracker-status
Tracker daemon's status is Idle
rhadamanthos@QuinMantha:~$ tracker-search test | tail
/home/rhadamanthos/Desktop/Heavyarms/rhadamanthos/CVS_STUFF/clearsilver/clearsilver-0.10.4/perl/test.out
/home/rhadamanthos/Desktop/Heavyarms/rhadamanthos/CVS_STUFF/clearsilver/clearsilver-0.10.4/perl/test.hdf
/home/rhadamanthos/Desktop/Heavyarms/rhadamanthos/CVS_STUFF/clearsilver/clearsilver-0.10.4/perl/test.gold
/home/rhadamanthos/Desktop/Heavyarms/rhadamanthos/CVS_STUFF/clearsilver/clearsilver-0.10.4/perl/test.cs
/home/rhadamanthos/Desktop/Heavyarms/rhadamanthos/Dosbox/dosbox-0.65/src/shell/shell.cpp
/home/rhadamanthos/Desktop/Heavyarms/shared/WinStore/StepMania/Themes/default/BGAnimations/ScreenCenterImage background/test.png
/home/rhadamanthos/Desktop/Heavyarms/shared/WinStore/StepMania/Themes/Groove 2.2/BGAnimations/ScreenCenterImage background/test.png
/home/rhadamanthos/Desktop/Heavyarms/shared/WinStore/StepMania/Themes/Groove 2.2/Graphics/_ps2 box/test.txt
/home/rhadamanthos/Desktop/Heavyarms/shared/WinSys/Program Files/OpenOffice.org 2.1/program/python-core-2.3.4/lib/urllib.py

So I definitely have search results. However, when I search "Test" in the tracker deskbar applet, it shows me that there are many results found, but will not display them. The "All Files" listing has a number next to it (3493, notice I piped the above search to tail), but clicking on "All Files" has no effect. The results window remains blank.

Rhadamanthos (fizz8472) wrote :

This is a screenshot I took of my search results screen, so you can see what I mean.

Emilio Pozuelo Monfort (pochu) wrote :

Thanks for your report.

Could you please attach ~/.xsession-errors and ~/.local/share/tracker/tracker.log after doing such search?

Changed in tracker:
status: New → Incomplete
Emilio Pozuelo Monfort (pochu) wrote :

And which Ubuntu and tracker versions do you have?

Rhadamanthos (fizz8472) wrote :

Ubuntu version: Hardy Heron (alpha), 64-bit desktop build
Tracker package version: 0.6.4-1ubuntu1

I removed the .xsession-errors file since there was a lot of cruft in it, did a search, closed the applet, and when I went back the file had not been created. It does not look like this error causes anything to be logged to that file.

The same thing happened with the tracker log. Doing the search from the deskbar applet appears to cause no messages to be logged to tracker.log.

Anything else I should try? Can I start the applet in a debug mode, or from the console? Is there a verbose option?

Emilio Pozuelo Monfort (pochu) wrote :

Yes, set Verbosity to 3 (debug) in ~/.config/tracker/tracker.cfg, although I'm not sure whether that will affect t-s-t or only trackerd.

Could you attach your tracker.cfg too? And does this happens with every search or only searching for "test"? Does it happen with and without the ""?

Thanks

Rhadamanthos (fizz8472) wrote :

Appears to happen with every search. The quotes were just there for illustration. I tried other search terms, they appear to have the same problem.

Set the debug, but does not appear to have had an effect.

Tracker config attached, after the debug modification.

Emilio Pozuelo Monfort (pochu) wrote :

The config looks ok. I have no idea why this is happening, specially since tracker-search is showing results.

Jim Braux-Zin (j-brauxzin) wrote :

I have a similar problem : search results located on my USB hard drive appear blank in the results list (although on the sidebar it shows the correct count of results)

BadServo (badservo) wrote :

I've been getting this error since Gutsy, still encountering it in Hardy. Oddly enough, if you search for a term from the applet that returns a large number of results, so that you have to use the arrows to cycle between sets of 10, then files will show up randomly. Some sets being blank, others showing thumbnails/icons.

Rhadamanthos (fizz8472) wrote :

Interesting. Could it be that when there is not an image to associate with a file, that it does not display the name properly?

I'll try this out on my machine and see if I can reproduce BadServo's behavior.

Jim Braux-Zin (j-brauxzin) wrote :

This problem seems fixed for me on an up to date hardy although I can't say since when.

Chris D (cdekter) wrote :

Using Gutsy 7.10 AMD64

If you perform the same search in tracker-search and tracker-search-tool, what you find is that the results that are displayed in the GUI are the same results that are listed out by the command line tool. As far as I can see, that means there are two possible bugs:

1. The result counts in the GUI tool are incorrect.
2. Not all results are being returned by the index.

If 2 is the case, then it can't be related to any issues with file types missing icons (since the command line tool doesn't care about icons). I tested this by using an incomplete icon theme, then changing to a stock icon theme (Human), and my search results were no different.

Jason Gullifer (jgull8502) wrote :

I'm also experiencing this bug in the Hardy Beta. I posted in another bug report as well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers