tracker search tool shows no results

Bug #163544 reported by socketbind on 2007-11-18
188
This bug affects 20 people
Affects Status Importance Assigned to Milestone
tracker (Ubuntu)
High
Unassigned
Nominated for Jaunty by Jonathan Ernst

Bug Description

See the attached screenshots. Same with any query string.

socketbind (socketbind) wrote :
Vincenzo Ciancia (vincenzo-ml) wrote :

Does it block? If so, it may be related to a bug I just saw, where tracker does not reply at all to the command line tools tracker-search and tracker-status.

Attaching a ltrace and a strace of tracker-search in any case.

Vincenzo Ciancia (vincenzo-ml) wrote :
Vincenzo Ciancia (vincenzo-ml) wrote :
socketbind (socketbind) wrote :

It does not block, I can use even the paging buttons but nothing shows up on the list.

Vincenzo Ciancia (vincenzo-ml) wrote :

When it happens, please try (in a terminal window) the command

tracker-search "STRING YOU WANT TO SEARCH"

(tracker-search is in the package tracker-utils which you should install) and see if it blocks. If not, please attach the output from that command.

Using tracker-search "clone":
1 results, the output is only the path to the file, nothing else.

Using the tracker search tool, query string "clone":
364 results, nothing displayed in the list, hits in several categoies.

Likewise results with any query string.

On Dec 11, 2007 4:40 PM, Vincenzo Ciancia <email address hidden> wrote:

> When it happens, please try (in a terminal window) the command
>
> tracker-search "STRING YOU WANT TO SEARCH"
>
> (tracker-search is in the package tracker-utils which you should
> install) and see if it blocks. If not, please attach the output from
> that command.
>
> --
> tracker search tool shows no results
> https://bugs.launchpad.net/bugs/163544
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Stefan Lange (albundy) wrote :

The same errors appears here (Gutsy 32bit). I don't see any search results (although some categories are listed in the tracker-search-tool) - so the same problem as socketbind had posted initially.
Using tracker-search on the command line returns no result at all ...

ethanay (ethan-y-us) wrote :

7.10 w/latest

I had the same issue -- I don't know if it ever displayed that there were results...

but lately it was just coming up 100% blank (as if the index were empty).

Killing trackerd and restarting it solved the issue. Don't know why it appeared.

I do know that I had installed a 3rd party Thunderbird e-mail indexer a while back, but tracker was still displaying results.

The only contributing factor I can think of is that it's been several weeks since I've shut down/restarted my computer. It's gone through dozens of suspend/hibernate and resume cycles, so maybe something didn't shut down or restart correctly?

Vincenzo Ciancia (vincenzo-ml) wrote :

> The only contributing factor I can think of is that it's been several
> weeks since I've shut down/restarted my computer. It's gone through
> dozens of suspend/hibernate and resume cycles, so maybe something
> didn't
> shut down or restart correctly?

Not at all, since I usually restart my laptop (suspend-to-disk is
broken) and I have this problem too.

Jason Gullifer (jgull8502) wrote :

I'm also having this issue with 8.04 (I did an upgrade from 7.10 the other day). I tried restarting trackerd and that didn't help.

Changed in tracker:
importance: Undecided → High
Jason Gullifer (jgull8502) wrote :

This is no longer a problem for me. All I did was re-index and it now works.

hirak99 (hirak99) wrote :

Reindexing did not fix it for me. Nor did reinstalling, or uninstalling and again installing.
I've had this problem since Gutsy. As far as I remember, this problem popped up when I experemented with KDE, and then removed KDE. I've upgraded to Hardy now, and the bug was still there.

While I was writing this post I tried it and realized it is fixed for me now! Here's how:

I thought I'll install the package 'tracker-utils' so that I can atleast search from command line. It not only allowed me to use it from command line, as a pleasant surprise just after installing it I the GUI started to work! I hope this information will help towards fixing the bug.

hirak99 (hirak99) wrote :

Sorry, but it has not actually been fixed yet. What I just discovered is that it works for the search of 'test', however it fails again for a search of - for example - 'ubuntu', in the same manner. It shows All Files (23) and the right arrow for scrolling, but displayed no results.

Also searching for 'ubuntu' with tracker-search gave some (3) results, and then moving back to the gui I see the number (23) changed back to (3) but still no results in display. I'm again clueless here. Somehow tracker-search triggered the number (23) to change - perhaps started a re-search?

hirak99 (hirak99) wrote : Fixed(?)

Sorry for posting again, a reindexing now seems to have fixed it altogether! I did reindex before, but then it did not work. Seems installing 'tracker-utils' was the catalyst. I'll report back tomorrow if something went wrong again - no more posts today.

hirak99 (hirak99) on 2008-03-30
Changed in tracker:
status: New → Confirmed
rs4 (rubensilva84) wrote :

Hi, I install Hardy a few days and tracker only shows up results for my emails. I'm re-indexing as I type to see if solves the problem. Well have to rewrite my phrase, I was re-indexing tracker-extract just crashed.

Another thing I noticed was just after I restart I open tracker and shows up much more results... for a while, then came back to show only emails.

hpstg (michael-tsopeis) wrote :

Exactly the same here too, with Heron 8.04 x86-64. Tracker looks like it has indexed about 8.000 files, but no results at all are displayed.

I get the same symptoms here, it was the same in Gutsy. For me it happens after a few hibernates; once it doesn't work, it will not work until I restart the computer (as opposed to hibernate), and restarting trackerd is enough to correct the problem.

On the logs, I found this interesting line (it appears for every keyword I try):
> Suggested spelling for test is test.
So maybe there's a problem with the correspondance between the keyword and the known keywords list?

Higa (higabyte) wrote :

I have the same problem. No results. I am using Hardy Heron 8.04 with a notebook HP DV9000 series. =\
I've tried to re-index but nothing happens.

Also re-indexing. No results shows.
using tracker-search in command line:

stijn@stijn-laptop:~$ tracker-search stijn
stijn@stijn-laptop:~$ tracker-search test

Results nothing.. also GUI: nothing

For me the problem is solved; I just wasn't able to search DURING the first Re-index.

Vincenzo Ciancia (vincenzo-ml) wrote :

I consistently found that I have to reindex twice (on hardy, after deleting any stale cache or configuration) because first time the indexing process blocks when a few folders are missing and no search results are reported at all.

+1 here, I'm having the same problem. In addition, it seems that the tool did not search into my LaTeX (extension .tex) files. Will try a re-index now.

By the way, in my case it happened only with some kind of files. For example, text files showed the "empty" window (and the lack of indexing of .tex files), while it worked well for example for PDF files.

Andy Owen (the-new-andy) wrote :

I have the same issue. Though most searches I try seem to work, with a few that don't. This is in hardy, with tracker 0.6.6-0ubuntu3 installed. I haven't tried reindexing.

On Thu, 2008-05-01 at 13:07 +0000, Romano Giannetti wrote:
> By the way,

...and by the way again, I started a re-index four hours ago, let the
laptop idle otherwise, and it still is not be able to give me results I
had before... my home is 10G. Is this normal/expected?

So is this bug considered to affect only users upgrading from older versions and keeping old indexes? Can it be useful I keep my old index for debugging purposes or is it better I re-index? It's not a real problem to me, so if i can help solving this...

Romano: see whether tracker-search-tool reports that indexing is still going on or not. If it's over, then maybe you still experience this bug.

Felipe Figueiredo (philsf) wrote :

This bug affected me with gutsy, but after hardy upgrade and a reindex (just to be sure) I get all results from tracker normally, with the noticeable exception wo .tex files.

OK, thanks. I guess you should file a separate bug about .tex files.

I add a "me too" to Felipe reports. .tex tracking is not working well --- just a few hits, the majority of .tex files are ignored. Felipe, if you open a bug on this, could you keep me Cc: ed? Otherwise I can open it, whatever.

I see I was not clear enough: it seems that after the re-index the tracker tool works well, modulo the .tex files. So I think this issue could be considered closed (but it seems that the tracker package would need an update to force a re-index for every user).

The hit count shown in TST is an estimate only.

Once you hit next/prev it adjusts the estimate to be more accurate

We cant show an accurate count as it might include deleted items

We could probably improve things by checking the count if its small and auto correcting it

Vincenzo Ciancia (vincenzo-ml) wrote :

I reindexed twice after installing hardy (and after having deleted any tracker config file). Then tracker worked for me nicely for a month or so. Yesterday it was deadlocked and I had to kill trackerd. I don't know why it was deadlocked (maybe related to new gvfs and fuse mounts?) however after having killed tracker, even after a reboot, the only results shown are for e-mails. I am now reindexing.

same issue. gives amount of files and doesn't show any or shows only one.

Issue persists. I've removed the tracker and will reinstall once the problem is resolved. Probably this should be removed from Intrepid too, in case the bug is not fixed by then - so that new users do not have any misgivings.

Bengt Olsson (bengt-blafs) wrote :

Confirm the behaviour. Did a re-index some time after hardy was installed. It seems like the issue is not with tracker itself but with the tracker-search-tool. By using the command line "tracker-search" you can list the files that contains the search word, it is just that they do not show up in the tracker-search-tool.

* For most search terms there are no results displayed (but there are hits)
* For some terms partial results are displayed
* For some terms all results are displayed

Maybe Affected package above should be "tracker-serach-tool" instead of "tracker". Running hardy updated as of today.

Jack Deslippe (jdeslip) wrote :

For me, tracker-search on command line also gives no results. I reindex and it works about a week and then finally develops the problem (no results) again causing me to have to reindex. Pretty annoying!

I reindexed and now results show up (not just a number and an empty result field) - just that before I had all my IMAP emails (Evolution) indexed - which are now gone :-)

Vincenzo Ciancia (vincenzo-ml) wrote :

Il giorno Tue, 14 Oct 2008 09:46:47 -0000
excogitation <email address hidden> ha scritto:

> I reindexed and now results show up (not just a number and an empty
> result field) - just that before I had all my IMAP emails (Evolution)
> indexed - which are now gone :-)

This happened to me too in intrepid, tracker worked for a long time
without e-mails, then I saw e-mails without any other kind of
document :) Then I reindexed and I had everything but e-mails didn't
show up, but it's only a matter of waiting a tenth of seconds. Maybe
timeouts should be shortened (but timeouts for what actually?).

Vincenzo

ichhaankur (n-arju-lx) wrote :

I have also faced this.

guille (guizzzmo) wrote :

I have the same problem described by Bengt Olsson. After reindexing and restarting the session everything works fine.

Guillermo

Haiko von Holten (hholten) wrote :

Did the latest tracker-update solve this issue? I haven't recognized it again yet...

ichhaankur (n-arju-lx) wrote :

It seems to have been resolved with the update.

So I close it. If somebody still experiences this, feel free to reopen or comment here.

Changed in tracker:
status: Confirmed → Fix Released

Still happening. (Latest software versions on Ubuntu 8.04)

notelopuedesimaginar: Can you try running 'trackerd --reindex'? This will rebuild your database, and may take some time. After that, just try to trigger the bug again. Thanks!

I just installed the latest tracker from source (0.6.90), and am now experiencing this. I reindexed too...a couple times.

Changing back to new, since the problem still is floating around.

Changed in tracker:
status: Fix Released → New
Kim d'Audretsch (kimda) wrote :

I also have a problem with tracker under intrepid but with when I search for files using the tracker search it will only list emails. When I try to use the search in programs like audacious it will not shoiw any results. If I kill trackerd and restart it again then I can find everything again. This is very weird behaviour.

kim@athena:~$ lsb_release -ra
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 8.10
Release: 8.10
Codename: intrepid

ii tracker 0.6.6-1ubuntu5.1 metadata database, indexer and search tool
ii tracker-search-tool 0.6.6-1ubuntu5.1 metadata database, indexer and search tool -

This bug is also present in jaunty

Martyn Russell (martyn-lanedo) wrote :

Note: If you are using tracker-search-tool and it says you have 10 files but no results are shown, this is normal behaviour. The hit score you get back is an "indication". This is exactly the same way that Google works. This is reproducible by indexing the kernel source, then removing the top level directory. There are no results, but the search tool says there are on the left in the categories.

We are currently working on improving this, but right now, unindexing content is far too slow to be done on delete events. The fix for this is to remove hits when they are searched for and the data has gone from the main database. This is currently broken too and we are in the process of fixing it this week.

Regarding the unindexing being too slow, this is something that will improve after the next release (next week 0.6.91) which will have support for SQLite FTS and should be much faster than the QDBM database we are currently using (which we estimate is taking up 75% of the time we spend indexing).

Martyn: my problem is that often the results of tracker are not exhaustive, which make it much less useful... for example, if I search for "Jiles":

(0)pern:~/www/DEA/sp4% tracker-search Jiles
/home/romano/research/ferrite/biblio/Jill-Atherton-spice-model.pdf
/home/romano/research/ferrite/biblio/Brachtendorf.pdf
/home/romano/research/ferrite/biblio/verilog-a-mag.pdf
/home/romano/research/ferrite/biblio/simul-hyster-04014515.pdf
/home/romano/research/ferrite/imtc07-journal/57tim12-lizonmartinez-proof.pdf
/home/romano/personal/pubblicazioni/ferriti-asymm.pdf

But

(0)pern:~% grep Jiles **/*.tex | wc -l
25

which are at least 25 files which have Jiles in it but are not shown in tracker. So the problem are not false positives, but false negatives.

I have re-indexed several times and yes, I have untex installed since day one.

Anyway, tracker is still very useful and growing well, so thanks for the effort. I just hope it could be improved.

Romano, I think that's a separate issue that should be filed as its own bug. If you look at the original screenshot, that's not exactly what's happening.

Martyn, I think the deletion thing is a problem too, but this bug looks like it's different. In the screenshot, he has hundreds of hits that aren't getting displayed by tracker. This is how it behaves for me too. I input a word into the search tool, and it shows me big counts of files that have that query. But when I click on a category, almost zero results ever display.

I'm running 0.6.90, installed from source.

Martyn Russell (martyn-lanedo) wrote :

mlissner, I know this is going to sound silly, but if you move a directory with 200 files in it to some place Tracker doesn't monitor, it is considered a DELETE event. In that case, you then can have a lot of hits which are grossly misreported by the search tool. If you do the same thing with the linux kernel (i.e. 26k files) and search for "kernel", that's a big number to be out by. It isn't that hard to be out.

NOTE: Carlos Garnacho, committed his patch today which corrects this slowly over time, so for big removals it will be noticeable, for small deletes it should work properly now.

Romano, it may well be that we don't handle .tex files properly - I would need a file to test with and to add it to my local monitored directories to see what happens with it to test that. Sounds like a simple case of just not indexing that file type.

That makes perfect sense. I mean...it should do the right thing, but I understand why it doesn't already.

The experience I'm having, and I'm guessing it's the same as the original poster is that immediately after indexing I have this problem. I'm at a point where I've done no deletion, nor any moving, or anything that would mess with tracker's indexing...yet, nearly all of my files don't show up when the category is chosen on the left in the search tool.

hirak99 (hirak99) wrote :

How about checking the existence of the files and subtracting the non-existant count from the number of index hits before displaying it? That will get rid of the confusion I suppose. Also how about showing all the indexed files, with the ones that have been removed as gray? May be with a check box which allows one to view only the remaining ones.

Martyn Russell (martyn-lanedo) wrote :

hirak99, by then it is too late, if you click the next button and it shows you nothing and all that changes is the statistics on the left hand side then the user is confused and thinks the button doesn't work. I agree, we should have something better though to let the user know what is going on. We have some code in place now to actively unindex content in our idle time. Hopefully this case will be minimised. We also will be moving to FTS soon and that should also improve our situation vastly.

I think there multiple seperate issues being talked about here.

The initial bug talks about no results,

then there's the no email/just emails indexed issue

and lately there's a lot of talk about wrong numbers displayed.

So go file your own bugs ;-)

Vincenzo Ciancia (vincenzo-ml) wrote :

I think the "no results" and "e-mail only" should be the same misbehaviour. From what I experienced in the past, it seems to me that results related to files are sometimes extremely slow to arrive. The e-mail appearing is independent (it may depend on actually having them indexed, or actually having results in them). I don't know if when the results don't arrive at all, it is because of timeouts.

baytuni (oytun-peksel) wrote :

same thing continues in jaunty too.

ichhaankur (n-arju-lx) wrote :

I noticed that if you reindex, then the problem disappears!

John Toliver (john-toliver) wrote :

On Thu, Apr 23, 2009 at 19:56, ichhaankur <email address hidden> wrote:
> I noticed that if you reindex, then the problem disappears!
>
> --
> tracker search tool shows no results
> https://bugs.launchpad.net/bugs/163544
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “tracker” source package in Ubuntu: New
>
> Bug description:
> See the attached screenshots. Same with any query string.
>

--
I've discovered the key to success is to never give up. You either
learn the right way, or you run out of ways to do it wrong. A win/win
situation!

John Toliver (john-toliver) wrote :

Re-indexing does fix the problem. The issue is that first of all,
this shouldn't happen, and secondly, it happens frequently enough that
re-indexing every time the results fail to display is not convenient
and makes tracker not ready for everyday use.

On Thu, Apr 23, 2009 at 19:56, ichhaankur <email address hidden> wrote:
> I noticed that if you reindex, then the problem disappears!
>
> --
> tracker search tool shows no results
> https://bugs.launchpad.net/bugs/163544
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “tracker” source package in Ubuntu: New
>
> Bug description:
> See the attached screenshots. Same with any query string.
>

--
I've discovered the key to success is to never give up. You either
learn the right way, or you run out of ways to do it wrong. A win/win
situation!

Balaji G (balajig81) wrote :

Hi
Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Thanks,
Cheers,
Balaji

Changed in tracker (Ubuntu):
status: New → Confirmed
Vincenzo Ciancia (vincenzo-ml) wrote :

Still there in karmic, reindexing fixes it, then it reappears. In this way, it more or less happens that every time I need to find a file, I have to reindex first.

raven (jkdyzrexkngb) wrote :

jaunty 64 clean install/up to date
tracker 0.6.93-0ubuntu3
tracker search tool 0.6.93-0ubuntu3
tracker-utils 0.6.93-0ubuntu3
untex 9210-10

I have the same issue as original poster
when I reindex it works for some time than I get the same issue again

thanks

Ernst (ernst-blaauw) wrote :

I'm running Karmic Alpha 6. If I search for ubuntu, the tracker tool shows on the left side:

Documents (25)

On the right side, I see three documents (instead of the expected 10). I can click on the arrow; on the next page, 2 results are shown (and above this 'Search results 11-10 of 25 results). On the last page, again 2 results are showed. So, I got 7 results.
If I type on the command line:

$tracker-search -s Documents ubuntu |wc -l

I get 8 (as the first row is not a file, this result matches the 7 reults above). Why does the GUI does not count correctly? I have not deleted or moved files, this is just after the first indexing finished.

Alextazy (alextazy0) wrote :

I've got the same kind of problem as Ernst.

Alextazy (alextazy0) wrote :

Oups, i've forgotten to precise that i'm under fedora 10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers