incomplete or missing search results shown

Bug #149300 reported by Paul Meathrel on 2007-10-05
This bug report is a duplicate of:  Bug #163544: tracker search tool shows no results. Edit Remove
14
Affects Status Importance Assigned to Milestone
tracker (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: tracker

When running a search in the gutsy beta with all of the latest updates applied more often than not incomplete results or a blank screen of results are shown. In the attached screenshots you should be able to see this behaviour. In the first no search results are shown in the right hand pane despite the count which is shown. In the second only partial results are shown, according to the label at the top of the screen results 21-30 are being shown but only three items appear. These results are repeatable in my setup.

Paul Meathrel (paulmeathrel) wrote :
Marten Klencke (mklencke) wrote :

I have the same problem with some keywords. The problem occurs quite often, but I can't correlate it to something else and it doesn't happen with all keywords.

Paul Meathrel (paulmeathrel) wrote :

I've noticed this too - indexing has finished yet some words produce partial results and other produce complete results without a problem.

The hit count is only an estimate as it might include stuff thats deleted

Also only hits for files that actually exist are shown

latests svn version clears duds upon search so a research gets back correct it count - Im looking at rechecking hit counts if duds are detected atm

Paul Meathrel (paulmeathrel) wrote :

I would have thought given that indexing is completed that files which have been moved or deleted would have been adjusted in the index and therefore it should show the right results. Perhaps this is a naive view of how it works?

They are adjusted in the database but not the index

thats because a doc may have many thousands of words and hunting them all down when you delete would cause unacceptable performance - imagine if you deleted a massive source tree!

moves are handled smartly - only the filename metadata is changed

BTW there was a bug in 0.6.3 which did not handle deleted words from a file or file move (IE not deleted files) - this has been fixed in svn version and soon to be released 0.6.4

Paul Meathrel (paulmeathrel) wrote :

Will these two change come thru the Update Manager? I'm using the Gutsy beta? Or will I need to do something else to test this for you?

Its not in repo yet - I hope it will but it depends on the unbuntu devs

They will only include critical or important bug fixes at this stage so fingers crossed that they consider this an important fix

Paul Meathrel (paulmeathrel) wrote :

Thanks for the quick reply Jamie. IMHO it would seem to be important since tracker appears not be to working under this type of fairly common situation. (Crosses fingers)

Marten Klencke (mklencke) wrote :

I understand, hunting down all those keywords would be very intensive. So do I understand correctly that in the current situation the index slowly gets polluted? Or is there some kind of "cleanup" process that periodically weeds out deleted files?

If it doesn't exist yet, perhaps something like that can be implemented using a black list of deleted files (which is updated upon deletion of files). This can then be taken into consideration by the search tools and can be used for cleaning up the database in idle time.

Then again, I am by no means acquainted with the Tracker code and internals so this might be a stupid suggestion. There may be all kinds of difficulties that arise by implementing such a scheme.

Paul Meathrel (paulmeathrel) wrote :

Any news on whether this is available in Gutsy final?

It was not classed as a blocker so did not get thorough to final

however should be in first update to gutsy (post final)

Paul Meathrel (paulmeathrel) wrote :

Great, thanks Jamie - I appreciate the update.

Changed in tracker:
status: New → Confirmed
Andy Bovett (abovett) wrote :

I'm getting this problem also in the release version of Gutsy. I'm searching for a term I know is present in current files, and the summary is showing that lots of files have been found, but none are displayed. Not sure why this search term triggers it - for what it's worth, searching for "pluto" shows the problem, whilst searching for "jupiter" or "titan" does not.

Andy B

Changed in tracker:
status: Confirmed → In Progress
jeremy-list (quick-dudley) wrote :

I would call this bug a severe one. I 'm consistently getting zero results even searching for files by the exact filename and the file is located in my home directory: not even in a sub-directory! If this bug only affected people who like tracker it wouldn't be so bad but some idiot's made Nautilus completely dependent on tracker for all its search functionality.

Changed in tracker:
importance: Undecided → Medium

Same bug as original from Paul Meathrel, but i can't get any search result, only the numbers ( 1- 10 from 52, i.e.).
Please update this bug to severe.

Tracker hasn't show any result since gusty. Instead an system upgrade I did a fresh install, so the system is brand new.

Emilio Pozuelo Monfort (pochu) wrote :

This is fixed in tracker 0.6.4

You can install it from https://launchpad.net/~pochu/+archive and give some feedback in bug 175676 so it can be backported to gutsy.

Cheers

Changed in tracker:
status: In Progress → Fix Released
Vincenzo Ciancia (vincenzo-ml) wrote :

I have tracker 0.6.6 (hardy) and the problem is still there, both with LANG=it_IT and LANG=C. Attaching screenshot illustrating the problem, should I reopen the bug?

Vincenzo Ciancia (vincenzo-ml) wrote :

Notice the number of results, and the blank page. If I run tracker-search in a terminal, it finds all matches and shows those in the terminal correctly:

vincenzo@frattaglia:~$ tracker-search catfusion|wc -l
26
vincenzo@frattaglia:~$ tracker-search catfusion|head
/home/vincenzo/Desktop/file/dottorato/lavori/CatFusion/CatFusion.pdf
/home/vincenzo/Desktop/file/dottorato/lavori/CatFusion/CatFusion.tex-backup

Savvas Radevic (medigeek) wrote :

Problem seems to have reappeared

Changed in tracker:
assignee: nobody → desktop-bugs
status: Fix Released → Confirmed

I am facing the exact same problem on Hardy Heron beta, fully updated so far till 25 March 2008. The left pane shows count, and the right pane doesn't show the results, but the 'next page/previous page' arrows are working just as they should if the files were displayed. This is just as the screenshot posted above by the person who reported the bug.

hirak99 (hirak99) wrote :

Could it be because I installed and uninstalled KDE 3 when I had Gutsy?

dejan (dejan120) wrote :

I have the same problem in Hardy with Tracker version 0.6.6.

@hirak99
I also installed/uninstalled KDE3 in Hardy.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers