Thunderbird and Kmail indexing has been disabled

Bug #148207 reported by Chris Kenyon on 2007-10-02
60
This bug affects 5 people
Affects Status Importance Assigned to Milestone
tracker (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: tracker

In Preferences > Index Preferences there are check boxes for supporting Thunderbird and Kmail.

Both options appear to have been disabled - is this intentional?

CK

Emilio Pozuelo Monfort (pochu) wrote :

Yes, this is intentional, as the TB support is experimental, and so, we won't enable it for Gutsy. It should be OK for Hardy though.

Closing the report.

Changed in tracker:
importance: Undecided → Low
status: New → Won't Fix

How about removing he check box - it is very frustrating for users. Either
it is visible and an option or it is not. The present set up is incredibly
frustrating.

CK

On 02/10/2007, Emilio Pozuelo Monfort <email address hidden> wrote:
>
> Yes, this is intentional, as the TB support is experimental, and so, we
> won't enable it for Gutsy. It should be OK for Hardy though.
>
> Closing the report.
>
> ** Changed in: tracker (Ubuntu)
> Importance: Undecided => Low
> Status: New => Won't Fix
>
> --
> Thunderbird and Kmail indexing has been disabled
> https://bugs.launchpad.net/bugs/148207
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Christopher Kenyon | <email address hidden> | M +44 7970 733 502 +44

Brian Murray (brian-murray) wrote :

I agree with Chris showing users a feature this way is quite the "tease" and can result in frustration. Futhermore, I can imagine it leading to more bug reports which is just more unnecessary work for us. If the feature is experimental and therefore not accessible it should not presented in a UI this way.

Changed in tracker:
status: Won't Fix → Confirmed
status: Confirmed → Triaged
Data (ubuntuaddress) wrote :

Does anyone know, if tracker version 0.6.6 supports indexing thunderbird emails yet?
I could not find anything in http://www.gnome.org/projects/tracker/index.html
but I am not sure as the release notes are pretty brief...

Would be great to have tracker supporting thunderbird-search though it's probably not going to happen in hardy either...

Marcelo Fernandez (fernandezm) wrote :

I think this bug affects all the people who works with Thunderbird (the priority should be "Medium"), and no, it isn't solved in Hardy, either. :-(

Emilio Pozuelo Monfort (pochu) wrote :

As I said, this was considered experimental by upstream and I don't think things have changed in the 0.6 branch. We will consider this decision again for the 0.7 series.

Václav Šmilauer (eudoxos) wrote :

Thunderbird uses sqlite instead of morkdb for some time now, getting data is therefore much simpler than writing mork parser.

Enaut (franz-die) wrote :

there is a Plugin for thunderbird along with a very nice instruction on how to install it. Its beta but it works pretty well... even if it takes a hell of time to index my ~20000 mails :P...

http://nocostsoftware.blogspot.com/2008/05/installing-thunderbird-email-support.html

Jeremy Impson (jdimpson) wrote :

Does this answer apply to the "Additional mbox style mailboxes..." section of the same Email tab of tracker-preferences?

Believe it or not I still use pine (in the form of alpine), and I've been unable to convince trackerd to index the mbox-format files in ~/mail.

Rumpeltux (rumpeltux) wrote :

The thunderbird extension is also available directly from the tracker repository: http://svn.gnome.org/svn/tracker/trunk/extensions/thunderbird-extension/

After installation restart trackerd which should then start indexing the emails. Works like a charm in intrepid.

drx (drx) wrote :

Rumpeltux, it only indexes the metadata of messages, which is not super-useful.
Tracker has to support Thunderbird i think. Nobody i know uses Evolution for anything :)

Jack Wasey (jackwasey) wrote :

tracker appears to have the slowest development process in the world. it's still beta level as far as i can tell. the last code drop added no new features (despite several years of "planned features" on the web site), just a refactoring and a few of many needed bug fixes.

unless things pick up quickly, i'm afraid think google desktop search is the best option.

Martyn Russell (martyn-lanedo) wrote :

Thunderbird and KMail were never supported.
We spent the last 12 months refactoring the code because it was needed
There have been some serious speed improvements and system performance is much better while it is in use.
We accept patches. If you want to help out great :), if not, you're really not adding anything useful to this bug report.

drx (drx) wrote :

Jack's comment was useful because it shows the frustration users have with tracker. He gives you free, effortless user research.

I applaud your effort of a redesign to make it perform better. However, searching through email is still painfully slow in Thunderbird or Kmail, no matter how much you improved tracker.

Anyway, looking forward to an awesome desktop search once you're done.

Jack Wasey (jackwasey) wrote :

i do appreciate the work, and want to help. however, i just can't deal with the many usability and stability problems right now on my main desktop.

is there a way i can activate thunderbird indexing for testing?

is there a log output of problem files which either caused tracker or helper apps to crash? an option to upload these apport-style would be an excellent way of gathering corner cases.

Martyn Russell (martyn-lanedo) wrote :

Jack, there is no support for Thunderbird, as in, no code ever written to handle it. For logging, you can edit $HOME/.config/tracker/tracker.cfg and change Verbosity to 3 (max) and you will find logs for trackerd, tracker-indexer and tracker-extract all in $HOME/.local/share/tracker/.

You might want to disable evolution if you are finding you have email issues right now you should be able to do this with the tracker-preferences application or by running trackerd -d evolution or by changing the config file.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers