Tracker doesn't index openoffice.org files

Bug #117307 reported by Sakumatti Luukkonen on 2007-05-28
14
Affects Status Importance Assigned to Milestone
tracker (Ubuntu)
Low
Emilio Pozuelo Monfort

Bug Description

Binary package hint: tracker

Using the newest tracker ( Version: 0.5.4-4) from feisty repos with a fully updated feisty, tracker doesn't index (or return any results for) any openoffice.org files.

uname -a output: Linux saku-desktop 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

My .odt documents are located in ~/Dokumentit/Koulu, and according to tracker.log it is indexing the directory but while searching for any strings in the documents, tracker doesn't return any results.

Emilio Pozuelo Monfort (pochu) wrote :

Hi Sakumatti.

Do you have 'o3read' installed? If not, please install it and check again.

Thanks
Emilio

Changed in tracker:
assignee: nobody → pochu
status: Unconfirmed → Needs Info

No, it doesn't seem to index openoffice.org files with o3read
installed either. I tried removing ~/.Tracker directory too, but it
didn't help.

Well, it works now. Seems like it wanted take some time to index those
files after all. You can close this bug now.

On another note, maybe o3read should be added as tracker's dependency,
so problems like this wouldn't happen.

On 08/06/07, Sakumatti Luukkonen <email address hidden> wrote:
> No, it doesn't seem to index openoffice.org files with o3read
> installed either. I tried removing ~/.Tracker directory too, but it
> didn't help.
>

Emilio Pozuelo Monfort (pochu) wrote :

Thanks for checking. I'm closing the bug then.

Regarding promoting o3read as a Depends instead of a Recommends, I'll ask the Debian maintainer.

Cheers
Emilio

Changed in tracker:
status: Needs Info → Rejected
Ryan Zeigler (rzeigler) wrote :

Just a heads up, this is still a problem in gutsy as of Sep. 20. Not cool for fresh installs, since most of the files on my computer are opendocument files.

Emilio Pozuelo Monfort (pochu) wrote :

Hello Ryan, and thanks for the remind.

We have written a MainInclusionReport for o3read, so we can ship it by default.
See https://wiki.ubuntu.com/MainInclusionReportO3Read for more information.

Cheers,
Emilio

Emilio Pozuelo Monfort (pochu) wrote :

Reopening. We want to install o3read by default, now that tracker is installed too.

Changed in tracker:
status: Invalid → In Progress
Changed in tracker:
importance: Undecided → Low
Nicolò Chieffo (yelo3) wrote :

and what about other files?
.doc files are intexed with the package wv
.xls files are indexed with gnumeric

I think that this is going to be a problem

Martin Pitt (pitti) wrote :

 tracker (0.6.3-0ubuntu1) gutsy; urgency=low
 .
   [ Emilio Pozuelo Monfort ]
   * New upstream release (LP: #130794, #131983, #132320, #137352, #138331,
     #139173, #132505, #131559, #131735, #132710, #133246, #137873, #138778.
   * debian/patches/01-version_fix.patch,
     debian/patches/02-getenv.patch,
     - Removed, fixed upstream.
   * debian/patches/03-system_ioprio.patch: not needed anymore, as tracker
     now tries ioprio system syscalls if available.
   * debian/patches/01_from_upstream_fix_stemming.patch:
     - Added, fixes language selection.
 .
   [ Martin Pitt ]
   * debian/control: Promote o3read to a dependency. That way, updates will get
     it, too, and we avoid making it a dependency of ubuntu-desktop. With the
     external dependency we can avoid installing the internal code copy.

Changed in tracker:
status: In Progress → Fix Released
Nicolò Chieffo (yelo3) wrote :

sorry but I really have a suspect... does o3read index opendocument
files or only old openoffice files? because if it indexes old
openoffice files it is quite useless...

Emilio Pozuelo Monfort (pochu) wrote :

Hi Nicolò

We have tested it and it works for the new format too.

Cheers,
Emilio

Nicolò Chieffo (yelo3) wrote :

Are you sure? even the site does not mention the opendocumen format...
read man o3read...
could it be that new tracker can index openoffice files without any other need?
if not this should mean that the opendocument format is identical to
the old format, which is strange!

Emilio Pozuelo Monfort (pochu) wrote :

Check it yourself ;)

emilio@kiko:~$ unzip -p somedocument.odt content.xml | o3totxt

Nicolò Chieffo (yelo3) wrote :

I trust you!
maybe the o3read only searches for <text> tags...
if so, I think that tracker could integrate this functionality without
having to depend on an unmaintained (I think) package...

Thijs Thiessens (t-thiessens) wrote :

I have tested tracker on Intrepid without o3read installed and it does not search in my odt files. I have tried installing o3read but intrepid didn't have an installable candidate. I did install wv and tracker did index my .doc files! So any news on o3read?

Steve Jackson (aearenda) wrote :

o3read is not in Intrepid's repos. Perhaps Tracker filters need to call odt2txt instead, but this is not installed by default. Copying o3totxt from Hardy seems to work as a stopgap.

Michael Biebl (mbiebl) wrote :

2008/11/9 Steve Jackson <email address hidden>:
> o3read is not in Intrepid's repos. Perhaps Tracker filters need to call
> odt2txt instead, but this is not installed by default. Copying o3totxt
> from Hardy seems to work as a stopgap.
>

You might want to sync tracker 0.6.6-2 from Debian, where I have
already fixed that. The changelog is:

tracker (0.6.6-2) unstable; urgency=low

  * debian/control
    - Add Build-Depends on pkg-config.
    - Add Vcs-* fields.
    - Replace Recommends on o3read with odt2txt.
  * debian/patches/01-secure_tmpdir.patch
    - Use mktemp to create a secure tmpdir for the msword filter.
      Thanks to Jon Dowland for the patch. Closes: #473733
  * Add symbols files for libtrackerclient0 and libtracker-gtk0.
  * debian/patches/02-static_keywords_reply.patch
    - Make _keywords_reply a static function to not export it in the public
      API.
  * debian/patches/03-prefer_odt2txt.patch
    - Use odt2txt to index OpenOffice documents. Closes: #478091

 -- Michael Biebl <email address hidden> Sun, 25 May 2008 02:20:25 +0200

Cheers,
Michael
--
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

Emilio Pozuelo Monfort (pochu) wrote :

Michael Biebl wrote:
> 2008/11/9 Steve Jackson <email address hidden>:
>> o3read is not in Intrepid's repos. Perhaps Tracker filters need to call
>> odt2txt instead, but this is not installed by default. Copying o3totxt
>> from Hardy seems to work as a stopgap.
>>
>
> You might want to sync tracker 0.6.6-2 from Debian, where I have
> already fixed that.

Thanks Michael! 0.6.6-2ubuntu1 is now on Jaunty, merging your latest changes.
Closing the report.

 status fixreleased

laksdjfaasdf (laksdjfaasdf) wrote :

Is there a fix for Intrepid planned? Tracker is an important part of Ubuntu desktop and it would be bad if it's not fixed for Intrepid even it's not a LTS version.

To get it to work in Intrepid :

simply install the "o3read" package from Hardy and then get Tracker to re-index.
http://packages.ubuntu.com/uk/hardy/o3read

you can now index .odp files

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments