/usr/lib/tracker/tracker-extract 31 -> chdir -> do_exec -> fork_exec_with_fds -> fork_exec_with_pipes -> g_spawn_async_with_pipes

Bug #1823167 reported by errors.ubuntu.com bug bridge on 2019-04-04
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Tracker
Fix Released
Unknown
tracker-miners (Ubuntu)
Status tracked in Eoan
Disco
High
Didier Roche
Eoan
High
Didier Roche

Bug Description

* Impact
The tracker indexer hits errors on some files

* Test case
No specific testcase, check that errors stop on https://errors.ubuntu.com/problem/2d3540bf66f1db4ac13f98446641b0d9c512c19c

* Regression potential
It could be that some files stop being properly read/indexed but since the code is already failing today it's not very likely, the change also include a code test which should help covering the specific case described

----------------

The Ubuntu Error Tracker has been receiving reports about a problem regarding tracker-miners. This problem was most recently seen with package version 2.1.6-1, the problem page at https://errors.ubuntu.com/problem/2d3540bf66f1db4ac13f98446641b0d9c512c19c contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker and are a software developer, you can request it at http://forms.canonical.com/reports/.

Andrea Azzarone (azzar1) on 2019-04-19
Changed in tracker-miners (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
importance: Undecided → High
status: New → In Progress
Andrea Azzarone (azzar1) wrote :

The fix has been merged upstream. I think it's worth SRUing it to disco because it's one of the most reported errors in errors.ubuntu.com. Tagging as rls-dd-incoming.

tags: added: rls-dd-incoming
Changed in tracker:
status: Unknown → Fix Released
Will Cooke (willcooke) on 2019-04-30
tags: removed: rls-dd-incoming
Changed in tracker-miners (Ubuntu Disco):
importance: Undecided → High
status: New → Triaged
assignee: nobody → Andrea Azzarone (azzar1)
Changed in tracker-miners (Ubuntu Disco):
assignee: Andrea Azzarone (azzar1) → nobody
Changed in tracker-miners (Ubuntu Eoan):
assignee: Andrea Azzarone (azzar1) → nobody
summary: - /usr/lib/tracker/tracker-
- extract:31:chdir:do_exec:fork_exec_with_fds:fork_exec_with_pipes:g_spawn_async_with_pipes
+ /usr/lib/tracker/tracker-extract 31 -> chdir -> do_exec ->
+ fork_exec_with_fds -> fork_exec_with_pipes -> g_spawn_async_with_pipes
Changed in tracker-miners (Ubuntu Eoan):
assignee: nobody → Didier Roche (didrocks)
Changed in tracker-miners (Ubuntu Disco):
assignee: nobody → Didier Roche (didrocks)
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tracker-miners - 2.1.6-1ubuntu1

---------------
tracker-miners (2.1.6-1ubuntu1) eoan; urgency=medium

  * debian/patches/git_tracker_extract*.patch:
    - Cherry-pick upstream fixes for tracker index segfault on some files
      (LP: #1823167)

 -- Didier Roche <email address hidden> Wed, 29 May 2019 09:22:46 +0200

Changed in tracker-miners (Ubuntu Eoan):
status: In Progress → Fix Released
Łukasz Zemczak (sil2100) wrote :

What I like in this bugfix upload is that most of the changes come with tests, so it certainly makes me feel a bit safer. But since the change involves rewriting of the tracker-extract quite significantly, I would like to request some normal-usage dogfooding of the package before switching the verification-done tag.

Thank you!

Changed in tracker-miners (Ubuntu Disco):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-disco

Hello errors.ubuntu.com, or anyone else affected,

Accepted tracker-miners into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/tracker-miners/2.1.6-1ubuntu1~19.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

The fix for this bug has been awaiting testing feedback in the -proposed repository for disco for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Didier Roche (didrocks) wrote :

Note that the fix is a random crash fix. I didn't get the crash myself but upstream applied the fix upstream, which is supposed to remove the crash.

As testing it, I didn't get any new crash at least, marking as verification-done.

tags: added: verification-done verification-done-disco
removed: removal-candidate verification-needed verification-needed-disco
Łukasz Zemczak (sil2100) wrote :

Looking at the error tracker, the crash rate seems to have decreased indeed. Let's give it a try.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tracker-miners - 2.1.6-1ubuntu1~19.04

---------------
tracker-miners (2.1.6-1ubuntu1~19.04) disco; urgency=medium

  * debian/patches/git_tracker_extract*.patch:
    - Cherry-pick upstream fixes for tracker index segfault on some files
      (LP: #1823167)

 -- Didier Roche <email address hidden> Wed, 29 May 2019 09:22:46 +0200

Changed in tracker-miners (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for tracker-miners has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.