package trac 0.11.7-3 failed to install/upgrade: postinst installs symlinks to /usr/lib/python*/site-packages/trac/htdocs/js instead of dist-package

Bug #580412 reported by Philip Muškovac on 2010-05-14
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
trac (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: trac

 cd: 21: can't cd to /usr/lib/python*/site-packages/trac/htdocs/js

that doesn't exist here, I do have

/usr/lib/python2.6/dist-packages/trac/htdocs/js

though.

ProblemType: Package
DistroRelease: Ubuntu 10.10
Package: trac 0.11.7-3
ProcVersionSignature: Ubuntu 2.6.32-19.28-preempt 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-preempt x86_64
NonfreeKernelModules: vboxnetadp vboxnetflt vboxdrv nls_iso8859_1 nls_cp437 usb_storage ufs qnx4 hfsplus hfs minix ntfs vfat msdos fat jfs xfs reiserfs binfmt_misc rfcomm ppdev sco bridge stp bnep l2cap kvm_intel kvm nfsd exportfs nfs lockd nfs_acl auth_rpcgss sunrpc btrfs zlib_deflate crc32c libcrc32c snd_hda_codec_analog snd_hda_intel joydev snd_hda_codec snd_hwdep snd_pcm_oss snd_mixer_oss snd_pcm usbhid thinkpad_acpi arc4 snd_seq_dummy pcmcia snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event iwlagn snd_seq iwlcore snd_timer snd_seq_device mac80211 yenta_socket rsrc_nonstatic uinput sdhci_pci hid psmouse serio_raw snd nvram btusb bluetooth ricoh_mmc pcmcia_core sdhci led_class video output cfg80211 nvidia soundcore snd_page_alloc intel_agp lp parport dm_raid45 xor vesafb ohci1394 ieee1394 ahci fbcon tileblit font bitblit softcursor e1000e vga16fb vgastate
Architecture: amd64
Date: Fri May 14 05:06:42 2010
ErrorMessage: subprocess installed post-installation script returned error exit status 2
PackageArchitecture: all
SourcePackage: initramfs-tools
Title: package trac 0.11.7-3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

Related branches

Philip Muškovac (yofel) wrote :
Tim Hatch (timhatch) wrote :

I checked and this appears to be a packaging issue in the debian. The original trac tarball doesn't include any reference to that, but trac_0.11.7-3.diff does around line 1024, and that version fails to install on a fresh 10.04 system with the same error you described. 0.11.7-1 is unaffected.

The Debian bug 576988 was opened, but they say should have been fixed in 0.11.7-3 (and I double-checked, the ubuntu 0.11.7-3 is the same as the debian one). I don't have a Debian machine handy to test whether 0.11.7-3 installs ok on debian.

Changed in trac (Ubuntu):
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Starting from python 2.6 the directory name has changed from site-packages to dist-packages. It doesn't fail in Debian because default python is 2.5

Changed in trac (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
summary: - package trac 0.11.7-3 failed to install/upgrade: subprocess installed
- post-installation script returned error exit status 2
+ package trac 0.11.7-3 failed to install/upgrade: postinst installs
+ symlinks to /usr/lib/python*/site-packages/trac/htdocs/js instead of
+ dist-package
Ara Pulido (ara) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package trac - 0.11.7-3ubuntu1

---------------
trac (0.11.7-3ubuntu1) maverick; urgency=low

  * Do not point directly to site-packages to avoid incompatibility
    with python 2.6. (Fixes: LP: #580412)
 -- Ara Pulido <email address hidden> Mon, 05 Jul 2010 11:46:04 +0200

Changed in trac (Ubuntu):
status: Triaged → Fix Released
tags: added: patch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions