Ubuntu

Sync tpb 0.6.4-8 (universe) from Debian unstable (main)

Reported by Mahyuddin Susanto on 2010-12-16
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tpb (Ubuntu)
Wishlist
Unassigned

Bug Description

Debian changelog since last merge:

tpb (0.6.4-8) unstable; urgency=low

  * New maintainer (Closes: #643900)
  * Switch to dpkg-source 3.0 (quilt) format
  * debian/compat:
    - Bump debhelper compat level to 7
  * debian/control:
    - Update Build-Depends debhelper to (>= 7.0.50~)
    - Bump to Standards-Version 3.9.3, no changes needed
    - Add upstream home page
    - Add dpkg-dev (>= 1.16.1~) to Build-Deps as we require the hardening
      build flags
  * debian/rules:
    - Replace "dh_clean -k" with "dh_prep"
  * debian/watch
    - Remove dh_make template
  * debian/tpb.config:
    - Fix lintian warning: unused-debconf-template
    - Remove "db_input medium tpb/makedev",
      not contained in debconf templates file (Closes: #656917)
   * Fix lintian spelling error:
    - debian/patch/fix-spelling-error-in-manpage.patch
    - debian/patch/fix-spelling-error-in-binary.patch

 -- Prach Pongpanich <email address hidden> Sun, 08 Apr 2012 11:57:25 +0700

tpb (0.6.4-7.1) unstable; urgency=low

  * Non-maintainer upload.
  * Fix pending l10n issues. Debconf translations:
    - Indonesian (Mahyuddin Susanto). Closes: #607336
    - Polish (Michał Kułach). Closes: #662093

 -- Christian Perrier <email address hidden> Sun, 11 Mar 2012 21:51:21 +0100

tpb (0.6.4-7) unstable; urgency=low

  * Update use of /dev/.udev for the /run transition. Closes: #644329
    Thanks to Roger Leigh for the patch.
  * Remove references to devfs, it died years ago.
  * Lintian-prompted cleanups:
    + Update Standards-Version
    + Add build-arch and build-indep rules
    + Clean up clean rule, don't ignore errors

 -- Steve McIntyre <email address hidden> Sat, 21 Jan 2012 18:48:25 +0000

tpb (0.6.4-6) unstable; urgency=low

  * Fix pending l10n issues with new/updated Debconf translations. Thanks
    again to Christian Perrier for his tireless work on this front!
    * Spanish (Omar Campagne). Closes: #582318
    * Danish (Joe Hansen). Closes: #597762
    * Italian (Vincenzo Campanella). Closes: #600220
  * Updated Standards-Version.

 -- Steve McIntyre <email address hidden> Mon, 18 Oct 2010 12:53:41 +0100

tpb (0.6.4-5) unstable; urgency=low

  * Change the priority of the udev rule so that udev doesn't change
    permissions on /dev/nvram again afterwards. Thanks to Kevin Coyner for
    a patch. Closes: #569111

 -- Steve McIntyre <email address hidden> Wed, 10 Feb 2010 12:26:57 +0000

tpb (0.6.4-4) unstable; urgency=low

  * Add a udev rules file to set up appropriate permissions on /dev/nvram.
    Thanks to Paul Martin for the patch. Closes: #551086. Also remove the
    old conf file /etc/devfs/conf.d/tpb if it still exists.
  * Remove old MAKEDEV code and dependency. Closes: #477061

 -- Steve McIntyre <email address hidden> Sun, 17 Jan 2010 21:58:47 +0000

tpb (0.6.4-3) unstable; urgency=low

  * Initial upload from new maintainer.
  * Update to recent Standards-Version and fix a load of lintian warnings:
    + Use debhelper 6 and higher, in debian/compat
    + Add misc:Depends
    + Add debhelper tokens as appropriate
    + Remove old devfs cruft
    + Add Pre-depend on debconf for preinst
  * Remove old makedev question
  * Add Russian debconf translation. Thanks to Yuri Kozlov. Closes: #541762
  * Add French translation and debconf translation. Thanks to Frédéric
    Boiteux. Closes: #448613.

 -- Steve McIntyre <email address hidden> Tue, 22 Sep 2009 23:38:41 +0100

Mahyuddin Susanto (udienz) wrote :

i'm working at this package

Changed in tpb (Ubuntu):
assignee: nobody → Mahyuddin Susanto (udienz)
Mahyuddin Susanto (udienz) wrote :

Debdiff from debian to ubuntu attached

Changed in tpb (Ubuntu):
assignee: Mahyuddin Susanto (udienz) → nobody
Evan Broder (broder) on 2010-12-16
Changed in tpb (Ubuntu):
assignee: nobody → Evan Broder (broder)
status: New → In Progress
Evan Broder (broder) wrote :

Your changelog entry needs some work:

 - (small nit) Our standard form for LP closers is "(LP: #12345)" not "(Closes LP: #12345)"
 - Don't bother putting in the changelog that you're changing Maintainer/Original-Mainatainer. There's no need to document something that we will always do

But most importantly,

 - Please *do* actually list the Ubuntu changes that you're keeping. Merging is an opportunity to reconsider the changes that have been introduced in the past and confirm that they're still needed. Without this, it's difficult to track the ongoing Ubuntu diff from Debian.

And, in fact, I see several places where we could shrink the Ubuntu diff, which makes packages more maintainable in the long run. For instance, there are some commented-out lines which were unnecessarily removed from debian/rules, and a blank line that was removed from debian/tpb.preinst. Also, there are a bunch of changes in the .po files that seem superfluous.

We also discussed adding a new translation on #ubuntu-motu. Since I don't speak Indonesian and can't review your work in that area, I'm uncomfortable sponsoring that work myself. Since, as far as I know, we can only use Rosetta for packages in main, I think the best thing to do would be to submit this translation file to Debian's Indonesian l10n list. If they approve of it, then I wouldn't have a problem including the translation until Debian is unfrozen.

I'm going to go ahead and unsubscribe ubuntu-sponsors for now, but feel free to resubscribe them when you've updated the patch.

Changed in tpb (Ubuntu):
assignee: Evan Broder (broder) → Mahyuddin Susanto (udienz)
status: In Progress → Confirmed
importance: Undecided → Wishlist
tags: added: patch
Mahyuddin Susanto (udienz) wrote :

Please forgetting last debdiff. this is another one

Changed in tpb (Ubuntu):
assignee: Mahyuddin Susanto (udienz) → nobody
Bhavani Shankar (bhavi) wrote :

hello Mahyuddin,

this looks a bit better than the former but still a few things that caught my eye are

1. its LP: #690927 instead of LP: #12345 in the LP closure directive

2. Please make the changelog more verbose i.e when you mention for example debian/init.d you should mention what is its relevant change affected in ubuntu so that its that much easier to track changes from previous merged version

3. Please update your Maintainer field to Ubuntu Developers <email address hidden> instead of the old address (Hint: you can use update-maintainer from ubuntu-dev-tools for the same)

4. Your changelog contains whitespaces such as

@@ -186,13 +269,13 @@ tpb (0.3.0-1) unstable; urgency=low
   * new upstream version

  -- Markus Braun <email address hidden> Tue, 22 Jul 2002 15:30:32 +0200
-
+
 tpb (0.2.2-1) unstable; urgency=low

   * new upstream version

  -- Markus Braun <email address hidden> Mon, 8 Jul 2002 23:42:07 +0200
-
+
 tpb (0.2.1-1) unstable; urgency=low

   * Initial Release.

Please delete/correct them

5. As Evan said, I too see unnecessary deletion of commented out lines in debian/rules which can be avoided I think

Unsubscribing sponsors for now. Please resubscribe when the above points are taken care of

Regards

Heello coolbhavi

> 1. its LP: #690927 instead of LP: #12345 in the LP closure directive
>

hm.. i don't know exacly this bug #12345, but i think debian already fix it
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=569111

> 2. Please make the changelog more verbose i.e when you mention for
> example debian/init.d you should mention what is its relevant change
> affected in ubuntu so that its that much easier to track changes from
> previous merged version
>

Okay, its done

> 3. Please update your Maintainer field to  Ubuntu Developers <ubuntu-
> <email address hidden>> instead of the old address (Hint: you
> can use update-maintainer from ubuntu-dev-tools for the same)
>

Done
> 4. Your changelog contains whitespaces such as

Done

> 5. As Evan said, I too see unnecessary deletion of commented out lines
> in debian/rules which can be avoided I think
>
Done

thanks Bhavi!

--
Mahyuddin Susanto

Evan Broder (broder) on 2010-12-18
Changed in tpb (Ubuntu):
assignee: nobody → Evan Broder (broder)
status: Confirmed → In Progress

[20:45] ebroder: udienz: It looks like there were several Ubuntu changes that you dropped without explanation
[20:45] ebroder: udienz: For instance, in 0.6.4-2.3ubuntu3, we added libxinerama-dev and dpatch to the build-dependencies in debian/control, and you dropped that change
[20:46] ebroder: udienz: You also dropped debian/patches/02_relibtoolize.dpatch
[20:47] ebroder: udienz: You also dropped the changes to debian/rules which caused the patches in debian/patches to be applied
[20:47] ebroder: udienz: You also dropped the "#DEBHELPER#" in debian/tpb.postrm and debian/tpb.preinst
[20:47] ebroder: udienz: And you dropped the environment variable change in debian/tpb.xsession
[20:458 ebroder: udienz: And you dropped a substantial change to src/cfg.c
[20:49] ebroder: udienz: Oh wait, forget that last bit. Looks like might it's been incorporated upstream?
[20:49] ebroder: udienz: But if that was the case, it should be documented in the changelog as well
[20:51] ebroder: ebroder: okay, i will try to fixing it

Unsubscribing sponsors again for the time being. Please resubscribe when ready.

Changed in tpb (Ubuntu):
assignee: Evan Broder (broder) → Mahyuddin Susanto (udienz)
status: In Progress → Triaged
Mahyuddin Susanto (udienz) wrote :

Please forgot last diff, here is new diff.

@ ebroder
Done,
tpb (0.6.4-6ubuntu1) natty; urgency=low

  * Merge from debian unstable (LP: #690927)
  * Keep Ubuntu changes:
    - debian/patches/01_fix_xosd_aclocal.dpatch
    - debian/patches/02_relibtoolize.dpatch
  * debian/control
    - Adding libxinerama-dev and dpatch at Build-Depends
    - Adding makedev and misc depends at Depends
  * debian/rules
    - Starting tpb at startup (LP: #368546)
  * debian/init.d
    - Load tpb in the init script (LP: #146987)
    - Adding LSB informations (LP: #446703)
  * debian/tpb.postinst
    - Allow normal user to run tpb (LP: #158262)

Changed in tpb (Ubuntu):
assignee: Mahyuddin Susanto (udienz) → nobody
Mahyuddin Susanto (udienz) wrote :

Two patch under debian/patches is not used anymore (ebroder)
So this is new patch

Evan Broder (broder) wrote :

Based on IRC discussion, we think this should possibly be a sync request, not a merge.

The only outstanding question is if we need an initscript to load the nvram module on the older IBM ThinkPads that tpb targets. If udev causes the nvram module to be loaded automatically (which I think it should), then we can drop our init script and rely on udev.

Unsubscribing sponsors pending further investigation.

Mahyuddin Susanto (udienz) wrote :

Evan, i have asked to my friend about this packages. i agree if this packages has been sync and to merge

summary: - Please merge tpb 0.6.4-6 (universe) from Debian unstable (main)
+ Sync tpb 0.6.4-6 (universe) from Debian unstable (main)

Hello Mahyuddin

you should *never* subscribe ubuntu archive admins on yourselves when you are filing a sync request it will be done by the sponsors (MOTU in case of universe,multiverse and core-dev in case of main or restricted) upon ACK of the sync request

cf: https://wiki.ubuntu.com/SyncRequestProcess

Marking as incomplete due to pending further investigation as to detailed explanation of why the package can be synced

regards

PS: archive-admins please hold on and please wait before syncing this bug as of now

kind regards

Changed in tpb (Ubuntu):
status: Triaged → Incomplete
assignee: nobody → Mahyuddin Susanto (udienz)
Daniel Hahler (blueyed) wrote :

I am doing some tests and then plan do sync the package instead.

Changed in tpb (Ubuntu):
assignee: Mahyuddin Susanto (udienz) → Daniel Hahler (blueyed)
status: Incomplete → In Progress
Daniel Hahler (blueyed) wrote :

I have tried getting the current and new version to work on my system, but it does not appear to work (see bug #915682).

I am waiting for feedback from the upstream author.

No news on this bug?

Daniel Hahler (blueyed) wrote :

I am unassigning myself from the bug: it does not work on my system (just tried again with 13.10).

Changed in tpb (Ubuntu):
assignee: Daniel Hahler (blueyed) → nobody
status: In Progress → Triaged
Mattia Rizzolo (mapreri) on 2014-01-19
Changed in tpb (Ubuntu):
assignee: nobody → Mattia Rizzolo (mapreri)
status: Triaged → In Progress
summary: - Sync tpb 0.6.4-6 (universe) from Debian unstable (main)
+ Sync tpb 0.6.4-8 (universe) from Debian unstable (main)
description: updated
Mattia Rizzolo (mapreri) wrote :

Since I cannot check if the init script is needed anymore I give up.

Changed in tpb (Ubuntu):
assignee: Mattia Rizzolo (mapreri) → nobody
status: In Progress → Confirmed
Steve Langasek (vorlon) wrote :

This package is high on the list at <http://qa.ubuntuwire.com/oldmerges/>, and the package itself is by all rights obsolete anyway now (there's no need to poll /dev/nvram for these keys, the kernel exposes the keys via the input subsystem). So I'm going to go ahead and sync this from Debian, dropping the Ubuntu delta.

Changed in tpb (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.