tp-smapi 0.41-1 can't load by Kernel 4.4.0-116

Bug #1755301 reported by stk76 on 2018-03-12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tp-smapi (Ubuntu)

Bug Description

I recognized the last days that tp-smapi 0.41-1 can't load by Kernel 4.4.0-116, while with all 4.4.0-xxx-Kernels before it gives no problems. TLP (for example) says that tp-smapi can't load by kernel and is "inactive".

I tried different tips from forums and compiled the actual tp-smapi 0.42 too - but all with the same effect: tp-smapi(-dkms) is able to install und is compiled right, modules are found by "modinfo" but the modul is not loading with Kernel during startup!

Tried to load it with terminal command but there is coming a warning about an exec-format-error.

So if i install and compile tp-smapi with older 4.4.0-xxx-Kernels, there is no error message and the tp-smapi-module is loaded and active.

tested on:
Ubuntu 14.04, Linux Mint 17.3, MATE, 64bit, Kernel 4.4.0-116 (LTS)

Could it be an incompability with the newest Spectre/Meltdown-Patches in Kernel(s)?

I heard about a lot of work and changes because of this.

So i hope tp-smapi (or the Kernel) could be fixed and running stable with next Kernel-or tp-smapi-upgrade.

Thank's for caring!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers