Tovid package does not install all dependencies

Bug #207471 reported by Ryan Lester on 2008-03-27
12
Affects Status Importance Assigned to Milestone
tovid (Ubuntu)
Medium
Unassigned
Nominated for Hardy by Peter Cherriman

Bug Description

Binary package hint: tovid

I don't know about Gutsy, but the Hardy package of Tovid does not install the dependency 'mencoder'. Its in the repositories, so it would be extremely simple to just add in that one word to the source package.

Related branches

exactt (giesbert) wrote :

also dependency on package dvdauthor is missing in hardy.

Changed in tovid:
status: New → Confirmed
exactt (giesbert) wrote :

another one: imagemagick

Also, I couldn't get todisc to work until I installed the package libsox-fmt-all. I kept getting the error: sox soxio: Failed reading `-': unknown file type `raw' . There are separate sox format libraries, but hey...why not. Fresh install of Hardy.

Also, missing makedvd. It's not available from any Hardy repositories, but the man file is available. Had to download the deb package from the tovid website to get makedvd.

Maia Everett (linneris) on 2008-05-09
Changed in tovid:
assignee: nobody → sikon
importance: Undecided → Medium
status: Confirmed → In Progress
Maia Everett (linneris) wrote :

makedvd IS in the package. It's in /usr/share/tovid.

I'll add the missing dependencies.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tovid - 0.31-0ubuntu2

---------------
tovid (0.31-0ubuntu2) intrepid; urgency=low

  * debian/control:
    - Added missing dependencies. (LP: #207471)

 -- Matvey Kozhev <email address hidden> Sat, 10 May 2008 16:03:12 +0700

Changed in tovid:
status: In Progress → Fix Released
Maia Everett (linneris) on 2008-05-10
Changed in tovid:
assignee: sikon → nobody
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released

You can use tovid and todisc without referencing the binaries directly, but not makedvd? That's not very user friendly IMHO and differs from from the usage of the tools when installed from tovid's website. In any case, thanks for the fix!

Peter Cherriman (pjcherriman) wrote :

Could the 0.31-0ubuntu2 be put in hardy-proposed with an intention of adding it to the hardy repo, since hardy is a supposedly a long term support release.

unixnewbie (darfsten) wrote :

i can confirm this bug. I installed tovid.
Package: tovidgui
State: installed
Automatically installed: yes
Version: 0.31-0ubuntu1
Priority: optional
Section: multiverse/graphics
Maintainer: Ubuntu MOTU Developers <email address hidden>
Uncompressed Size: 61.4k
Depends: python (>= 2.4), python-wxgtk2.6, tovid (= 0.31-0ubuntu1)
and when I tried to run it the first time I received an error that mencoder wasn't installed.
Also, I am getting an error after it's done encoding saying that makexml can't find the *.mpg file. I look at the directory that i chose as the new /tmp location and there is only a file called *.tovid_encoded.mpg. Not sure what this means. Do I need to enable the proposed repo?

unixnewbie (darfsten) wrote :

another note. when running tovid it also states missing "composite" and "convert" but it does for whatever reason does seem like it continues to work?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers