Ubuntu

touchegg crashed with SIGSEGV in geis_get_region_attr_type()

Reported by Barra on 2012-01-19
328
This bug affects 64 people
Affects Status Importance Assigned to Milestone
touchegg (Ubuntu)
Medium
Unassigned

Bug Description

touchegg don't start on EEE 101MT (asus netbook with touchscreen)

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: touchegg 1.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-9.16-generic 3.2.1
Uname: Linux 3.2.0-9-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Thu Jan 19 07:02:25 2012
ExecutablePath: /usr/bin/touchegg
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
ProcCmdline: touchegg
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7fb53ec5c778: movdqa (%rsi),%xmm1
 PC (0x7fb53ec5c778) ok
 source "(%rsi)" (0xfffffbf0) not located in a known VMA region (needed readable region)!
 destination "%xmm1" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: touchegg
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /usr/lib/libutouch-geis.so.1
 geis_filter_add_term () from /usr/lib/libutouch-geis.so.1
 ?? ()
 ?? ()
Title: touchegg crashed with SIGSEGV in geis_filter_add_term()
UpgradeStatus: Upgraded to precise on 2012-01-15 (3 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Barra (barra78) wrote :

StacktraceTop:
 geis_get_region_attr_type (geis=<optimized out>, attr_name=0xfffffbff <Address 0xfffffbff out of bounds>) at geis.c:1193
 _get_attr_type_for_facility (attr_name=0xfffffbff <Address 0xfffffbff out of bounds>, facility=GEIS_FILTER_REGION, geis=<optimized out>) at geis_filter.c:434
 geis_filter_add_term (filter=0xcd6790, facility=GEIS_FILTER_REGION) at geis_filter.c:489
 GestureCollector::addWindow (this=0xcc39b0, w=170) at src/touchegg/gestures/collector/GestureCollector.cpp:164
 Touchegg::start (this=0x7fff701e3b70) at src/touchegg/Touchegg.cpp:66

Changed in touchegg (Ubuntu):
importance: Undecided → Medium
summary: - touchegg crashed with SIGSEGV in geis_filter_add_term()
+ touchegg crashed with SIGSEGV in geis_get_region_attr_type()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in touchegg (Ubuntu):
status: New → Confirmed
William Grant (wgrant) on 2012-03-28
visibility: private → public
tags: added: bugpattern-needed
SethWoodworth (seth-woodworth) wrote :

The issue in touchegg's tracker is here: https://code.google.com/p/touchegg/issues/detail?id=148

Their latest SVN says it has a fix for this issue.

bruno.braga (bruno-braga) wrote :

I confirm it is working on Ubuntu 12.04 amd64 (using macbook pro). The version in repository is causing seg fault, but compiling from source in latest SVN is fine (r164).

Alexander Rau (alexander-rau86) wrote :

refering to #7: yes compiling from source in latest SVN (r164) has no "crash with SIGSEGV in geis_get_region_attr_type()".

However, running "$ touchegg" only shows:

[ +] Unknown gesture:
 Name -> "n/a"
 Number of fingers-> 3

tags: added: quantal
Andrey Sitnik (iskin) wrote :

Why Importance is just Medium? Application can work on eny environment.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package touchegg - 1.1.1-0ubuntu1

---------------
touchegg (1.1.1-0ubuntu1) raring; urgency=low

  [ Mitsuya Shibata ]
  * New upstream release (LP: #1059489)
    - Fixed several segv problems:
      LP: #1065673, LP: #856022, LP: #918551
    - Applied geis rename patch.
  * Removed 0001-geis_rename.patch, not needed anymore.

  [ Andrew Starr-Bochicchio ]
  * Add a debian/watch file.
  * Update Format field of debian/copyright to latest spec.
 -- Mitsuya Shibata <email address hidden> Mon, 17 Dec 2012 23:16:27 +0900

Changed in touchegg (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.