totem sound cuts out predictably on repeat

Bug #993051 reported by Gregory Gauthier on 2012-05-02
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
totem (Fedora)
New
Undecided
Unassigned
totem (Ubuntu)
Undecided
Unassigned

Bug Description

Expected behavior: When totem is set to repeat indefinitely, the file should play continuously until a new file is opened in totem or totem is closed or paused. (This is the behavior in Oneiric.)

Actual behavior (Precise): The audio file plays normally on the first playthrough. On the second playthrough, the sound cuts out at 12 seconds in. (To test, I used elf-land.ogg and legends_of_the_north.ogg from wesnoth). The audio file appears to continue playing, but no sound eminates. If you pause, the song jumps to the end. If you unpause at this point, the song appears to jump back to the point at which it was stopped, but there is still no audio output. If you seek at this point, the song cuts out 12 seconds after the point at which playback was started (so if you start at 0:28, the music will cut out at 0:40). I have also observed the sound restarting for no reason.

I also receive the following error message in console:

(totem:4869): GLib-GObject-CRITICAL **: Read/writable property 'object' on class 'ZeitgeistDpPlugin' has type 'TotemObject' which is not exactly equal to the type 'GObject' of the property on the interface 'PeasActivatable'

This appears to be confined to totem. Running mplayer -loop 0 <filename> does not create any discernable playback problems, including the issue described above.

Other information:
lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

apt-cache policy totem
totem:
  Installed: 3.0.1-0ubuntu21
  Candidate: 3.0.1-0ubuntu21
  Version table:
 *** 3.0.1-0ubuntu21 0
        500 http://ftp.usf.edu/pub/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: alsa-base 1.0.25+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic-pae 3.2.14
Uname: Linux 3.2.0-24-generic-pae i686
NonfreeKernelModules: nvidia
.etc.asound.conf:
 pcm.pulse { type pulse }
 ctl.pulse { type pulse }
 pcm.!default { type pulse }
 ctl.!default { type pulse }
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gauthier 2642 F.... pulseaudio
 /dev/snd/pcmC0D0p: gauthier 2642 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe220000 irq 48'
   Mixer name : 'Analog Devices AD1984'
   Components : 'HDA:11d41984,17aa20bb,00100400'
   Controls : 31
   Simple ctrls : 19
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 7KHT24WW-1.08'
   Mixer name : 'ThinkPad EC 7KHT24WW-1.08'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Wed May 2 00:57:40 2012
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_Card: Built-in Audio - HDA Intel
Symptom_Jack: Green Headphone Out, Left
Symptom_Type: Sound works for a while, then breaks
Title: [6459CTO, Analog Devices AD1984, Green Headphone Out, Left] fails after a while
UpgradeStatus: Upgraded to precise on 2012-04-27 (5 days ago)
dmi.bios.date: 06/06/2008
dmi.bios.vendor: LENOVO
dmi.bios.version: 7LETB9WW (2.19 )
dmi.board.name: 6459CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7LETB9WW(2.19):bd06/06/2008:svnLENOVO:pn6459CTO:pvrThinkPadT61:rvnLENOVO:rn6459CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 6459CTO
dmi.product.version: ThinkPad T61
dmi.sys.vendor: LENOVO

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in totem (Ubuntu):
status: New → Confirmed
Vasil Yakauleu (vasilbelarus) wrote :

Yes, I have the same problem on Ubuntu 12.04 i386 desktop.
The same bug appears on http://ftp.gnome.org/pub/GNOME/misc/promo-cd/GNOME-3.4.iso system based on fedora 17, so it seems to be totem bug(not ubuntu).

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Raring Ringtail.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 and 2 of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in totem (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers