Scrolling through the playlist with the mouse wheel also skips ahead/back in the current track

Bug #954952 reported by Martijn vdS on 2012-03-14
184
This bug affects 32 people
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Undecided
Unassigned

Bug Description

When I scroll through the "playlist", the currently playing song/video skips ahead as if I was pointing at the video (or its position bar) while turning the mouse wheel.

It will even skip to the next/previous item if you scroll far enough.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: totem 3.0.1-0ubuntu20
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Wed Mar 14 12:54:54 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110803)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
SourcePackage: totem
UpgradeStatus: Upgraded to precise on 2011-12-03 (101 days ago)

Martijn vdS (martijn) wrote :
tags: added: totem
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in totem (Ubuntu):
status: New → Confirmed

are there rly only 3 users affected by this bug? its still alive in 12.04

Honesty... It seems i'm not affected anymore from this bug. When i scroll using the wheel it seeks forward/backward and just near the end of the played track if seek forward it skips to the next entry in the playlist

how did you manage to achieve that? if im scrolling in playlist it still seeks through the track. i installed precise daily-live 3 days before release.

Forgive me, I was wrong... The bug still exists also in my Computer. I forgot the description of the problem, so yesterday I read it quickly and didn't understand the real problem... I confirm that the bug is still present

Dan Dart (dandart) wrote :

Confirmed - this still happens on 3.0.1

This bug was reported again in for 3.0.1 with bug 954952.

ACK I wish there was an edit - my paste buffer had the wrong number. bug 997504 ...

Nicolas Delvaux (malizor) wrote :

This bug does not happen on Oneiric although the Precise package is based on the same upstream tarball (Totem 3.0.1).

I managed to rebuild and install the Oneiric package on my Precise box, but it did not solve this issue.
So I guess this is probably not a Totem bug, but rather a bug in a dependency or an input bug (xorg?)

cdar (cdar07) wrote :

I'm also affected by this bug. My idea to solve this,
is to change scroll-event connection in glade file data/totem.ui
from object class="GtkWindow" id="totem_main_window"
to object class="GtkVBox" id="tmw_main_vbox".

Ubuntu 12.04, totem 3.0.1-0ubuntu21

The attachment "totem_bug_954952.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Nicolas Delvaux (malizor) wrote :

The proposed patch works here. I did not notice any regression.
This is rather a workaround than a true fix, because the same file cause no bug on Oneiric and Debian.

However, the patch seems fine. So it would be cool to include it in a SRU in order to fix this annoying bug and then investigate the true issue in Quantal (I just tested with the latest daily-live and the bug is still there, even if Totem was updated to v3.4).

@cdar: I'm sure ubuntu-reviewers will be happy if you can find some time to follow this process: https://wiki.ubuntu.com/Bugs/HowToFix#Work_on_fix

cdar (cdar07) wrote :

Haha! Only that? Too much for me. I did:
bzr branch lp:ubuntu/totem, pbuilder -dist precise create, changed totem.ui, dch -i, and now
bzr bd -- -S -us -uc says:

dpkg-source: info: using source format `3.0 (quilt)'
dpkg-source: info: building totem using existing ./totem_3.0.1.orig.tar.gz
dpkg-source: info: local changes detected, the modified files are:
 totem-3.0.1/data/totem.ui
dpkg-source: error: aborting due to unexpected upstream changes, see /tmp/totem_3.0.1-0ubuntu23.diff.4KmYNK
dpkg-source: info: you can integrate the local changes with dpkg-source --commit
dpkg-buildpackage: error: dpkg-source -b totem-3.0.1 gave error exit status 2
debuild: fatal error at line 1350:
dpkg-buildpackage -rfakeroot -d -us -uc -S failed
bzr: ERROR: The build failed.

Nicolas Delvaux (malizor) wrote :

Well, it seems the tutorial is out of date...

Here is what I think you should do:
(warning: I'm not an appointed reviewer so I may be wrong)

- Start from a clean repository (bzr branch lp:ubuntu/totem)

- Go in debian/patches and add your patch with a name like "95_fixscrolling_through_playlist.patch".
I attached an quilt version of your patch, you should use it.

- edit the "series" file and add the patch in the list.

- bzr add debian/patches/YOUR_PATCH

- dch -i , bzr bd -- -S -us -uc, sudo pbuilder build DSC_FILE.dsc

- When it's over, install and test debs from /var/cache/pbuilder/result.

- If it works as expected, you can follow this: https://wiki.ubuntu.com/Bugs/HowToFix#Committing_the_fix

Hope this help!

cdar (cdar07) wrote :

Can't make branch:

cdar@ubu:~/tmp/totem_lp$ bzr branch lp:ubuntu/precise/totem
bzr: ERROR: Revision {<email address hidden>} not present in "Graph(StackedParentsProvider(bzrlib.repository._LazyListJoin(([CachingParentsProvider(None)], []))))".

Nicolas Delvaux (malizor) wrote :

Well, the branch seems to be broken...
I guess you can still use the "lp:ubuntu/totem" branch.
Reviewers should be able to cherry-pick your commit easily.

Nate Wiebe (natew) wrote :

Still here in 12.10...

Le 22/11/2012 05:17, Nate Wiebe a écrit :
> Still here in 12.10...

Are you sure?
Here 12.10 fixed it.

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Raring Ringtail.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 and 2 of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in totem (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers