Pictures in tags of audio files, which act as thumbnails, are NOT shown for ALL files in same directory

Bug #914313 reported by Amr Ibrahim on 2012-01-10
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Low
Unassigned

Bug Description

Pictures embeded in tags of audio files (e.g. ID3v2 for MP3), which act as thumbnails, are NOT shown for ALL audio files in the same directory. Although all audio files have the same picture in their tags, only some random files show their thumbnails (See attached screenshots).

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: nautilus 1:3.2.1-0ubuntu3.1
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
Uname: Linux 3.0.0-14-generic x86_64
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Tue Jan 10 16:34:08 2012
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)
---
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
DistroRelease: Ubuntu 12.04
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
Package: libgstreamer0.10-0 0.10.36-1ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Tags: precise running-unity
Uname: Linux 3.2.0-29-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo vboxusers

Amr Ibrahim (amribrahim1987) wrote :
summary: - Pictures in tags of audio files (e.g. ID3v2 for MP3), which act as
- thumbnails, are NOT shown for all files in same directory
+ Pictures in tags of audio files, which act as thumbnails, are NOT shown
+ for all files in same directory
Amr Ibrahim (amribrahim1987) wrote :
Matthew Libersky (liberskym) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

---
Bug Squad Volunteer Triager

Changed in nautilus (Ubuntu):
status: New → Confirmed
summary: Pictures in tags of audio files, which act as thumbnails, are NOT shown
- for all files in same directory
+ for ALL files in same directory
description: updated
Sebastien Bacher (seb128) wrote :

totem is doing the audio,video thumbnailing, reassigning there, could you add an example file to the bug?

affects: nautilus (Ubuntu) → totem (Ubuntu)
Changed in totem (Ubuntu):
importance: Undecided → Low
Amr Ibrahim (amribrahim1987) wrote :
description: updated

apport information

tags: added: apport-collected precise
description: updated
salva (guerreroruiz-salvador) wrote :

I have the same problem.
I've found the problem is on the text codification of the id3v2 tags.
When you codificate them in unicode (utf) Nautilus is no more able to show mp3 image.
I hope it will help.

Amir Adar (zorbama) wrote :

I had a similar problem, and found a workaround. All I did was completely remove the three folders in ~/.thumbnails: fail, large and normal. Nautilus then re-reads the metadata and assigns new icons to all the files on the computer. I hope this helps.

On 08/09/12 08:12, Amir Adar wrote:
> I had a similar problem, and found a workaround. All I did was
> completely remove the three folders in ~/.thumbnails: fail, large and
> normal. Nautilus then re-reads the metadata and assigns new icons to all
> the files on the computer. I hope this helps.
>
Unfortunately, your workaround didn't work. There are still some files
which didn't show their thumbnails. Just like before; randomly, some of
them did and the others didn't.

Amr Ibrahim (amribrahim1987) wrote :

This bug is fixed after updating Totem to 3.4.3 from https://launchpad.net/~gnome3-team/+archive/gnome3 in Ubuntu 12.04.

Fabio Marconi (fabiomarconi) wrote :

Thanks Amr for the update.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in totem (Ubuntu):
status: Confirmed → Fix Released
Joshua Bakita (bakitajoshua) wrote :

I'm not entirely sure this is fixed, I still seem to be able to reproduce this bug using nautilus on 13.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers