totem plugin causes frequent gecko crashes because NPPVpluginKeepLibraryInMemory is broken

Bug #90333 reported by Alexander Sack on 2007-03-07
2
Affects Status Importance Assigned to Milestone
Totem
Undecided
auto-wap4u2
totem (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem

NPPVpluginKeepLibraryInMemory is broken in gecko and will lead to crashes if plugins use it. However, totem can work around by applying patch from

http://bugzilla.gnome.org/show_bug.cgi?id=415389

Applying that patch fixes firefox top crashers, like:

bug 72018
bug 74576
bug 72018

and epiphany crasher:

http://bugzilla.gnome.org/show_bug.cgi?id=353503

Alexander Sack (asac) on 2007-03-07
Changed in totem:
importance: Undecided → High
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for the patch Alexander

 totem (2.17.92-0ubuntu4) feisty; urgency=low
 .
   * debian/control.in:
     - don't Build-Depends on libxxf86vm-dev, the screen resizing is confusing
   * debian/patches/30_dlopen_noremove_dbus_glib.dpatch:
     - patch from Alexander Sack updated for the feisty version,
       fix "totem plugin causes frequent gecko
       crashes because NPPVpluginKeepLibraryInMemory is broken" (Ubuntu: #90333)

Changed in totem:
assignee: nobody → desktop-bugs
status: Confirmed → Fix Released
Alexander Sack (asac) wrote :

after this has baked in feisty, we should consider to nominate for stable updates as well.

description: updated
Andrew (and471) on 2009-08-26
Changed in totem:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.