Totem gives location not found error from any terminal window other than the one used to open the application

Bug #891982 reported by NW on 2011-11-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Totem
Invalid
Medium
totem (Ubuntu)
Undecided
Unassigned

Bug Description

If you open totem from one terminal and then attempt to open files in totem from a different terminal window using the command 'totem <exisiting media file>' totem throws a Location not found error. This has only occurred since upgrade to 11.10.
The same command for the same file from the terminal window originally used to open totem works without error.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: totem 3.0.1-0ubuntu7.1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Fri Nov 18 10:03:48 2011
ExecutablePath: /usr/bin/totem
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
SourcePackage: totem
UpgradeStatus: Upgraded to oneiric on 2011-11-15 (2 days ago)

NW (nwalternate) wrote :

Removed XSession Error text as it had some irrelevant info in it, the relevant error is given below:

** Message: Error: Resource not found.
gstfilesrc.c(1036): gst_file_src_start (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin1/GstFileSrc:source:
No such file "/home/.../Videos/title01.mkv"

Can see the problem here, the focus of totem is stuck in the folder in which the original terminal window opened it. Terminal 1 (which opened totem) opened a file in /home/.../Videos/

Terminal 2 was in /home/.../Videos/SomeOtherFolder/. It must have sent ./title01.mkv to totem rather than the full path.

NW (nwalternate) on 2012-01-19
description: updated
Juan Carlos Inostroza (jci) wrote :

Hi,

the problem is still happening in this version:

totem:
  Installed: 3.0.1-0ubuntu21.1
  Candidate: 3.0.1-0ubuntu21.1
  Version table:
 *** 3.0.1-0ubuntu21.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        100 /var/lib/dpkg/status
     3.0.1-0ubuntu21 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages

Error message can be replicated as follows:

1.- Open any media file using totem from terminal window (on directory A)
2.- Open another terminal window
3.- Switch to another directory (directory B) and launch totem with any file from directory B/
4.- Error message appears

The message on the totem instance is this:

** Message: Error: Resource not found.
gstfilesrc.c(1042): gst_file_src_start (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin3/GstFileSrc:source:
No such file "<media file>"

In my case, launched totem from ":~/Music/1/Quantum Conundrum Soundtrack". Then on another terminal launched totem from "~/Music/1/Riverside - 2013". Error is

gstfilesrc.c(1042): gst_file_src_start (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin1/GstFileSrc:source:
No such file "/home/jci/Music/1/Quantum Conundrum Soundtrack/01 - Riverside - New Generation Slave.mp3"

Seems that totem is sticking to the first directory instead.

Kind regards,
--j

Changed in totem (Ubuntu):
status: New → Confirmed
Changed in totem:
importance: Unknown → Medium
status: Unknown → Invalid
Paul White (paulw2u) wrote :

Upstream report marked as a duplicate of #643807
which was closed "RESOLVED FIXED" on 2012-03-29
Error not seen with with totem 3.36 in Ubuntu 18.04
Closing as fixed

Changed in totem (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.