Coherence DLNA/UPnP client not showing on plugins list

Bug #880076 reported by orzeh on 2011-10-22
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
coherence (Ubuntu)
Undecided
Unassigned
totem (Ubuntu)
Low
Unassigned

Bug Description

After install DLNA should be accesible but it does not, plugin (Coherence DLNA/UPnP) is not listed anywhere in Totem.

WORKAROUND:
Use the coherence and totem packages from PPA: ppa:rye/lp880076 as this will not be fixed in upstream packages. The GNOME project is migrating to Grilo project for UPnP but no Totem integration is available for now.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: totem 3.0.1-0ubuntu7.1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Sat Oct 22 22:20:53 2011
ExecutablePath: /usr/bin/totem
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
SourcePackage: totem
UpgradeStatus: No upgrade log present (probably fresh install)

orzeh (orz3h) wrote :
orzeh (orz3h) wrote :

now i've found - this bug might be a duplicate of Bug #855100

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in totem (Ubuntu):
status: New → Confirmed
Changed in totem (Ubuntu):
importance: Undecided → Low
Roman Yepishev (rye) on 2012-04-03
Changed in totem (Ubuntu):
assignee: nobody → Roman Yepishev (rye)
Changed in coherence (Ubuntu):
status: New → Confirmed
Roman Yepishev (rye) wrote :

Patch for current coherence-0.6.6.2

affects: coherence → coherence (Ubuntu)
Changed in coherence (Ubuntu):
assignee: nobody → Roman Yepishev (rye)
Roman Yepishev (rye) wrote :

And here's the patch for current totem-3.0.1-0ubuntu21

The totem plugin sources had to be tweaked a bit as well.

Please note that coherence patch is sufficient to be used by totem, I haven't checked the other clients yet (I recall rhythmbox could use coherence too).

As the plugin was disabled in bug 827382, it needs to be re-enabled in debian/totem-plugins-extra.install too.

The packages are being built in ppa:rye/lp880076 and by default they will not replace the existing versions. You will need to install these manually, see https://launchpad.net/~rye/+archive/lp880076 for the specific version strings.

Roman Yepishev (rye) wrote :

OTOH the plugin was dropped by Totem upstream and since the Coherence upstream is unactive (last change is around a year ago) there is a little chance the patches can end up being in Debian or Ubuntu.

http://git.gnome.org/browse/totem/commit/?id=adc3ba965ab46a94335ffee06dacdad24322a093

The attachment "04_swith_to_gir.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Roman Yepishev (rye) wrote :

This will definitely be a PPA-only "fix" since GNOME is switching to Grilo framework which will handle UPnP as well.
http://live.gnome.org/Grilo

Changed in coherence (Ubuntu):
assignee: Roman Yepishev (rye) → nobody
Changed in totem (Ubuntu):
assignee: Roman Yepishev (rye) → nobody
Changed in coherence (Ubuntu):
status: New → Won't Fix
Changed in totem (Ubuntu):
status: Confirmed → Won't Fix
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers