needs to be updated for libtotem-plparser API change

Bug #86271 reported by Michael R. Head on 2007-02-19
2
Affects Status Importance Assigned to Milestone
PyGTK
Fix Released
Medium
totem (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: serpentine

Serpentine toss some exceptions to the commandline during startup. I believe this is why most (m3u and pls) playlists can't be parsed, but I can't say for sure.

Here's the stacktrace from the terminal. Note that this import error doesn't prevent serpentine from running.

burner@phoenix:~$ serpentine
Error loading 'filter_plparser' plugin:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/serpentine/plugins/__init__.py", line 38, in <module>
    module = imp.load_source (plug, plugins[plug])
  File "/usr/lib/python2.5/site-packages/serpentine/plugins/plugfilter_plparser.py", line 22, in <module>
    from totem import plparser
ImportError: /usr/lib/python2.5/site-packages/gtk-2.0/totem/plparser.so: undefined symbol: totem_pl_parser_type_get_type

Sebastien Bacher (seb128) wrote :

Thank you for your bug, the python bindings need to be updated for API change

Changed in serpentine:
importance: Undecided → High
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :
Changed in gnome-python-desktop:
assignee: nobody → desktop-bugs
Michael R. Head (burner) wrote :

Dunno how smart launchpad is WRT dupes in remote bug trackers, so I'm updating manually since the reported bug was marked a dupe.

Sebastien Bacher (seb128) wrote :

totem bug and fixed upstream

Changed in gnome-python-desktop:
status: Confirmed → Fix Committed
Changed in pygtk:
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

This upload fixes the bug

 totem (2.18.0-0ubuntu1) feisty; urgency=low
 .
   * New upstream version:
     - Fix resizing of the sidebar the first time it's opened (Ubuntu: #84073)
     - Fix using the playlist parser with the Python bindings (Ubuntu: #86271)
     - Translate the preferences dialogue title
     - Don't change the screen resolution when switching to fullscreen
       and the resolution isn't the highest possible
     - Don't crash when the XRandR extension isn't available (Ubuntu: #86821)
     - Avoid crashes when Totem is compiled with LIRC support, and
       no remoted are configured (Ubuntu: #90123)
     - Make the ASX playlist parser more robust (Ubuntu: #70706)
     - Browser:
       - Don't crash when the plugin has been unloaded, and the desktop
         theme is changed
       - Fix parsing of boolean values
     - Fix playback of Ogg Vorbis files (xine-lib backend) (Ubuntu: #89895)
   * debian/patches/01_from_upstream_update_for_new_gstreamer.dpatch:
     - dropped, fixed with the new version
   * debian/patches/03_autoconf.dpatch:
     - updated
   * debian/patches/30_dlopen_noremove_dbus_glib.dpatch:
     - dropped, bug fixed with the new version

Changed in totem:
status: Fix Committed → Fix Released
Changed in pygtk:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.