MASTER firefox crash [@totemScriptablePlugin::~totemScriptablePlugin]

Bug #86265 reported by John Vivirito on 2007-02-19
116
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Critical
firefox (Ubuntu)
High
Mozilla Bugs
Nominated for Feisty by Alexander Sack
totem (Ubuntu)
High
Ubuntu Desktop Bugs
Nominated for Feisty by Alexander Sack

Bug Description

Binary package hint: firefox

After going to link on bug #86243 it loaded fine but after closing the link firefox crashed with the attached report.

totem-mozilla: Installed: 2.17.91-0ubuntu3
totem-xine: Installed: 2.17.91-0ubuntu3
totem: Installed: 2.17.91-0ubuntu3
firefox: Installed: 2.0.0.1+1-0ubuntu1

ProblemType: Crash
Date: Mon Feb 19 07:28:41 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/lib/firefox/firefox-bin
Package: firefox 2.0.0.1+1-0ubuntu1
ProcCmdline: /usr/lib/firefox/firefox-bin
ProcCwd: /home/gnomefreak
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_US.UTF-8
 LANGUAGE=en_US:en
Signal: 11
SourcePackage: firefox
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/tls/i686/cmov/libpthread.so.0
 nsProfileLock::FatalSignalHandler (signo=-1210515468)

 totemScriptablePlugin::~totemScriptablePlugin ()
Uname: Linux FeistyFawn 2.6.20-8-generic #2 SMP Tue Feb 13 05:18:42 UTC 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev scanner video

John Vivirito (gnomefreak) wrote :
Alexander Sack (asac) wrote :

we need a retrace here.

Changed in firefox:
assignee: nobody → mozillateam
status: Unconfirmed → Needs Info
Alexander Sack (asac) wrote :

oh ... sorry ... already properly traced

this is probably http://bugzilla.gnome.org/show_bug.cgi?id=407679 which has a fix attached.

Checkin is here: http://svn.gnome.org/viewcvs/totem?view=rev&revision=4034

TODO:
  + verify that fix works
  + add totem package to bug
  + hunt duplicates

John Vivirito (gnomefreak) wrote :

Stacktrace after retrace

John Vivirito (gnomefreak) wrote :

ThreadStack after retrace

John Vivirito (gnomefreak) wrote :

the fixed packages for now until review and upload can be found at
http://gnomefreak.youmortals.com/Totem/

Changed in firefox:
status: Needs Info → Confirmed
Alexander Sack (asac) on 2007-02-20
Changed in firefox:
importance: Undecided → High
Alexander Sack (asac) wrote :

confirming, setting high importance, as this is a frequently reported crash in firefox.

Changed in totem:
importance: Undecided → High
status: Unconfirmed → Confirmed
Alexander Sack (asac) wrote :

in progress for firefox package as we wait for patch to be applied in totem.

Changed in firefox:
status: Confirmed → In Progress
Sebastien Bacher (seb128) wrote :

fixed upstream

Changed in totem:
assignee: nobody → desktop-bugs
status: Confirmed → Fix Committed
Changed in totem:
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

fixed to feisty now

Changed in totem:
status: Fix Committed → Fix Released
David Farning (dfarning) on 2007-02-24
Changed in firefox:
assignee: mozillateam → mozilla-bugs
miked (miked11) wrote :
miked (miked11) wrote :

Fresh install Ubuntu 7.04 Beta- The Feisty Fawn (Herd6?)
i386/i686.iso Alternative Install with updates and upgrades.

On Mon, Mar 26, 2007 at 12:10:02PM -0000, miked wrote:
>
> ** Attachment added: "Crash file firefox"
> http://librarian.launchpad.net/6938945/_usr_lib_firefox_firefox-bin.0.crash
>

Please don't attach crash reports to existing bugs, but open a new
one. This crash is probably unrelated.

Thanks,

 - Alexander

Alexander Sack (asac) wrote :

this was fixed by a totem update long ago.

Changed in firefox:
status: In Progress → Fix Released
Changed in totem (Ubuntu):
status: Fix Released → In Progress
Changed in firefox (Ubuntu):
status: Fix Released → Fix Committed
Changed in totem:
status: Fix Released → Fix Committed
Changed in totem (Ubuntu):
status: In Progress → Fix Committed
Micah Gersten (micahg) wrote :

This was fixed long ago. Upstream has been closed for 2 years. Please file a new report if you are still having issues.

Changed in firefox (Ubuntu):
status: Fix Committed → Fix Released

Same for totem. Closing the bug since this should have been fixed for a long time and there were no recent duplicates.

Changed in totem (Ubuntu):
status: Fix Committed → Fix Released
Changed in totem:
importance: Unknown → Critical
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.