python plugins not working

Bug #855100 reported by Nikolaus Filus
236
This bug affects 47 people
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Fix Released
Medium
Jeremy Bicha
Oneiric
Fix Released
Medium
Jeremy Bicha

Bug Description

Hi,

I upgraded to Oneiric and noticed that the upnp-coherence plugin is missing. After installing it manually, I noticed that some plugins aren't working on totem.
Output from console:

(totem:5249): libpeas-WARNING **: Could not find 'Module' in '/usr/lib/totem/plugins/upnp-coherence/upnp-coherence.plugin'

(totem:5249): libpeas-WARNING **: Error loading '/usr/lib/totem/plugins/upnp-coherence/upnp-coherence.plugin'
/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
  import gobject._gobject
Traceback (most recent call last):
  File "/usr/lib/totem/plugins/pythonconsole/pythonconsole.py", line 69, in <module>
    class PythonConsolePlugin(gobject.GObject, Peas.Activatable):
TypeError: Error when calling the metaclass bases
    metaclass conflict: the metaclass of a derived class must be a (non-strict) subclass of the metaclasses of all its bases

(totem:5249): libpeas-WARNING **: Error loading plugin 'pythonconsole'
Traceback (most recent call last):
  File "/usr/lib/totem/plugins/opensubtitles/opensubtitles.py", line 298, in <module>
    class OpenSubtitles(gobject.GObject, Peas.Activatable):
TypeError: Error when calling the metaclass bases
    metaclass conflict: the metaclass of a derived class must be a (non-strict) subclass of the metaclasses of all its bases

(totem:5249): libpeas-WARNING **: Error loading plugin 'opensubtitles'
Traceback (most recent call last):
  File "/usr/lib/totem/plugins/jamendo/jamendo.py", line 66, in <module>
    class JamendoPlugin(gobject.GObject, Peas.Activatable, PeasGtk.Configurable):
TypeError: Error when calling the metaclass bases
    metaclass conflict: the metaclass of a derived class must be a (non-strict) subclass of the metaclasses of all its bases

(totem:5249): libpeas-WARNING **: Error loading plugin 'jamendo'
Traceback (most recent call last):
  File "/usr/lib/totem/plugins/dbus/dbus-service.py", line 30, in <module>
    class dbusservice(gobject.GObject, Peas.Activatable):
TypeError: Error when calling the metaclass bases
    metaclass conflict: the metaclass of a derived class must be a (non-strict) subclass of the metaclasses of all its bases

(totem:5249): libpeas-WARNING **: Error loading plugin 'dbus-service'
Traceback (most recent call last):
  File "/usr/lib/totem/plugins/iplayer/iplayer.py", line 16, in <module>
    class IplayerPlugin (gobject.GObject, Peas.Activatable):
TypeError: Error when calling the metaclass bases
    metaclass conflict: the metaclass of a derived class must be a (non-strict) subclass of the metaclasses of all its bases

(totem:5249): libpeas-WARNING **: Error loading plugin 'iplayer'
Totem-Message: socket created
Segmentation fault (core dumped)

ProblemType: BugDistroRelease: Ubuntu 11.10
Package: totem 3.0.1-0ubuntu5
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
NonfreeKernelModules: slamr
ApportVersion: 1.23-0ubuntu1
Architecture: i386
Date: Tue Sep 20 23:39:19 2011SourcePackage: totem
UpgradeStatus: Upgraded to oneiric on 2011-09-17 (3 days ago)

Revision history for this message
Nikolaus Filus (nfilus) wrote :
Revision history for this message
Sérgio Faria (sergio91pt) wrote :

The d-bus, Jamendo, subtitles and the python console won't load with a TypeError.
Also got tomtem to crash when tried to activate Bemused (bug 855116) but seems I can't reporiduce it.

Changed in totem (Ubuntu):
status: New → Confirmed
description: updated
Revision history for this message
Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha)
Changed in totem (Ubuntu Oneiric):
assignee: nobody → Jeremy Bicha (jbicha)
Jeremy Bicha (jbicha)
Changed in totem (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Nikolaus, or anyone else affected,

Accepted totem into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Revision history for this message
Jeremy Bicha (jbicha) wrote :

Accepted into oneiric-proposed, the package will build now and be
available in a few hours. Please test and give feedback here. See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
enable and use -proposed. Thank you in advance!

Revision history for this message
Miklos Juhasz (mjuhasz) wrote :

I updated to the version in proposed and tried to activate the Subtitle Downloader plugin but I am still getting the stacktrace:

/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
  import gobject._gobject
Traceback (most recent call last):
  File "/usr/lib/totem/plugins/opensubtitles/opensubtitles.py", line 300, in <module>
    class OpenSubtitles(GObject.Object, Peas.Activatable):
  File "/usr/lib/totem/plugins/opensubtitles/opensubtitles.py", line 303, in OpenSubtitles
    object = GObject.property(type = GObject.Object)
  File "/usr/lib/python2.7/dist-packages/gi/_gobject/propertyhelper.py", line 111, in __init__
    self.type = self._type_from_python(type)
  File "/usr/lib/python2.7/dist-packages/gi/_gobject/propertyhelper.py", line 202, in _type_from_python
    raise TypeError("Unsupported type: %r" % (type_,))
TypeError: Unsupported type: <type 'gobject.GObject'>

(totem:2635): libpeas-WARNING **: Error loading plugin 'opensubtitles'

Revision history for this message
Jeremy Bicha (jbicha) wrote :

Miklos, thanks for the feedback. The only warning I got when activating the opensubtitle plugin was:

/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
  import gobject._gobject

But we should make sure that one works correctly. Have you had a chance to test any of the other plugins? (I didn't get a warning or error with the other ones.)

Revision history for this message
Miklos Juhasz (mjuhasz) wrote :

I have just installed Oneiric into a virtual machine and tested the plugins _without_ having the proposed repository enabled. As expected, D-Bus Service, Jamenod, Python Console and Subtitle Dowloader failed.

Then I enabled the proposed repository, upgraded the totem package and checked again: _all_ plugins worked fine.

On my laptop however I am still getting stacktraces for all 4 plugins. I will get back to you if I manage to figure out why it works in a clean virtual machine and why not on my laptop which has been installed from the very same iso a couple of days ago and is kept up-to-date.

Revision history for this message
Miklos Juhasz (mjuhasz) wrote :

D-Bus Service, Jamendo and Python Console can be enabled on my laptop and they remain enabled after restarting Totem. I checked the python console and it works (did not know how to check the other two plugins but there's nor warning or error on the console).

The issue is with the subtitle editor plugin:

- I can only enable it if I first enable one of the other three plugins mentioned above
- it does not work - pressing the Find button to find subtitles does not have any effect
- after restarting totem fails to load and makes the other 3 fail as well and it can only be disabled by using dconf-editor
- after enabling it I see the following stacktrace (same as in comment #7):

/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
  import gobject._gobject

Revision history for this message
Martin Pitt (pitti) wrote : Re: [Bug 855100] Re: python plugins not working

Jeremy Bicha [2011-10-11 19:56 -0000]:
> /usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
> import gobject._gobject

For the record, this is because that plugin imports another static
module which in turn imports gobject. So that needs to be fixed to use
GI as well.

Revision history for this message
Martin Pitt (pitti) wrote :

So it seems the proposed package improves things, but not perfect yet. Thus setting to v-done, but we'll reopen the bug once this makes it to -updates.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Jeremy Bicha (jbicha) wrote :

I have a new 7.1 upload waiting in the proposed queue which should fix the subtitle plugin also.

Revision history for this message
costales (costales) wrote :

Hi! With Oneric updated to today and proposed repositories enabled, I can't enabled the subtitle plugin.

Steps:
 1. Open Totem.
 2. Menu: Edit / Plugins
 3. Enable the subtitles downloader > Error, you can't enabled it!

More users with this problem in #871681
Best regards and thanks!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 3.0.1-0ubuntu7

---------------
totem (3.0.1-0ubuntu7) oneiric-proposed; urgency=low

  * debian/patches/04_port_to_gobject.patch:
    Use the new pygobject, fixes all Python plugins (LP: #855100)
  * debian/patches/70_bbc_plugin.patch: Dropped completely as a different
    version of this patch is now part of Totem's official plugins
 -- Jeremy Bicha <email address hidden> Tue, 11 Oct 2011 00:30:17 -0400

Changed in totem (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Revision history for this message
Radics Ottó (saboteur777) wrote :

Subtitle download plugin still broken, can't enable it.

Changed in totem (Ubuntu):
status: Fix Committed → Confirmed
Revision history for this message
Michal Rudolf (mrudolf) wrote :

Same here. Also, even opening local subtitles doesn't work for DVDs. I don't know if this is related, so I am waiting for this bug to be fixed first.

Revision history for this message
theghost (theghost) wrote :

Same here Ubuntu 11.10 x64 with Totem 3.0.1-0ubuntu7, the Subtitle Downloader Plugin can't activated.

Revision history for this message
theghost (theghost) wrote :

Still got the following error with totem - 3.0.1-0ubuntu7 and the subtitle downloader plugin:

/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
  import gobject._gobject
Traceback (most recent call last):
  File "/usr/lib/totem/plugins/opensubtitles/opensubtitles.py", line 300, in <module>
    class OpenSubtitles(GObject.Object, Peas.Activatable):
  File "/usr/lib/totem/plugins/opensubtitles/opensubtitles.py", line 303, in OpenSubtitles
    object = GObject.property(type = GObject.Object)
  File "/usr/lib/python2.7/dist-packages/gi/_gobject/propertyhelper.py", line 111, in __init__
    self.type = self._type_from_python(type)
  File "/usr/lib/python2.7/dist-packages/gi/_gobject/propertyhelper.py", line 202, in _type_from_python
    raise TypeError("Unsupported type: %r" % (type_,))
TypeError: Unsupported type: <type 'gobject.GObject'>

Revision history for this message
Jeremy Bicha (jbicha) wrote :

The subtitle plugin should be fixed in 3.0.1-0ubuntu7.1 which should be available in proposing within a few hours. Please test and give feedback here.

Revision history for this message
costales (costales) wrote :

Yesterday I received the update. All works right now :D Thanks very much Jeremy!

Revision history for this message
Alexander Koptelov (alexandre-koptelov) wrote :

Returning to the original issue (upnp-coherence plugin), it isn't there yet (3.0.1-0ubuntu7), and in 3.0.1-0ubuntu7.1 I see it is commented out in the debian/totem-plugins-extra.install. Is it for a good reason?

Revision history for this message
Brad Needham (fishrcynic) wrote :

Any update when upnp-coherence plugin will be fixed or if it will be fixed?

Revision history for this message
Roman Yepishev (rye) wrote :

The fix in 7.1 is incomplete - the configure.in file blacklists coherence_upnp plugin and debian/totem-plugins-extra.install has the coherence_upnp line commented.

Changed in totem (Ubuntu Oneiric):
status: Fix Released → New
Revision history for this message
Roman Yepishev (rye) wrote :

And if the package is built and enabled, totem crashes with:

/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
  import gobject._gobject
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:40: Warning: specified class size for type `PyGtkGenericCellRenderer' is smaller than the parent type's `GtkCellRenderer' class size
  from gtk import _gtk
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:40: Warning: g_type_get_qdata: assertion `node != NULL' failed
  from gtk import _gtk
Segmentation fault

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in totem (Ubuntu Oneiric):
status: New → Confirmed
Changed in totem (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in totem (Ubuntu Oneiric):
importance: Undecided → Medium
status: Confirmed → Triaged
Revision history for this message
Matt Winter (mattwinter) wrote :

So is the problem understood, and someone just needs to fix it? Or has this yet to be investigated?

Revision history for this message
Pavol Klačanský (pavolzetor-deactivatedaccount) wrote :

Subtitle does not download nothing, and it becomes greyed in menu

Revision history for this message
theghost (theghost) wrote :

@Pavol Klacansky: Sadly, the broken subtitle download is a different bug, that is not fixed, although we have working patch attached to the bug-report. Have a look at fpr further information: https://bugs.launchpad.net/ubuntu/+source/totem/+bug/886947

Revision history for this message
John McCourt (butterman) wrote :

My elderly mother just had a shoulder operation so can't move around alot. They have an Ubuntu machine hooked up to their TV. It would be really great if she could watch her old movies easily without having to get up. I'd really appreciate it if someone gets this fixed.

Revision history for this message
Jeremy Bicha (jbicha) wrote :

Alexander, the coherence plugin has been dropped by the Totem developers.

http://git.gnome.org/browse/totem/commit/?id=adc3ba965ab46a94335ffee06dacdad24322a093

Jeremy Bicha (jbicha)
Changed in totem (Ubuntu Oneiric):
status: Triaged → Fix Released
Changed in totem (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Javier Vilalta (jvilalta) wrote :

I have the same problem. What exactly is the fix?, if it's "won't fix" because it has been removed by the Totem developers, it would be nice to remove the reference to the DLNA compatibility in the package description: it's confusing.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers