Totem Movie Player not resizing video in fullscreen anymore

Bug #769272 reported by User Unknown on 2011-04-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: totem

Ever since I did a gstreamer upgrade (from the Gstreamer Developers PPA: https://launchpad.net/~gstreamer-developers/+archive/ppa) a couple of days ago, the Movie Player (totem 2.30.2 using GStreamer 0.10.32 (prerelease)) will not resize the video display anymore when switching to full screen. The screen goes all black as expected, but the video is displayed in the center of the screen at 100% of video size. Also resizing the video player's window does not change the video size anymore, neither does the "Zoom In/Out" in totem appear to do anything.

This seems to affect only the default Movie Player (totem). Gnome MPlayer or VLC are not affected.

Here's a list of the gstreamer related upgrades:
gstreamer0.10-alsa (0.10.32-1~lucid1) to 0.10.32.2-1~lucid7
gstreamer0.10-plugins-bad (0.10.21-1~lucid1) to 0.10.21.2-1~lucid2
gstreamer0.10-plugins-base (0.10.32-1~lucid1) to 0.10.32.2-1~lucid7
gstreamer0.10-plugins-base-apps (0.10.32-1~lucid1) to 0.10.32.2-1~lucid7
gstreamer0.10-plugins-good (0.10.27-1~lucid2) to 0.10.28.2-1~lucid2
gstreamer0.10-plugins-ugly (0.10.17-1~lucid1) to 0.10.17.2-1~lucid2
gstreamer0.10-pulseaudio (0.10.27-1~lucid2) to 0.10.28.2-1~lucid2
gstreamer0.10-x (0.10.32-1~lucid1) to 0.10.32.2-1~lucid7
libgstreamer-plugins-base0.10-0 (0.10.32-1~lucid1) to 0.10.32.2-1~lucid7

This might be kind of a dupe of Bug #668280, but that one has all different versions of Ubuntu, the Linux kernel, Totem and GStreamer.

Additional info:
1) Ubuntu 10.04.2 LTS; 10.04
2) totem: 2.30.2-0ubuntu1; gstreamer: 0.10.32.2-1~lucid7
3) Well, having my video displayed as large as the player's window or in full screen size.
4) Video size remains at 100% or 1:1 regardless of the player's window size or full screen mode.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: totem 2.30.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-31.61-generic 2.6.32.32+drm33.14
Uname: Linux 2.6.32-31-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Apr 23 01:15:55 2011
ExecutablePath: /usr/bin/totem
InstallationMedia: Pinguy OS 10.04 x64 - Release amd64
ProcEnviron:
 LANGUAGE=en_DK:en
 LANG=en_DK.utf8
 SHELL=/bin/bash
SourcePackage: totem
XsessionErrors:
 (polkit-gnome-authentication-agent-1:3357): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (Do:3393): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.
 (nm-applet:3385): Gdk-CRITICAL **: IA__gdk_window_thaw_toplevel_updates_libgtk_only: assertion `private->update_and_descendants_freeze_count > 0' failed

User Unknown (user-unknown) wrote :
User Unknown (user-unknown) wrote :

Also with recent update of gdm (2.30.0-0ubuntu5.2) and linux kernel (2.6.32.32.38) totem Movie Player didn't regain its video scaling abilities.

Am I really the only one experiencing this?? How can that be? Any help? Please!

User Unknown (user-unknown) wrote :

Apparently, with the latest update of some of the GStreamer related packages Totem Movie Player regained its video scaling abilities:

Upgraded the following packages:
gir1.0-gstreamer-0.10 (0.10.32.2-1~lucid2) to 0.10.32.3-1~lucid1
gstreamer-tools (0.10.32.2-1~lucid2) to 0.10.32.3-1~lucid1
gstreamer0.10-alsa (0.10.32.2-1~lucid7) to 0.10.32.3-1~lucid1
gstreamer0.10-plugins-base (0.10.32.2-1~lucid7) to 0.10.32.3-1~lucid1
gstreamer0.10-plugins-base-apps (0.10.32.2-1~lucid7) to 0.10.32.3-1~lucid1
gstreamer0.10-tools (0.10.32.2-1~lucid2) to 0.10.32.3-1~lucid1
gstreamer0.10-x (0.10.32.2-1~lucid7) to 0.10.32.3-1~lucid1
libgstreamer-plugins-base0.10-0 (0.10.32.2-1~lucid7) to 0.10.32.3-1~lucid1
libgstreamer0.10-0 (0.10.32.2-1~lucid2) to 0.10.32.3-1~lucid1
libgstreamer0.10-dev (0.10.32.2-1~lucid2) to 0.10.32.3-1~lucid1

Now I can finally use Movie Player again to watch my vids in full screen or any other window size, for that matter. What a treat. (I still don't get how I could be apparently the only one to experience this...)

Changed in totem (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers