Ubuntu

Bad cache managing in video playing

Reported by Patrice Vetsel on 2006-12-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Undecided
Unassigned
totem (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

I'm under feisty.

I'v a little bandwidth connection (512DSL). Using firefox, i want to see big quality trailers.

Problem :
i'v put 56kbps Modem/RNIS under totem preference.
Using gconf-editor i'v changed "buffer-size" to 10sec for totem.

But with that, when i launch a big quality trailer, totem under firefox try to play less than 1sec after starting (too fast, cache is empty), and freeze each seconds.

Conclusion : with little connection, totem is unusable under firefox.

Patrice Vetsel (vetsel-patrice) wrote :

I must add that without firefox, just with totem. Using this link :
http://images.apple.com/movies/touchstone/the_invisible/the_invisible-tlr2_h640w.mov

buffer-size set to 20 seconds for totem with gconf-editor. When i open this link, i can see the cache reloaded 5 times in the 20 first seconds... freezing video etc.

Normally if i have a 100%cache i must have (almost) 20sec of videos in cache.

Sebastien Bacher (seb128) wrote :

do you use totem-gstreamer or totem-xine?

Patrice Vetsel (vetsel-patrice) wrote :

totem-gstreamer

Patrice Vetsel (vetsel-patrice) wrote :

For a network play it's not buffer-size but network-buffer-threshold.
Putting this 2 parameters at 20seconds don't resolv anything

Sebastien Bacher (seb128) wrote :

Thank you for the details. Looks like an upstream problem, somebody having it should probably forward that to bugzilla

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Confirmed
Patrice Vetsel (vetsel-patrice) wrote :

Closing this bug as totem 2.17.91-0ubuntu2 works fine now

Changed in totem:
status: Confirmed → Fix Released
Changed in totem:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers