gnome-screensaver activates while watching a movie in totem

Bug #630753 reported by Nick Moffitt on 2010-09-05
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
Low
Chris Coulson

Bug Description

Binary package hint: gnome-screensaver

I recently upgraded my laptop from lucid to maverick, and found after rebooting that gnome-screensaver is not temporarily disabled by totem. I'm uncertain as to whether this is totem's fault or gnome-screensaver's, but somehow the two are not coöperating.

All you have to do to reproduce is set the screensaver timeout to five minutes and try to watch a six minute movie.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-screensaver 2.30.0-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
Architecture: amd64
Date: Sun Sep 5 11:41:23 2010
EcryptfsInUse: Yes
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
ProcEnviron:
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-screensaver
WindowManager: gnome-wm

Nick Moffitt (nick-moffitt) wrote :
antistress (antistress) wrote :

Same bug with a clean install of maverick beta

roman.rene (roman-rene) wrote :

Same here (Maverick beta )

Marc Sousbie (marcsousbie) wrote :

Same bug with Totem but not with VLC (on a clean install of maverick beta).

Didier Roche (didrocks) wrote :

Chris, can you have a look at it?
Thanks!

Changed in gnome-screensaver (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in gnome-screensaver (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Chris Coulson (chrisccoulson) wrote :

The issue seems to be with totem. If you start it with a video, then it doesn't try to inhibit the screensaver. However, if you pause and then resume the video, it will inhibit as expected

affects: gnome-screensaver (Ubuntu) → totem (Ubuntu)
Changed in totem (Ubuntu):
importance: Medium → Low
Chris Coulson (chrisccoulson) wrote :

I've uploaded a fix for this to Maverick. Will send this upstream when I start work again on Mondat

Changed in totem (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 2.31.90-0ubuntu2

---------------
totem (2.31.90-0ubuntu2) maverick; urgency=low

  * Fix LP: #630753 - gnome-screensaver activates while watching a movie
    in totem. Attempting to inhibit the screensaver before running the main
    loop will always fail, because the DBus proxy will not be setup yet,
    and the X11 fallback doesn't do anything in Ubuntu
    - add debian/patches/08_scrsaver_startup_inhibit.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Fri, 24 Sep 2010 23:12:06 +0100

Changed in totem (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers