Totem unable to play youtube videos

Bug #609855 reported by Frederik Elwert on 2010-07-25
182
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
totem (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: totem

Using Ubuntu 10.04 and Totem 2.30.2

When doubleclicking on a YouTube search result, a dialog pops up saying:

An error occurred
Could not open location; you might not have permission to open the file.

In the terminal, the following error message is printed:

** Message: Error: "http://www.youtube.com/get_video?video_id=y9Xtn_KwsW4&t=vjVQa1PpcFOreYC64yTLRY9InBddsNr0ZpPtX0lhKc4%3D&fmt=18": Not Found
gstsouphttpsrc.c(1096): gst_soup_http_src_parse_status (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin0/GstSoupHTTPSrc:source:
404 Not Found

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: totem 2.30.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-9.14~lucid1-generic-pae 2.6.35-rc5
Uname: Linux 2.6.35-9-generic-pae i686
Architecture: i386
Date: Sun Jul 25 22:38:08 2010
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.utf8
 SHELL=/bin/bash
SourcePackage: totem

Kenobi (kazmirzak) wrote :

The same with me. Cannot play any youtube video in Totem, same message. Youtube on Firefox runs well.

Linux Mint 9, Totem 2.30.2

description: updated
Gabor Kelemen (kelemeng) wrote :

Happened to me too, confirming. Also, I see this on the terminal several times:

$ totem
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:accessControl action="comment" permission="allowed"/>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:accessControl action="videoRespond" permission="allowed"/>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:accessControl action="rate" permission="allowed"/>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:accessControl action="embed" permission="denied"/>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:accessControl action="syndicate" permission="denied"/>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:accessControl action="commentVote" permission="allowed"/>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:accessControl action="list" permission="allowed"/>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:rating numDislikes="5217" numLikes="82306"/>

Changed in totem (Ubuntu):
status: New → Confirmed
mannonixa (rooske2) on 2010-07-27
Changed in totem (Ubuntu):
assignee: nobody → mannonixa (rooske2)
mannonixa (rooske2) on 2010-07-27
Changed in totem (Ubuntu):
assignee: mannonixa (rooske2) → nobody
mannonixa (rooske2) wrote :

confirm, same messages in terminal

Changed in totem (Ubuntu):
assignee: nobody → Mirsal Ennaime (mirsal-ennaime)
status: Confirmed → In Progress
Mirsal Ennaime (mirsal-ennaime) wrote :
Changed in totem (Ubuntu):
assignee: Mirsal Ennaime (mirsal-ennaime) → nobody
status: In Progress → Confirmed
Changed in totem:
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

confirmed, the git change leads to a 403 error

Changed in totem (Ubuntu):
importance: Undecided → Low
Mirsal Ennaime (mirsal-ennaime) wrote :

Excerpt from an IRC conversation with a totem developer:

<mirsal> Does the youtube plugin work in master ?
<pwithnall> Yes, but only if you use giosrc rather than souphttpsrc
<mirsal> How can i use giosrc ?
<pwithnall> You'd need to change the ranking of your GStreamer elements

Maui Muc (stefan-mauerberger) wrote :

Sorry, but I have to report that playing Youtube on Totem isn't working. Within all updates including proposed, the error is still the same.

But I must also confess that I have no idea how to switch from souphttpsrc to giosrc. Could somebody please explain how to?

hormosapiens (hormosapiens) wrote :

same here. it was a good solution for me cause flash player in FF kills my celeron cpu.

please fix it soon. thanks a lot

Jaysam Bayron (jayas16) wrote :

Hi,
I am also getting same error. I cannot play youtube videos directly from my Movie Player 2.30.2.
Hope this will be fix soon, can't wait to use this awesome app.

thanks..

Changed in totem (Ubuntu):
status: Confirmed → Triaged
B. Clausius (barcc) wrote :

Hi, I have applied the patch from git://git.gnome.org/totem,
commit 50027abd715acc24978e7830162c70c7e1a05811
to the totem package in lucid.
I have made a debdiff and debs are in my PPA:
https://launchpad.net/~barcc/+archive/ppa

Sebastien Bacher (seb128) wrote :

does the backport fix the issue?

  Thanks B Clausius, I updated four totem packages on my system with the
ones from your ppa and this solved the issue. --> I can use the youtube
plugin in totem again to watch the clips. :-)

--
Diese Mail wurde mit GnuPG/PGP signiert und/oder verschlüsselt.
This e-mail was signed and/or encrypted with GnuPG/PGP.

On 10.09.2010 12:18, Sebastien Bacher wrote:
> does the backport fix the issue?
>

tags: added: patch
Trigger (n00b61-2) wrote :

B Clausius` updated packages work just great for me.
YouTube works again, I can search and play videos.

Good job B Clausius :D

Jens Maucher (jensmaucher) wrote :

I can search videos, but when i try to play them i just see a black screen.. no video, no sound.

Can see videos from files?
/Thomas

On 11 sep 2010 15:45 "Jens Maucher" <email address hidden>
<email address hidden> wrote:

> I can search videos, but when i try to play them i just see a black
> screen.. no video, no sound.
>

Jens Maucher (jensmaucher) wrote :

Do you mean local saved *.flv videos from youtube? Yes i can.

B. Clausius (barcc) wrote :

@Jens
Some file are not streamed, but stored in /tmp/totem-* and played by totem if fully downloaded. This can take a long time. Please look at /tmp/ directory, whether there is such a file with increasing size. If so, that's a problem not related to this bug.

Jens Maucher (jensmaucher) wrote :

Ok, thank you.

Pedro Villavicencio (pedro) wrote :
Pedro Villavicencio (pedro) wrote :

the issue is still there, talked to upstream and opened a new bug here: https://bugzilla.gnome.org/show_bug.cgi?id=629692 ; feel free to subscribe to it, thanks.

Changed in totem:
status: Fix Released → Unknown
Changed in totem:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in totem:
status: Confirmed → Incomplete
Changed in totem:
status: Incomplete → Unknown
Pedro Villavicencio (pedro) wrote :

looks to be caused by the fluendo plugins, could you try to remove that set of plugins and try to play the videos again? worked fine here after removing those. Thanks.

Changed in totem (Ubuntu):
status: Triaged → Incomplete

Me, I don't have those plugins installed. So not my case...

Pedro Villavicencio (pedro) wrote :

could you get a debug log then? thanks.

I'm not really sure if this is what I was expected to do, I ran the command "totem --debug" in the terminal and this is the output. Is this what u need?

Pedro Villavicencio (pedro) wrote :

we need one with gstreamer symbols, please run it as: GST_DEBUG_NO_COLOR=1 GST_DEBUG=5 totem &> totem-debug.txt ; compress that resulting file and attach it to the report, thanks. which version of Ubuntu are you running there?

Here it is, hopefully correct now... I'm running 10.04. And I also use pulseaudio with pulseaudio-equalizer.

scribe63 (scribe6324) wrote :

I am having this same issue on 10.04 64 bit.

My GST_DEBUG_NO_COLOR=1 GST_DEBUG=5 totem &> totem-debug.txt is attached.

I tried totem_plugins_youtube.py.patch patch, but there is no /usr/lib/totem/plugins/youtube/youtube.py.

When I run the patch I get the error
Hunk #1 FAILED at 337.
1 out of 1 hunk FAILED — saving rejects to file /usr/lib/totem/plugins/youtube/youtube.py.rej
Any ideas ?

I understand this works in 10.10, is there a backport, what gives.

John O (jplo) wrote :

Running 10.10, and no joy with totem and youtube. It handles other videos fine though.

Fabio Marconi (fabiomarconi) wrote :

I'm closing this report as Fix released, if someone still experiencing this issue, please run in a terminal ubuntu-bug fluendo to open a new updated report.
Thanks
Fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in totem (Ubuntu):
status: Incomplete → Fix Released
affects: totem → ubuntu
Changed in ubuntu:
importance: Medium → Undecided
status: Unknown → New
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.