.smi files are not played correctly

Bug #605370 reported by Walter Cheuk on 2010-07-14
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Totem
Expired
Wishlist
totem (Ubuntu)
Low
Unassigned

Bug Description

Some parameters within .smi files are not parsed correctly, both in Totem and gnome-mplayer. To be specific, the clip-begin and clip-end tags are not honoured. Attached is an example file.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: libgstreamer0.10-0 0.10.29.4-1
ProcVersionSignature: Ubuntu 2.6.35-7.12-generic 2.6.35-rc4
Uname: Linux 2.6.35-7-generic x86_64
Architecture: amd64
Date: Wed Jul 14 19:17:39 2010
ExecutablePath: /usr/bin/totem
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100630.2)
ProcEnviron:
 LANGUAGE=zh_HK:zh_TW:zh
 LANG=zh_HK.utf8
 SHELL=/bin/bash
SourcePackage: gstreamer0.10

Walter Cheuk (wwycheuk) wrote :
bbordwell (benbordwell) wrote :

Could you please describe the expected behavior for this file? When I open the file I get an audio stream in totem, what is this file supposed to do differently?

Changed in gstreamer0.10 (Ubuntu):
status: New → Incomplete
Walter Cheuk (wwycheuk) wrote :

The first 4 minutes should be skipped (as described by the 'clip-begin' tag). Now the stream just start from the very beginning.

Changed in gstreamer:
status: Unknown → New
bbordwell (benbordwell) wrote :
Changed in gstreamer0.10 (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Low
Changed in gstreamer:
importance: Unknown → Medium
Changed in gstreamer:
status: New → Unknown
Changed in gstreamer:
status: Unknown → Invalid
Walter Cheuk (wwycheuk) wrote :

Why the bug is set to invalid? Any more info is needed? Please let me know.

bbordwell (benbordwell) wrote :

Walter, the bug is not invalid, just some shuffling around because it turns out this is a totem bug and not a gstreamer bug.

Changed in gstreamer:
importance: Medium → Unknown
status: Invalid → Unknown
affects: gstreamer0.10 (Ubuntu) → totem (Ubuntu)
affects: gstreamer → totem
Changed in totem:
importance: Unknown → Wishlist
status: Unknown → Confirmed
Neal McBurnett (nealmcb) wrote :

A real-world example at a popular site is the "listen" link at:

 "A Prairie Home Companion: May 6, 2006 - Moonlight on the Colorado River lyrics"
  http://prairiehome.publicradio.org/programs/2006/05/06/scripts/moonlight.shtml

See also the links and discussion at "How to play realmedia / SMIL / rtsp audio references with start/end points - Ask Ubuntu"
 http://askubuntu.com/questions/92088/how-to-play-realmedia-smil-rtsp-audio-references-with-start-end-points

Changed in totem:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.