Ubuntu

Totem does not update ID3 tag data on streaming radio stations

Reported by Justin "J" Lynn on 2006-08-26
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Low
totem (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Totem correctly receives streaming audio metadata when stream is opened but does not update this data when the radio station changes songs.

Steps to reproduce
1.) Open totem with nothing in the playlist
2.) Add location http://205.188.215.232:8012 or any other streaming radio station (using ID3 metadata)
3.) Observe that as the song changes totem does not update the metadata. (artist, song title, etc)

Miscellanious information
Tested with multiple stations that correctly update metadata in winamp player

Related branches

Sebastien Bacher (seb128) wrote :

Thanks for your bug. Do you use totem-gstreamer or totem-xine? What version of Ubuntu do you use?

Changed in totem:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
Justin "J" Lynn (jaesharp) wrote :

Sorry aobut not providing those specs. ^_^

Ubuntu Dapper (latest updates from canonical have been applied)
totem-gstreamer

Sebastien Bacher (seb128) wrote :

Do you still have a that issue? Could you point a new example, the one from the description seems to be working at the moment

Daniel Holbach (dholbach) wrote :

As described in the previous comments, your report lacks the information we need to investigate the problem further. We'll close this report for now - please reopen it if you can give us the missing information.

Changed in totem:
status: Needs Info → Rejected

I can confirm this bug
From Ubuntu Feisty - 2.18.1, example stream: http://207.200.96.231:8012 (soma fm)

Changed in totem:
status: Rejected → Unconfirmed
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

Using http://207.200.96.231:8012 the title in the properties sidebar change correctly when the track change on my desktop. Could you give details on your problem?

Changed in totem:
importance: Undecided → Low
status: Confirmed → Needs Info

Did you wait until the songs change?

On 5/17/07, Sebastien Bacher <email address hidden> wrote:
>
> Using http://207.200.96.231:8012 the title in the properties sidebar
> change correctly when the track change on my desktop. Could you give
> details on your problem?
>
> ** Changed in: totem (Ubuntu)
> Importance: Undecided => Low
> Status: Confirmed => Needs Info
>
> --
> Totem does not update ID3 tag data on streaming radio stations
> https://bugs.launchpad.net/bugs/57786
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Konrads Smelkovs
Applied IT sorcery.

Sebastien Bacher (seb128) wrote :

yes, the title change correctly

Changed in totem:
status: Incomplete → New
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Also the issue that you reported is one that should be reproducable with the live environment of the Desktop CD of the development release - Gutsy Gibbon. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in totem:
status: New → Incomplete
mtvoid (mtvoid) wrote :

I can confirm the bug too. I don't know why Totem seems to work fine for Sebastian, but I've never seen Totem change the track name when a stream is playing. It picks up the name of the currently playing track when starting, and sticks with it throughout, even after it's finished playing. Other players I've tried, like rhythmbox and gxine, do correctly change track titles.
I'm currently using the latest totem-gstreamer from gutsy. Is there any useful info that I can provide to debug the problem?

Pedro Villavicencio (pedro) wrote :

Thanks, would be nice if someone getting this problem can forward this bug upstream.

Changed in totem:
status: Incomplete → New
mtvoid (mtvoid) wrote :

I've added the bug report to GNOME's Bugzilla: http://bugzilla.gnome.org/show_bug.cgi?id=471233
I hope it's not a duplicate...
I've referenced the bug report here in Launchpad too.

Changed in totem:
status: New → Triaged
Changed in totem:
status: Unknown → New
Changed in totem:
status: New → In Progress

I am running ubuntu 8.04 beta 4 and I am having the same issue. It would be nice to have this fixed.

Jonathon Conte (thesicktwist) wrote :

Let me clarify what I believe to be the correct description of this bug. Totem (using the gstreamer backend) does update the row labeled "Title" in the sidebar, but it does not update its window's title bar when playing a stream. When one views the window's name via pressing ALT+Tab, glancing at gnome-panel or looking at the window itself, one always sees the song title of the first song that started playing.

Tomas Borovsky (tborovsky) wrote :

I am running Ubuntu 8.04.1 and Totem Movie Player 2.22.1 and I am having the same issue. It would be nice to have this fixed.

tankdriver (stoneraider) wrote :

confirm. (8.04.1 64-bit gstreamer)

Changed in totem:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 2.23.91-0ubuntu1

---------------
totem (2.23.91-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    - Numerous UI and bug fixes (lp: #246535)
    - DVB playback:
      - Add support for a helper to setup DVB channels
      - Support multiple DVB adapters
      - Better DVB error messages
    - New features:
      - Allow '+' and '-' to go to the previous/next tracks
      - Make the LIRC plugin work out-of-the-box on a majority of remotes,
        and add support for the Stop key
      - Add a Python console plugin
    - Movie player:
      - Require a newer gmyth to support newer MythTV instances
      - UI fixes for the playlist and play buttons showing the wrong status
        on error
      - Fix restoring previous sessions
      - Don't resize the window in the middle of a stream, for example,
        when watching TV
      - Build fixes for Python and Vala plugin backends
    - Youtube plugin:
      - Fix webpage URLs getting added to the playlist, rather than movies
        themselves
      - Don't eat the CPU when searching for videos
      - Blacklist the ffmpeg FLV demuxer, and popup the plugin installation
        helper if no other demuxers are available
    - GStreamer backend:
      - Fix possible drifts in the colour balance (lp: #216820)
      - Fix the UI not updating for internet radio titles when streaming
        (lp: #57786)
      - Add support for ATSC
      - Update visualisations aspect ratio when the screen size changes
  * debian/control.in:
    - updated libgtk and libtotem-plparser requirements

 -- Sebastien Bacher <email address hidden> Wed, 03 Sep 2008 16:32:13 +0200

Changed in totem:
status: Triaged → Fix Released
Changed in totem:
importance: Unknown → Low

I still have this bug when listening to somafm.com playlists, e.g. this station:
http://streamer-mtc-aa01.somafm.com:80/stream/1021

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.