Mozilla plugin fails to start due to unresolved symbols

Bug #56333 reported by Nicolas DERIVE on 2006-08-14
4
Affects Status Importance Assigned to Milestone
totem (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem-mozilla

I have to use mplayer-mozilla plugin (who works perfectly) instead of totem-mozilla one because the totem plugin provokes a crash of firefox bon echo beta 2, immediately after this plugin launches. Notice that totem-mozilla plugin is now by default in Ubuntu Edgy (by the ubuntu-desktop metapackage).

Nicolas DERIVE (kalon33) on 2006-08-14
description: updated
Matt Zimmerman (mdz) wrote :

This is due to unresolved symbols, as described in bug #56085:

mizar:[/etc] ldd -r /usr/lib/totem/libtotem-basic-plugin.so
        linux-gate.so.1 => (0xffffe000)
        libgnomevfs-2.so.0 => /usr/lib/libgnomevfs-2.so.0 (0xb7f86000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb7e74000)
        libgnutls.so.13 => /usr/lib/libgnutls.so.13 (0xb7e07000)
        libtasn1.so.3 => /usr/lib/libtasn1.so.3 (0xb7df3000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb7ddf000)
        libgcrypt.so.11 => /usr/lib/libgcrypt.so.11 (0xb7d91000)
        libnsl.so.1 => /lib/tls/i686/cmov/libnsl.so.1 (0xb7d7b000)
        libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0xb7d77000)
        libavahi-glib.so.1 => /usr/lib/libavahi-glib.so.1 (0xb7d74000)
        libavahi-client.so.3 => /usr/lib/libavahi-client.so.3 (0xb7d64000)
        libavahi-common.so.3 => /usr/lib/libavahi-common.so.3 (0xb7d59000)
        libresolv.so.2 => /lib/tls/i686/cmov/libresolv.so.2 (0xb7d46000)
        libutil.so.1 => /lib/tls/i686/cmov/libutil.so.1 (0xb7d42000)
        libgconf-2.so.4 => /usr/lib/libgconf-2.so.4 (0xb7d12000)
        libpopt.so.0 => /lib/libpopt.so.0 (0xb7d0b000)
        libORBit-2.so.0 => /usr/lib/libORBit-2.so.0 (0xb7cbb000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb7c84000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb7c81000)
        libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7c7d000)
        libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb7c79000)
        libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7c66000)
        libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0xb7c49000)
        libdbus-1.so.2 => /usr/lib/libdbus-1.so.2 (0xb7c12000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb7b84000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7aa9000)
        libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7a83000)
        libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb794d000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7941000)
        /lib/ld-linux.so.2 (0x80000000)
undefined symbol: NS_CStringContainerInit (/usr/lib/totem/libtotem-basic-plugin.so)
undefined symbol: NS_Alloc (/usr/lib/totem/libtotem-basic-plugin.so)
undefined symbol: _ZN8nsMemory5CloneEPKvj (/usr/lib/totem/libtotem-basic-plugin.so)
undefined symbol: NS_CStringGetData (/usr/lib/totem/libtotem-basic-plugin.so)
undefined symbol: NS_Free (/usr/lib/totem/libtotem-basic-plugin.so)
undefined symbol: NS_CStringContainerFinish (/usr/lib/totem/libtotem-basic-plugin.so)
undefined symbol: NS_CStringSetData (/usr/lib/totem/libtotem-basic-plugin.so)

Changed in totem:
importance: Untriaged → High
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

This upload fixes the issues:

 totem (1.5.91-1ubuntu3) edgy; urgency=low
 .
   * debian/patches/01_build_mozilla_plugin_with_xpcom.dpatch:
     - link with libxpcom since the new firefox stop doing that (Ubuntu: #56333)

Changed in totem:
assignee: nobody → desktop-bugs
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers