GStreamer encountered a general supporting library error.

Bug #544660 reported by Christoph Korn on 2010-03-22
184
This bug affects 35 people
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Medium
totem (Ubuntu)
Low
AX
Nominated for Lucid by Seth Kriticos

Bug Description

I searched for "blackened" with the YouTube plugin and got this error:
GStreamer encountered a general supporting library error.

The terminal output is:
** Message: Error: GStreamer encountered a general supporting library error.
gstffmpegdemux.c(1243): gst_ffmpegdemux_open (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20/ffdemux_swf:ffdemux_swf0:
Input/output error

ProblemType: Bug
Architecture: amd64
Date: Tue Mar 23 00:13:50 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/totem
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
NonfreeKernelModules: nvidia
Package: libgstreamer0.10-0 0.10.28-1
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: gstreamer0.10
Uname: Linux 2.6.32-16-generic x86_64

Related branches

Christoph Korn (c-korn) wrote :
Fatih Bostancı (fbostanci) wrote :

I can confirm this bug.

10.04 32 bit.

Seth Kriticos (seth-kriticos) wrote :

I can confirm this bug on 9.10 (64bit) and 10.04 beta1 (32bit) too.

YouTube seems to have changed their site just recently and globally broke the totem YouTube plug-in on both, my Karmic box and my Lucid virtual machine.

As this plug-in is installed by default on Lucid, this should either be fixed before final release or moved from the totem-plugins to the totem-plugins-extras package (which is not installed by default) and fixed later.

Seth Kriticos (seth-kriticos) wrote :

Ps. Pretty sure it's not a library issue. The plug-in was not touched since 5 months on my host system and worked only a few days ago, but drops the error now.

Here is the date from the last update:

ls -l /var/lib/dpkg/info/totem-plugins.list
-rw-r--r-- 1 root root 3342 2009-11-24 19:52 /var/lib/dpkg/info/totem-plugins.list

Changed in gstreamer0.10 (Ubuntu):
status: New → Confirmed
Lemmiwinks (lemmiwinks) wrote :

I get the same error, since today no video seems to work anymore. Before, there where only a few which brought up that error message.

Lemmiwinks (lemmiwinks) wrote :
Richard (richard-njoyscience) wrote :

I used to be able to watch YouTube on Totem, then a while back started getting the odd video with "GStreamer encountered a general supporting library error." error. Now they all seem to give that error. Just Googling around, it looks like a YouTube server side change?

This occurs for me as well.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, youtube changed their website again and totem needs to be update, see https://bugzilla.gnome.org/show_bug.cgi?id=614679, the change will be uploaded soon to lucid

affects: gstreamer0.10 (Ubuntu) → totem (Ubuntu)
Changed in totem (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Committed
affects: totem (Ubuntu) → gstreamer0.10 (Ubuntu)
affects: gstreamer0.10 (Ubuntu) → totem (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 2.30.0-0ubuntu3

---------------
totem (2.30.0-0ubuntu3) lucid; urgency=low

  * debian/patches/91_git_youtube_regex.patch:
    - git change to fix youtube video playing issues to website change
      (lp: #544660)
  * debian/patches/92_git_trailer_apple.patch:
    - git change to fix playing on the trailers.apple.com website
      (lp: #431817)
 -- Sebastien Bacher <email address hidden> Wed, 07 Apr 2010 00:39:37 +0200

Changed in totem (Ubuntu):
status: Fix Committed → Fix Released
Changed in totem:
status: Unknown → Fix Released
AX (bimbo357) on 2010-04-20
Changed in totem (Ubuntu):
assignee: nobody → AX (bimbo357)
Changed in totem:
importance: Unknown → Medium
Jan Skala (101speirs) wrote :

Hello, this has error occurred on my and also my brother's PC. I use Totem 2.32.0 and GStreamer 0.10.30, Ubuntu 10.10 with latest update. While playing video from YouTube through Totem plugin.

Terminal output:

** Message: Error: V GStreamer došlo k chybě obecné podpůrné knihovny.
gstffmpegdemux.c(1255): gst_ffmpegdemux_open (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin1/GstDecodeBin2:decodebin21/ffdemux_swf:ffdemux_swf1:
Input/output error

(Message means: "GStreamer encountered a general supporting library error." as in first post.)

Federico Ruggiero (fedd) wrote :

I get same error.

Terminal output:

** Message: Error: GStreamer ha incontrato un errore generico nelle librerie di supporto.
gstffmpegdemux.c(1255): gst_ffmpegdemux_open (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20/ffdemux_swf:ffdemux_swf0:
Input/output error

It seems that youtube has updated the site and consequently the plugin does not work anymore.

I use ubuntu 10.10 64 bit version all updated.

Yes same for me, on both 10.10 amd64 and 10.04 32bit.

Krack (krack3rz) wrote :

I got the same problem, it says: "GStreamer encountered a general supporting library error."
Using Ubuntu 10.10 all latest updates.

I'm quite new, i see it says "fix released" here but i cannot find it, does that mean its in the update database or w.e?
Or is this problem not fixed yet?

Martin-Éric Racine (q-funk) wrote :

The problem returns every time Google changes its mind about the YouTube API.

kuh3h3 (kuh3h3) wrote :

for me same error.
maybe recent totem(2.32.2)ubuntu 11.04 also failed to fix GStreamer error.
old error reoccured.

jovan dragisic (jdragisic) wrote :

same here, totem 2.32.0, gstreamer 0.10.30 on maverick i686. way to go, youtube.
output:

** Message: Error: GStreamer encountered a general supporting library error.
gstffmpegdemux.c(1255): gst_ffmpegdemux_open (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20/ffdemux_swf:ffdemux_swf0:
Input/output error

peppe61 (newpeople) wrote :

Confermo errore: Riproduttore multimediale Totem 2.32.0 - Il riproduttore multimediale utilizza GStreamer 0.10.30
                                 Sistema operativo Ubuntu 10.10 ( linux-image-2.6.35-28 )

                                                                     Si è verificato un errore
                                                            GStreamer ha incontrato un errore
                                                             generico nelle librerie di supporto.

galess (galess) wrote :

I got the same error
version: Ubuntu 10.4 32 bit
totem 2.30.2
Linux 2.6.32-36-generic-pae #79-Ubuntu SMP Tue Nov 8 23:25:26 UTC 2011 i686 GNU/Linux

** Message: Error: GStreamer encountered a general supporting library error.
gstffmpegdemux.c(1255): gst_ffmpegdemux_open (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin2/GstDecodeBin2:decodebin22/ffdemux_swf:ffdemux_swf2:
Input/output error

Pom (pom4pom) wrote :

If I read these posts correctly, there is no fix at this time (April, 2012), correct?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.